Jump to content
richschmidt

mac System Requirements and Download Links for various versions of EN for Mac

Recommended Posts

I have a bit of a frustration. I can't seem to find system requirements listed anywhere for Evernote. It's nowhere on the main site, that I can see. (Searching the Knowledge Base brings up two old and conflicting articles.) Plus, I know there are old versions available for download for those with older versions of OS X, but they're extremely difficult to find. (The search feature on these forums isn't much help.)

Could someone post a list of the various versions available for download, as well as their system requirements?

And then, at some point, could someone who works for Evernote make that list available outside these forums?

  • Like 1

Share this post


Link to post

The App Store says

Requirements:

OS X 10.6.6 or later

I would imagine the direct download is the same.

Share this post


Link to post

The App Store says

Requirements:

OS X 10.6.6 or later

I would imagine the direct download is the same.

Ok. So that's for the current version. Thanks. What about older versions? I know there are versions available that work on OS X 10.5, for example, because when I download it on my older MacBook Pro, that's what the download link gives me.

I've seen direct links to older versions on the forums. It'd be helpful to have a list, along with the system requirements. And, of course, it'd be nice to have system requirements actually listed on the Evernote website so users don't have to guess.

  • Like 1

Share this post


Link to post

I agree with the original poster.  I know it's been years since his post but the system requirements are nowhere to be found, still!  I find this quite irritating from any software company.  Yeah the front page looks slick but you gotta "show me the Motts!"at some point...

  • Like 1

Share this post


Link to post

Agree with the frustrations.  It is unfathomable that no system requirements are posted.  Just trying to start using with my Note 4 and and imac.  Running OSX10.6.8, and can't find a version that will work with that OS.  Of course after downloading it and installing it once already only to be told AFTERWARDS, that it is incompatible with anything less then 10.7.5.

 

Bad why to start, and it wouldn't take much to provide a user with that information before downloading.  The fact that these thread has been here for years and nothing has ever been done to correct it does tell you something.

  • Like 1

Share this post


Link to post

The message I got from Evernote a few weeks ago basically said that the system requirements are listed on the Mac App store as mentioned earlier in this thread.  They even sent me a jpg screen capture from the App store showing the requirements for the latest version.  Apparently they still don't see any reason to publish it on the Evernote site.  I'm also not sure what other versions might be available for download from Evernote anyway.  

btw, I have a mac running 10.6.8 that has Evernote 5.5.2 installed and running.  I suspect that it is the last version available for Snow Leopard.  In my opinion, there are other reasons to move a computer from 10.6.8 as well (the lack of security updates etc).  I know that's not possible with older machines depending on the vintage but time does keep pushing ahead and you have to shift at some point. 

Share this post


Link to post

I very much agree with the original poster.... here we are years after his original post and STILL it is seemingly impossible to find what should be a simple answer to what is the latest version I can install on Mavericks 10.9.5 and how to find this version to download and install.  Apple Genius Bar recently wiped the hard drive on my older MacBook Pro and installed 10.9.5 since they felt a newer version would cause this machine to run slower (mid 2010 machine with 8 GB RAM).

The version of Eudora currently available requires OS/X 10.10 or higher, and while you can download and install it, it will the  have a circular icon with a diagonal line across it, and if you try to run it you get a message that it can't be run as it requires 10.10 or higher.

How can I find the latest version that WILL run on OS/X 10.9.5

Share this post


Link to post
On 25.3.2017 at 12:43 AM, biyahero said:

I very much agree with the original poster.... here we are years after his original post and STILL it is seemingly impossible to find what should be a simple answer

How can I find the latest version that WILL run on OS/X 10.9.5

Evernote stil ignores cry for help of customers. This is no good polocy. I also want to know which version of Evernote is the right one for OSX 10.9.5. Will I - or all the others - ever get an answer? Or will evernote ever put this information on its homepage?

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...