Jump to content
  • 0

(Archived) Attachments not synced on mac


gaurki

Idea

Hello,

I have been using Evernote to store an excel spreadsheet as an attachment to a note that I regularly access and update from 4 different devices (Windows XP, Windows Vista, Windows 7, and Mac Lion 10.7.5). I typically edit the file in OpenOffice.Org's Calc program since it's also cross-platform and I don't have to deal with Microsoft's *****.

All has been good until recently. When I double-click the attachment on the Mac Lion device it opens an older version of the attached file from a week ago, even though all notes are synced and current.

I noticed when I open the attachment on the windows devices it will add a new number to the name, i.e, attachment[1].ods, every time I open it. On the Mac it is always just attachment.ods no matter how many time I open it. So, could it be reopening the same old file from a Mac temp folder instead of re-downloading the attachment from the Evernote cloud?

And if so, anyone know how to clean out old Evernote temp files on a mac?

Link to comment

10 replies to this idea

Recommended Posts

This problem, or versions of it, has apparently been causing difficulty for some time. There are warnings about this spread around these forums going back to at least 2010. A recent one here: http://discussion.evernote.com/topic/49435-managing-workflows-any-advice/?p=249151

... and an older one helpfully offered up by support itself: http://discussion.evernote.com/topic/25808-what-is-ens-live-update-feature/?p=137603

 

Yet, what we are trying to do is precisely what is described in/as "coordinating projects" by Evernote (the most recent publicity communication I received promoting this just today).

 

Documents contained in notes do not reliably sync when they are edited. We "stumbled" onto this difficulty when just two of us were trying to collaborate on edits to a Microsoft Word document. Not only would edits not appear in the synced note in the notebook shared with another user, they also would not appear in the synced account of the same user on another device. After lengthy correspondence with support, the question has not been resolved (we are now waiting for testing from the QA team). 

 

In fact, the Evernote application does not reliably and accurately keep the status of a document contained in the local database.

 

I "re-created" almost all of the difficulties that have been described here and elsewhere a couple of days ago, starting from a completely clean install of the desktop application and re-download of the local database and a new notebook, note and word document (courtesy of Microsofts "term paper" template ... which I took as an example of a pretty bland kind of document type). This little exercise was performed with two late-model MacBook Pros, current OS, current versions of Evernote, etc. 

 

1. create a new Word document from the template ("Lorem Ipsum....") and move into an Evernote note. Sync. 

2. Login from another device. Sync. New note and document appears. So far, so good.

3. Share notebook with another user. Login as that user. Sync. New note and document appears. So far, so good.

3. Edit document in the original device and Evernote application, save. Sync. Re-open document. Edits are preserved

3a. Clue that things aren't unfolding well: the "updated" time stamp has not changed in the live environment. In other words, a problem with the "Live Update" in the very first instance.

4. Evernote from another device, same user account. Sync. Only the original note appears.

5. Evernote from another user account. Sync. Only the original note appears. 

6. Wait an hour or so. No change.

7. Change the note title in the original device and Evernote application (without editing the underlying note). Sync. Updated time stamp moves to current time. Re-open the document and the edited document appears.

8. Evernote from another device and/or another user. Sync. Updated time stamp and note title appear. Hey, something changed! Open underlying document: only the original is present.

8a. So now, you have Evernote reporting updated material, but that is a false positive.

9. Return to original device and Evernote application. Re-open document. Make edits that substantially change the file size. Save. Sync. Re-open document. Newly edited document appears.

9a. Uh-oh, no change in time-stamp. Little "meta" popup on the "Word" file icon shows new edit time, but no change in file-size of the Word doc (the actual document size changed from nearly 1MB to around 600k, large enough to notice?)

 

Post mortem: even a couple of days later, the version of the document on other devices and in other share accounts (as well as that shown in the web access) has not changed. 

 

While I have not taken the time to do the same sequential build-up of testing, we have now encountered similar problems in other instances. Edits to Excel spreadsheets. Changes to pdf documents with form fields. Loss of content (the underlying edited Word doc file became an "unknown file" of 0k)  when moving a note from one notebook to another.

 

I'd guess that the underlying local database does not play well with files in their "native" form. When opening a word doc, much less documents in other applications, a variety of "auto-save" and temporary files features and behaviors are present. The desktop application database seems to have difficulty with that and if it does not manage its content well, hard to see how the sync would keep up unless the whole thing is uploaded each time. (See 3a ... examples of this being a difficulty run back to 2009  http://discussion.evernote.com/topic/6601-document-live-update/#entry32761 ).

 

And, of course, there are those document types that Evernote does not handle at all.

 

From my experience, Evernote is a static "post once" resource only. 

 

Tom

Link to comment

I'm using Evernote Version 3.0.6 (221382). Can't remember if I direct-downloaded it or got it from the app store.

I haven't had any error messages and the rest of my notes are synced fine. This is my only attached file, however.

249.5 KB out of 60 MB used

Link to comment

It gets worse. I "synced" the Mac version of EN to try to make it download the new version of the file. Instead, it replaced the new version on the Cloud with the old version from a week ago that is stuck on the Mac, in effect deleting a week's worth of changes. Disappointing, will have to move my files to a different cloud service until this is resolved.

Link to comment
  • Level 5*

I'm having this same problem and am trying to get my office using Evernote. This hiccup has made the rest of the office gun shy of using Evernote :-(

I use Mac and have the latest version.

Hi. Welcome to the forums.

Could you tell us the version number of your application, and could you tell us if you downloaded it from the app store or not? If it is the app store version (most likely), you might want to try working with the Evernote direct downloaded version instead. Here is a link to instructions.

http://discussion.evernote.com/topic/16062-uninstalling-everrnote-for-mac-os-x/#entry173494

Link to comment

GrumpeyMonkey - thanks for the info, but I uninstalled completely, downloaded from the site, and the spreadsheet (Excel) will still not update. The other parts of the note will, but not the spreadsheet.

I'm using version 5.0.4 and the new Evernote for Business

Link to comment
  • Level 5*

GrumpeyMonkey - thanks for the info, but I uninstalled completely, downloaded from the site, and the spreadsheet (Excel) will still not update. The other parts of the note will, but not the spreadsheet.

I'm using version 5.0.4 and the new Evernote for Business

That does sound odd. I think if you contact the business customer service rep at Evernote, they will be able to help out the most quickly. In the meantime, I'd definitely try putting the Excel file into another note, or even emailing it to your account to see if that gets it to sync.

Link to comment

Archived

This topic is now archived and is closed to further replies.

Guest
This topic is now closed to further replies.
×
×
  • Create New...