Jump to content

(Archived) Evernote Clipper and Safari 6


Recommended Posts

I've had Evernote for a few years now, but got a new Mac in April, and it just doesn't work for me anymore! Loved it when it worked, but the Web Clipper does nothing on this computer. I have downloaded the latest version supposedly for Safari, but I never get a screen like I've seen on some of the blogs....and what I have simply does nothing at all.

How do I get this to work? If I try to copy and paste, even that gets messed up - it looks like sometimes the entire block of text goes into the title or something, and the page stays blank when I do it that way.

So, since I've paid up again, I need to figure this out. Can anyone help?

Occasionally I get the message that I have to sign in to the clipper - but I sure don't know where that is or why I would have to do that every time.


Adding: I also just realized that even though I downloaded the Clipper from the Evernote website, the little elephant icon looks different than what it should be...nothing around it, no "stamp, just plain elephant. Does that indicate something...like an old version or something? How would I check and why is it doing that if it comes from the website???

Link to comment

Okay, I know this is so uncool, but I'm going to follow up on my own post.

It's amazing what a little complaining here will do....I just got it to work for the first time EVER on this Mac.

Here's the solution for others with a similar issue: I had to uninstall the old clipper, and I did this through Safari. I wondered if that was the deal but never could figure out where it was!

My interface still doesn't look like what I've seen on the blogs - can't figure that part out - but it DOES work and that's the bottom line!

Link to comment
  • 2 weeks later...


This topic is now archived and is closed to further replies.

  • Create New...