Jump to content

(Archived) Broken Links and UPDATE on SKITCH.COM!


asiajason

Recommended Posts

Really. Skitch told me I had an update (1.09, to ver 2.) and I did. When it loaded, it said I couldn't run it on 10.6.8. So I went a searching....

---------------------------------------------

Go to skitch.com

Go to the bottom. Click FAQ.

Broken

------------------------------------

And thats not all....trying to find a solution to my problem.... ran into another broken link!

Go to http://support.evernote.com

Go to the bottom. Click FORUM

Broken. (https instead it should be http)

Mac OS X 10.6.8,

Safari 5.1.7 AND Chrome v22 = Not a problem on my end.

Cmon guys... get your basics together. Long time happy user of both. Not tonight I'm not happy though.

Link to post

Hi,

Links:

Skitch -> FAQ - Yes, I see the same. I guess this page was lost in the migration or a move around on the Evernote website.

Support -> Forum - Again, I see the same.

I believe that this is an old link/page though. If you browser through the Evernote website to the support page, you end up here: http://evernote.com/contact/support/

This has a correct link.

How did you get to your version of the support page?


Your issue with skitch.

I can't find any info about minimum requirements. There may be, not sure.

You can find a download link to an older version on the skitch page though if necessary:

https://evernote.com/skitch/

Scott

Link to post

How did you get to your version of the support page?

I went to skitch.com, clicked "support" at the bottom. That brought me to a evernote support page. Clicked "forums" at bottom.

I can't find any info about minimum requirements. There may be, not sure.

You can find a download link to an older version on the skitch page though if necessary:

https://evernote.com/skitch/

Yes, there is. And thats where they dropped the ball major time. Allowing it to update to a version that doesn't work is not acceptable.

10.7 is required for the newest version on the app store, so it correctly doesn't show in the "updates" section.

But when I clicked "check for update" from within the app, it happily updated, which broke my copy.

Link to post

But when I clicked "check for update" from within the app, it happily updated, which broke my copy.

I just downloaded the previous version (1.0x) which is now 1.12, and it doesn't allow updating within the app. But for those on previous versions, *don't update from within the app*

Link to post

I went to skitch.com, clicked "support" at the bottom. That brought me to a evernote support page. Clicked "forums" at bottom.

Ok, so that page should be updated to show the correct (new) link. I guess the older pages should be updated to show the correct link to the forum as well, since they are still reachable.

I can't find any info about minimum requirements. There may be, not sure.

You can find a download link to an older version on the skitch page though if necessary:

https://evernote.com/skitch/

Yes, there is. And thats where they dropped the ball major time. Allowing it to update to a version that doesn't work is not acceptable.

10.7 is required for the newest version on the app store, so it correctly doesn't show in the "updates" section.

But when I clicked "check for update" from within the app, it happily updated, which broke my copy.

I am not familiar with how the mac deals with app updates etc. so I can't really comment on that issue, other than to say that, yes there should be a better handling of version compatibility.

Scott

EDIT: So 1.09 allowed you to update to an incompatable version, but 1.12 doesn't?

That is useful information. I hope Evernote find a way to avoid this somehow.

Link to post

Archived

This topic is now archived and is closed to further replies.

Guest
This topic is now closed to further replies.
×
×
  • Create New...