Jump to content
  • 0

(Archived) Evernote won't update or load on to my macbook



I used to have Evernote on my laptop. Once I upgraded to 10.7.4, it didn't work. I deleted it and have tried to reinstall it and it still doesn't work. I used this thing all the time. It still works on my iPad and iPhone. But it always takes me to the App Center on my macbook and then comes up as an update. But I'm not updating, I'm trying to reinstall it. It also says I have to login to the account I used to purchase it. It was free, first of all, and I only have one account so I have no idea what that means. It used to be my favorite app and now I'm so frustrated that i can't get it back on my system that it is quickly becoming my least favorite. Can anyone help me with this?


Link to comment

7 replies to this idea

Recommended Posts

  • Level 5*

Thanks. I totally tried that, though, and it automatically takes me to the App Store to download.

I apologise, as Grumps suggests this link was meant to stay up for direct download.

I'll send this thread to an Evernote person and see what they can do.

For something so simple, they seem to be making a right dog's dinner of allowing users to download a file from their website.

Link to comment
  • Level 5*

That link works fine for me here. Is it not sending you to the direct download file?

That link works fine for me here. Is it not sending you to the direct download file?

Hi. The link takes me to the Applestore.


[EDIT:] *sigh*. My mistake. I am using Safari (long story) and I guess the download was occurring automatically. All of the buttons and links take us to the Applestore, though. I think this is rather confusing myself (why not just have a link to the alternative version, like we see on the Skitch page?), but it is working, and that is what counts.

Link to comment


This topic is now archived and is closed to further replies.

This topic is now closed to further replies.
  • Create New...