Jump to content

(Archived) Evernote not Syncing: "serviceURL is null"


Recommended Posts

I just got a new tablet running Evernote 4.2. I'm having troubles with logging in on this device. I've changed my password and was able to sync just fine earlier today. Now I'm getting the error: "Login Error: A problem was encountered while communicating with Evernote. serviceUrl is null"

My phone can still sync and I can login online, even online from the tablet, just not in Evernote itself.

Please help!

I did attempt to submit a ticket from the tablet, but I'm not sure if it went through or not since I can't get logged in!

Link to comment

Hi FlyingGirl, welcome to the forum :)

You are probably on the right track trying to submit a support ticket. I can't seem to find any other topics about this error message, and it is not one that I recognise at least.

Did you receive an autoresponse EMail from Evernote with a ticket number?

If not, then the ticket submission didn't go through.

You may want to submit one via the website:


Once you get a ticket number, you know that it went through.


Link to comment

Hey FlyingGirl & Scott,

I have this same error. Was there any resolution on this issue, FlyingGirl?

I will see about submitting a ticket from my phone (evo 4g lte w/ ice cream sandwich). If I am unable to find a route on my phone, then I thank you for the link to submit one online, Scott.

Be well,


Link to comment

Update: I fixed this issue on my Android phone by force stopping EN and deleting all the cache + data, then starting up EN again.


I'm having this exact same issue on my phone + EN. Every time I enter my password to log into EN on my phone it gives me the serviceURL null message. If there's a way I can "+1" someone else's bug report I'll do so.

Link to comment

Update: I fixed this issue on my Android phone by force stopping EN and deleting all the cache + data, then starting up EN again.

Interesting, does this work for you jonathan01123 and FlyingGirl?

Link to comment

I got it! I received a response from support and will repost it here. It worked for me. I did have some data that I'd updated on the device, but I was able to follow the steps to find the note that hadn't synced yet and post it via the web interface. One change to his instructions were that on a windows device I had to go to a slightly different folder:

"\Internal Storage\Evernote\someFolderLikeUser\notes"

The notes are in folders with cryptic names, so it is a bit of trial and error to find the correct one.

Email response to follow:

Dear Valued Customer,

We're sorry you're having issues with Evernote for Android.

To get your Evernote client functioning as soon as possible, please sign out of your account in the upper left and wait for it to close completely. Reboot your Android device and sign back in to Evernote. However, this will cause you to lose any changes that have not yet been uploaded.*

If you're still experiencing issues, we believe that reinstalling the latest version of the Android client may address your issue.

  1. Please uninstall the Android client
  2. Reboot (power cycle) your device. This will remove any unsynced notes, so be sure to save any important unsynced data first*.
  3. Visit the Android Market and search for "Evernote" to download and install the latest Application.

Please let us know if you have any further issues.

*If you are an advanced user, you may preserve your Pending notes by performing the following steps:

Mount the SD card to your desktop computer and look in: /sdcard/Evernote/notes/. You'll find a series of subdirectories containing HTML versions of your notes with .enml extensions, as well as images, audio files and any attachments. You can copy this folder to your desktop computer. You will need to rename the .enml files to .html first, then you can open them in your browser and "Clip" them into Evernote. You can copy the image and audio files directly into the desktop version of Evernote.

Let me know if you need any other further assistance.



Evernote Support

Link to comment

Hi FlyingGirl,

Thanks for updating us! :)

Ahh, re-install, that old trick :P

I am glad you got it solved, and kudos to EN support. Some new information for me about some of the ways that EN handles notes on Android too.

Does this help you as well jonathan01123?


Link to comment


This topic is now archived and is closed to further replies.

  • Create New...