Jump to content

(Archived) Firefox Web Clipper new Beta version 5.4 [RELEASED]


Recommended Posts

Hi all,

We have a new beta version of the Firefox Web Clipper, 5.4 that adds some desired new functions:

- Slowness bug fix as reported by some users

- Smart Filing

- Clip to Shared notebooks

- Article nudging

- New tag autocomplete and UI

- China service support

Get the new build here:

UPDATE - This beta has now been released -

As always please uninstall or disable your existing version before installing the beta version.

Please report issues or feedback on this thread with as much details as possible.

--- UPDATE ---

New version has been updated with a fix for the issue with Mac client 3.3 installed from the App store.

Link to comment

I get this error message when I try to install the beta. This occurs whether I try to install directly or save it to my pc. Also doesn't matter if Evernote is open or not. Please advise as to what I could be doing incorrectly. Thanks


Link to comment

Thanks eatrightny, (Debbi)

We haven's seen that error before so thanks for the detailed report. Could you mention a few more details about your system.

- OS & version

- Firefox version

- Is the problem occurring for the beta version only? Or also when you try to install the production version from https://addons.mozilla.org/en-US/firefox/addon/evernote-web-clipper/?src=search


Link to comment


using FF 14.0.1, Ubuntu 11.04.

The WebClipper (Beta) don't work. When I try to add somthing, I have to give Username/PW - but then it does nothing. Same over and over again. I tried to deactivate & to deinstll. Tried directly via FF and install from pc - all the same results...

Also I cant choose in the options than to send to EN Web...!?

What 2 do?


Link to comment

Please report issues or feedback on this thread with as much details as possible.

I have this version installed on Waterfox 14.0.1 - native clipping to evernote doesn't work, only web clipping works. Any chances to get 64 bit support to clip to the evernote app? I am surprised that this feature breaks on 64 bits...

Link to comment

Unfortunately this beta clipper suffers from the same problem all of the clippers have suffered from since Day 1: they always prompt for login credentials when you clip using the clipper.

Evernote will launch and it will successfully clip without those credentials being added, but the dialog box to log in is always presented when I clip, even after successfully authenticating, checking the "Remember me" box, logging in, etc.

I've tried explicitly allowing evernote.com in third-party cookie exceptions, I've tried launching Evernote as a separate process first, I've tried logging into the Web Evernote and then clipping to force a cookie update, but nothing works.

Is there some way to force the clipper and Evernote to remember the login credentials I've entered?

Link to comment

Thanks for the fast update to the beta.

I had the same problem, i upgraded the mac client to 3.3 and then the web clipper stopped working. I uninstalled and reinstalled the web clipper version listed on Mozilla's Add-On page, I changed the settings to save to web. "Saving to web" put me in an endless loop of logging in. It kept asking me for user name & PW and then forgetting them (yes, I chicked the remember me box, it just kept resetting). No note was saved.

I then installed the new build and it did the same thing ie., endless loop of not logging in. Then I just changed the "save to" destination to save to the local client and now it's working, which is what I wanted to do in the first place, but would like to have the option of saving to web.

Mac 10.7.4

FF 14.0.1

Evernote 3.3.0

Web Clipper 5.4

Hope any of that helps


edit: Just enabled cookies and endless loop login issue resolved

Link to comment

Been following the posts...still can't get a url clipping option to appear... I'm running same versions as ozma:

OSX 10.7.4

FF 14.0.1

Evernote 3.3.0

Web Clipper 5.4

I have clipper preferences set to send to web.

Would appreciate some guidance. Thanks.

Link to comment

That URL can not be succesfully clipped in Chrome, Firefox, or Clearly. I was able to clip in Win7 by Ctrl-A selecting the article and copying the selection via the Windows desktop client Win+A shortcut key.

Don't use Mac so not sure if equivalent function is provided by the Mac desktop client.

Link to comment

Brand new Evernote user.

I'm trying to import Catch.com notes. I searched a little and the best suggestion I saw was to open the Catch HTML export and then highlight and clip one-by-one into new Evernote notes. But, when viewing that page, my only choice when clicking on the icon is "Clip URL". When using the context menu, it creates a blank note.

Changing to "Clip to website" also only gives me the "Clip URL" choice from the icon or a "New note" (blank) from the context menu.

When I try a different page, for example, this forum, the options I expect are available.

Obviously, for me, a Catch importer would be the most convenient. It seems to me that a fairly generic CSV importer shouldn't be a huge task, and that technology could be applied to a wide range of situations. In fact, I'd be surprised if most of the scaffolding isn't already in place.

Or, is there another import option that I overlooked?

FF v14.0.1

Evernote Web Clipper v5.4 beta

Win 7 - 64 bit

Evernote Desktop v

Is there any way you could give a short explanation on why the Clipper's behavior changes based on the page being viewed? That surprised me.


Drake Christensen

Link to comment

Slightly off-topic, but for anyone looking to get one field of a CSV file into Evernote, importing the CSV into OpenOffice Calc lets you Copy&Paste a cell into a note. (For some reason it takes 3-5 taps of Ctrl-V for it to "take" in Evernote.) If you're only doing a few dozen then it's not too bad. Better than using the mouse to highlight on a webpage over and over again.

Drake Christensen

Link to comment
  • 3 weeks later...

Hey guys,

I've been using Evernote for years as well as OS X and Firefox. I to ran into the issue of the webclipper not working with FF14 and grew very frustrated with the lack of functionality.

A work around I found was to run the webclipper in Safari then copy and paste the URL across before using the Safari webclipper to pop it all into Evernote. Yes it wasn't all that neat but it worked well.

I can now happily report that the latest beta version of the webclipper for Firefox works and works well.

I know developing for a moving target such as Firefox is always going to be a tough and oning task (probably thankless too!) so I just wanted to say we do appreciate the effort and keep up the good work.

Link to comment
  • 2 weeks later...
  • 2 weeks later...

Thanks for that! For those of you like me who had to think about how to do the above, open new tab in firefox, have the finder window with the location of the xpi file next to it, ie. screen has both windows open and then drag the xpi file onto the empty page. It works, only now I don't have the web clipper icon on my toolbar now that it is installed and enabled.

Any help with that? Thanks

Link to comment
  • 1 month later...

The Evernote clipping icon disappeared from my Firefox browser two updates ago. I just tried uninstalling the add-on, reinstalling it, and restarting Firefox, but still no clipping icon. I just haven't been using it for months, or else if I really want to use Web Clipper, I open up Chrome and use that version -- but it kind of defeats the purpose of Web Clipper, which is convenience. Can anyone help?

FF Mac 16.0.2

Evernote Web Clipper 5.4

Mac 10.6.8

Link to comment

I'm having the same probem. The beta version will not open. Please advise.


Hi everyone,

I can't even open this download!

I've got firefox installed but it won't open .xpi

I don't have the other version of Evernote Clipper installed (new pc)

Any help appreciated.

Link to comment


This topic is now archived and is closed to further replies.

  • Create New...