Jump to content

(Archived) BUG: Windows client isn't able to find a word if some letters have different formatting


luckman212

Recommended Posts

  • Level 5

Using 4.5.6.6884 but I doubt this is specific to that version. I've just never noticed it before.

The bug is that text blocks containing Underlined Text do not seem to be indexed properly by the search engine. As a result, your searches will be incomplete or missing results.

steps to repro;

1. create a new note.

2. set title=ABCDEF

3. set body=xyzzy

4. sync

5. now, go to search bar (F6) and type "xyzzy"

6. your note should appear in the results

7. now, select the "x" in the body and UNDERLINE it

8. sync again

9. click "All Notes" to remove your search filter

10. search for "xyzzy" again -- nothing is found

Yikes.

Link to post
  • Level 5

Good catch Luckman212

Duplicated on Evernote client version 4.5.7.7033 (254164) Prerelease also

Search works if entire phrase is underlined but not on partial underline

But it works correctly on the web.

Probably not a common use case, but this might be part of the answer as to why search results vary from Windows Client to Web.

Link to post
  • Level 5

I filed a bug, Ticket #16051-107602

Since I'm no longer a paid user not sure if that queue is even monitored. Hrm.

Well, hopefully between the forum post and the ticket, someone will see it.

Link to post
  • Level 5

I filed a bug, Ticket #16051-107602

Since I'm no longer a paid user not sure if that queue is even monitored. Hrm.

Well, hopefully between the forum post and the ticket, someone will see it.

Evernote will respond, even if you are a free user.

Premium users get priority however.

Link to post
  • Level 5

Update: Installed 4.5.7.7111 (257033) Public today, no change in this behavior.

Did you get a response from Evernote Support to your June 3 Ticket #16051-107602?

Link to post
  • Level 5*

From a support person, it means that he was able to reproduce it, there's no workaround, and he filed a bug report on it. Support folks may or may not be able to delve under the hood to be able to figure it out, and usually can't fix it themselves, but getting a reproduceable scenario is the key: the devs are the ones who need to be able to figure out the specifics of what's going on. It's possible that assigning it to a dev hasn't happened yet, though.

Link to post
  • 2 weeks later...
  • Level 5

Well just keeping everyone else who might be interested up to date. Today I received this notice:

Dear Luke,

It has been two weeks since our last interaction, so we are closing out this support ticket. Should you have any other requests for support, suggestions or questions please feel free to open a new support ticket.

As of 4.5.7.7146 this bug still exists. I do hope it doesn't get swept under the development carpet.

Link to post
  • Level 5

Well just keeping everyone else who might be interested up to date. Today I received this notice:

Dear Luke,

It has been two weeks since our last interaction, so we are closing out this support ticket. Should you have any other requests for support, suggestions or questions please feel free to open a new support ticket.

As of 4.5.7.7146 this bug still exists. I do hope it doesn't get swept under the development carpet.

Yes, that is a standard automatically generated response to all support requests. Based on other discussions I have had with Evernote, I believe the internal bug report generated from your action will be reviewed and acted upon based on Evernote's priority rankings.

Link to post

Some of my notes have words which have the first letters which have bold formatting. Especially useful when using mnemonics and you need to highlight only the first letter.

However I noticed that my Android client found the particular note i was searching for but Windows client failed. So I tried the web and I was able to find it.

This applies if i just change only a single letter formatting(bold, italics or underline) like SAMPLE or SAMPLE or SAMPLE.

To illustrate I have attached 3 images. Search results from Web, Desktop and Android.

Hope this gets fixed soon!

post-93894-0-38211300-1340284697_thumb.j

post-93894-0-68238600-1340284812_thumb.j

post-93894-0-75153400-1340284817_thumb.j

Link to post
  • Level 5*
Looks like a variation on the originally reported underline search bug.

If you look close, you'll see that I merged it from its own note. Should have made it more obvious, maybe...

Link to post

Well just keeping everyone else who might be interested up to date. Today I received this notice:

Dear Luke,

It has been two weeks since our last interaction, so we are closing out this support ticket. Should you have any other requests for support, suggestions or questions please feel free to open a new support ticket.

As of 4.5.7.7146 this bug still exists. I do hope it doesn't get swept under the development carpet.

Yes, that is a standard automatically generated response to all support requests. Based on other discussions I have had with Evernote, I believe the internal bug report generated from your action will be reviewed and acted upon based on Evernote's priority rankings.

We get a development carpet to sweep things under? I must be under-utilizing that...

We've got this in our queue, it hasn't been lost :)

Link to post
  • 1 month later...
  • 5 months later...

Archived

This topic is now archived and is closed to further replies.

Guest
This topic is now closed to further replies.
×
×
  • Create New...