Jump to content
  • 0

BUG: Old versions of Evernote stuck in trash after update



The last two times I updated Evernote, I ended up with files that would not delete from the trash on the MacOS. I would get this error - "The operation can’t be completed because an unexpected error occurred (error code -8003)."

I googled and tried various suggestions to delete stuck files. Closing applications didn't work. Restarting didn't work. Terminal commands didn't work. FINALLY, I got it using Trash It.


Why was this happening? Is this what I have to look forward to with future updates? Evernote team - can you fix this bug in future versions?

Link to comment

11 replies to this idea

Recommended Posts

This actually is a "Mac" issue, and not an "Evernote" one, and we don't really have a good way of correcting it. Generally, in cases like this, the file was in-use while you trashed the app from the Finder, so the trash won't delete it. So, perhaps you were in the middle of a sync, or a reindex when you chose to update.

If someone else runs into this issue in the future, here's two ways to try to force empty the trash (without using Trash-It):

  1. Press and hold the mouse button on the Trash icon in the Dock. The context menu for Trash will display.
  2. Press and hold the Option key (Alt key).
  3. Select Empty Trash from the context menu for Trash.
  4. Release the Option key.

Or, Open "Terminal" (from Applications) and Type this:

rm -rf ~/.Trash/*

and hit enter or return.

Once the trash has been emptied once, it should be able to be emptied from then on.

Link to comment

The app was updated following the prompts and the un-deletable files were generated on two separate updates. I tried both of those methods that you suggest and the files would not delete. I suspect that I'm not the only one that has had this issue.

Link to comment

I've had the same problem as larsnateson.

The updater launched when I opened evernote and confirmed the update. I didn't do anything else and the file was stuck in my trash for several days until I used terminal to remove it. If the file was in use when it was trashed, it seems like an Evernote issue because Evernote was updating at the time.

This has happened twice with Evernote and never with any other apps.

Makes me leery about updating Evernote...

Link to comment

I can confirm this happens often after updating Evernote. In the past, quitting Evernote and forcing EvernoteHelper to quit from Activity Monitor was enough to allow the trash to be emptied, but now neither that nor using the 'Force Empty Trash' method seems to work. The rm -rf option did work, but doesn't strike me as a permanent solution.

A 'workaround' I've been using for a while now is only using the 'update on quit' function, but it seems every time I forget this and use the immediate update, this issue pops up. I'm not sure if it happens with Mac App Store updates, but it definitely happens on (most) direct updates from the app itself, without any manual trashing.

Link to comment

Just ran into this issue again while updating to 5.0.5. Above staff made the suggestion this might be because Evernote was syncing or re-indexing, but Evernote actually asked me if I would like to finish my sync before updating. I answered yes, but the old version is still stuck in the trash. So, either the 'wait until sync is finished' isn't working properly or the issue is somewhere else.

Link to comment

Is there someone from the Evernote team that can respond to this? I just ran into this issue again. I was not syncing at the moment, responded to a prompt from Evernote itself and did not download or update from the Mac App Store on this machine.


If it is indeed an issue with syncing while updating, perhaps the Evernote client should finish its sync before updating. If this is already the case (after all, when I quit while a sync is in progress I see an alert, but there was no alert this time) the issue is probably not with syncing but with something else.

Link to comment

Response #1 is from an Evernote employee.


Here's another option: use our direct download client available here: http://evernote.com/evernote/index.php?file=EvernoteMac


I'm sorry, but it seemed like you missed something in my post. Like I said, I did NOT download this Evernote client from the Mac App store (ie, I DID download the direct download client). Also, the first response said this might be an issue with syncing or reindexing. As this issue is occurring frequently and I always respond to the alert from Evernote asking me to update (as opposed to manually checking for updates) I doubt this is the case. Evernote shows an alert when I attempt to quit while syncing, I assume Evernote won't start an update when syncing, or else wait until the sync is finished before completing the process.


Other responses to that first reply appear to be indicating something similiar, so when I asked for I response I meant a response to the other replies. Upon rereading, that first reply also seems to be assuming that we manually trash Evernote from Finder, which is definitely not the case. And finally, the solution presented there, rm -rf ~/.Trash/*, isn't very safe...

Link to comment

I had the same problem more than two and a half years after this posted fix. Obviously your comment that Evernote does not have an easy way to fix the problem is valid, because the problem still exists. Providentially, the fix still works, several years and OS and Evernote versions later. Thanks!

Link to comment


This topic is now archived and is closed to further replies.

  • Create New...