Jump to content

(Archived) HELP: "Sync failed due to unexpected problem at server side"


Recommended Posts

Evernote won't sync, giving the error noted in the title. Activity log states:

11:40:36 [3576] 0% Connecting to www.evernote.com

11:40:36 [3576] 0% * loaded updateCount: 2505

11:40:36 [3576] 0% TException: Default TException.

11:40:36 [3576] 0% Session terminated abnormally, elapsed time: 0s

11:40:36 [3576] 0% * sent: 117B, received: 62B

11:40:36 [3576] 0% * 0s (100%) spent in EDAM RPC

Happens every time I try to sync today.

Any help hugely appreciated -- thanks!


Link to comment

Welcome to the forums.

11:40:36 [3576] 0% TException: Default TException.

That is a new one for me.

You need to submit a support request. See my signature for link.

Link to comment

I had this problem recently across different Windows machines I'm on. I had to uninstall EN, remove the database file, then perform a clean install.

Was it exactly the same error?

Did you do that as the result of a support request?

Link to comment

Sorry, I should have been clearer -- my log was different, for one, I didn't get the "TException" tag. However, I got the exact same sync error, which was persistent across several machines (though not my Mac). I issued a ticket, and ultimately the solution was to uninstall, remove the database file, then install the latest beta.

All this happened about a week ago.

Link to comment

Thanks for the update.

This error (Sync failed due to unexpected problem at server side) has been showing up relatively frequently starting recently, but, at this point I have only seen one quickly correctable cause for the problem (Problems syncing a specific shared notebook).

I have seen prior cases where rebuilding the local database was required to fix persistent sync errors. In those cases however only a single device was showing the problem.

Link to comment
  • 3 weeks later...

HELP! I'm a fairly heavy EN user (since 2008) and quite dependent on it, as it's fully integrated into my professional (GTD and education) and personal life.

For 5 days I've been getting "sync failed due to unexpected problem at server side" when I try to sync from my PC running Windows 7, and a current V4 of EN. I have submitted a couple tickets (last week) tried CHAT on Thursday, and haven't had a response yet. I've always had quick response in the past I'm fairly desperate to have this fixed by tomorrow, as I really need it up to date for work this week. Any ideas would be VERY much appreciated.

I know NOTHING about code, etc, but have tried everything that I can do myself from reading the forums and posts about similar problems. I use EN on my iPhone, iPad, Windows. All are up to date. I WAS getting an error on my iPhone as well, and I deleted it and reinstalled completely, and the error stopped. My iPhone and iPad are current with the browser version of EN.

My desktop V4 Windows, however is not syncing. I always get the sync error. "sync failed due to unexpected error on server side" The notes seem to be syncing TO my desktop version when I create them from my iphone or ipad, but not in reverse. I'm not confident that everything has synced, though.

Notebooks edited in Windows do not sync to the other devices/server. This is a challenge, as I just edited and tidied up ALL my notebooks on the desktop, thus how I learned of the problem. I've accepted that I'll likely have to do that again when this is fixed. I can lose any local changes on the desktop since the last completed sync, if I need too, as all of my current stuff is accurate on the (and created on) the iphone and server.

I have:

  • re-installed Windows V4 on my desktop
  • looked at the activity log and tried to determine the culprit- is. I thought it was "untitled audio note", as that came after " EDAMNotFoundException" and I searched (exported) and then deleted all "untitled audio note" and then emptied the trash. Now it says something different
  • deleted all shared notebooks
  • I installed EN on my husbands PC to see if I had the same sync error, but it's taking a LONG time to update the client database- it's stuck on 13%, so it may be a while before I can see if that works. If it does, then I assume that I need to somehow delete/rebuild the database on my PC? I tried to follow the posts on this topic, but it's over my head technically.
  • I tried to figure out how to search for that particular note GUID, that I guessed was the culprit (can someone else translate the activity log for me?) but couldn't find it. Even learned about the syntax! This is kind of like replacing my cars alternator without knowing anything about cars, and just following the manual. Except my car worked, and EN doesn't. :(



"08:27:10 [14808] 0% Updating server note "(cannot transcribe)"

08:27:10 [14808] 0% * guid={32cdfe8b-4574-4588-9e3f-fab9aceb559a}

08:27:11 [14808] 0% EDAMNotFoundException: id="Note.guid" key="32cdfe8b-4574-4588-9e3f-fab9aceb559a"

08:27:11 [14808] 0% Session terminated abnormally, elapsed time: 47s

08:27:11 [14808] 0% * sent: 6.3KB, received: 4.6KB

08:27:11 [14808] 0% * 36s (78%) spent in EDAM RPC

08:27:21 [13540] AutoUpdate: checking for update at: http://update.evernote.com/public/ENWin4/update.xml

08:27:22 [13540] Received status code 200 when accessing URL http://update.evernote.com/public/ENWin4/update.xml

08:27:22 [13540] AutoUpdate: no update found, remote revision is the same as the local revision (249072)

08:27:23 [13540] Received status code 200 when accessing URL http://update.evernote.com/public/ENWin4/ReleaseNotes_4.5.6.6884_en-us.html

08:27:29 [14808] 0% Connecting to www.evernote.com

08:27:29 [14808] 0% * loaded updateCount: 52659

08:27:30 [14808] 0% Client is up to date with the server, updateCount=52659

08:27:30 [14808] 0% * saved updateCount: 52659

08:27:31 [14808] 0% Expunging server items

Link to comment

The one thing that worked for me that doesn't appear in your list of what you did:

after uninstalling, delete your Evernote database file, then re-install.

(Given that you're having trouble on your husband's machine, however, I'm not 100% positive that would do the trick.)

I'm not sure where to point you to the Evernote database file (I have a custom location), but it should have the .exb extension. Mine is in (...)/Evernote/Databases/{myusername}.exb

Link to comment
  • 9 months later...

Hello, I'm fairly new to EN and have had trouble syncing for about a week. I have updated the software on both my PC and iPhone. I've emptied the trash in EN and in windows. I deleted what I thought was the corrupt file, to no avail. I updated my password.  "Sync failed due to unexpected problem on server side" is the error message I get.  Any ideas? Activity log below. Please address in layman's terms as I don't understand code. =)



Evernote for Windows (268604) Public
OS: Windows 6.1.7601 Service Pack 1
User: lhertz
Memory: 57.0MB
Created: 2013/03/04 11:51:13
11:49:48 [1208] 0% Synchronizing 1 note
11:49:48 [1208] 0% Creating local note "Getting Started with Evernote for Win...", resource count: 1
11:49:48 [1208] 0% * guid={84479DC6-B33E-41FA-A91D-1815EC10ED1C}
11:49:48 [1208] 0% * Retrieving note data, total size=1512
11:49:49 [1208] 0% * Creating local resource "b19fa5bfa58008319dfc6d1dcea48fb6"
11:49:49 [1208] 0% * rsrc={46B5D2C0-26F0-40B5-8FFA-D57B34B0A692}, note={84479dc6-b33e-41fa-a91d-1815ec10ed1c}
11:49:49 [1208] 100% * saved updateCount: 965
11:49:49 [1208] 0% Updating server items
11:49:49 [1208] 3% Creating server note "2013_02_26_19_46_08.pdf", resource count: 1
11:49:52 [1208] 3% EDAMNotFoundException: id="Note.notebookGuid" key="0dfa53f9-211b-45e8-aa0b-9398a663aff6"
11:49:52 [1208] 3% Session terminated abnormally, elapsed time: 5s
11:49:52 [1208] 3% * sent: 133KB, received: 2.9KB
11:49:52 [1208] 3% * 3s (78%) spent in EDAM RPC

Link to comment


This topic is now archived and is closed to further replies.

  • Create New...