Jump to content

(Archived) Share to Evernote has stopped working on Android


Recommended Posts

On my Galaxy Tab, I used to be able to clip web pages by going to the menu item "Share" and then selecting "Evernote." At that point I would see the same interface I see on my desktop when I use the chrome bookmarklet - it would allow me to clip the page and add tags, etc.

As of yesterday, this has stopped working. I get the same result on both the Dolphin browser and the built in Android browser:

1. In browser, select menu item "Share" and then "Evernote"

2. It tries to go to the URL evernote.com/clip/action...

3. This redirects to a login screen titled "welcome back" and prompts me for my login.

4. I login, and it redirects me to my evernote home screen, where I see my notes.

RESULT: nothing is ever clipped.

Once I am logged in, if I try it again, I get the same result -- it asks me to log in repeatedly.

But note that if I just go directly to the evernote web interface, it does not ask me to log in, because it remembers I am already logged in. So Evernote Is remembering that I'm logged in -- but for some reason, the clipper is incorrectly redirecting to login every time.

Is anyone else seeing this? I have rebooted my device and flushed the cache on both browsers. The fact that it's happening on both browsers makes me suspect something on EN's server side. I have also tried changing my user-agent in Dolphin to desktop and then to Android, but the result is the same. Any suggestions appreciated.

Link to comment

In the built-in Android browser, when I go to "Share" I see 2 options for Evernote:

1. "Evernote"

2. "Evernote -- Create note"

The first one goes to the usual clipper bookmarklet (just like in Chrome on Windows). The second one just sends the URL of the current page to evernote.

This interface is exactly the same on the built-in Android browser and on Dolphin.

So yes, there is no "web clipper" on Android, but you can "Share to" evernote through the web interface.

The problem is that the web interface is now broken for both Android browsers.

BTW, I did delete and then reinstall EN and I have the same result. This seriously hampers the usability of EN on my tablet, since the main thing EN is good for is "capture anywhere" -- and now I can no longer capture anything.

Link to comment

OK, it turns out that the "Share to Evernote" option (if invoked while viewing google.com) pulls up this URL:


And when I go to this URL, on both Windows and Android, it has stopped working. Prior to this week, going to this URL brought up the web-based clipping interface. Now, it redirects to the EN web login screen -- even if I'm already logged in to the EN web page. And after I log in, it takes me to the EN home page. I can never load the web-based clipper.

So I guess the question is: why did EN break the clip.action page, can we get it back, and/or is there any other option for clipping web pages from Android browsers?

Link to comment
  • 1 year later...


This topic is now archived and is closed to further replies.

  • Create New...