Jump to content

Import Folder using a different drive


Recommended Posts

I am having difficulty with Import Folders. Evernote and import folders have worked great for me in the past. Got a new laptop and have my program files on the C: drive with is a SSD. My storage is on a regular hard drive which is drive F: I have entered my import folders using the browse function and point them to the appropriate location on the F: drive, but they change and show up as being on on the C: drive. And, then, since that folder doesn't exist, it doesn't sync. For example, when I enter the import folder, it looks like: F:\Users\GS\Scans but after I get the import folder all set up and it doesn't sync, I go back and look at the import folders, it has changed to C:\Users\GS\Scans Any ideas? I did move my local files (under the Options tab) but that did not seem to help.

Thanks.

Boot

Link to post
  • 1 year later...

I'm having the exact same problem. I'm running Windows off a SSD (drive C) and using a local HDD (drive F) for storage. I'm trying to set up an Import Folder on drive F. I set the correct folder path as "F:\import" and hit OK, but the files in that folder are not imported into Evernote. When I open the Import Folder settings window again the folder path has automatically changed to "C:\import". I have already uninstalled and reinstalled Evernote and the problem persists.

 

I just submitted a trouble ticket, so we'll see if I get a response.

Link to post
  • 2 months later...

I also am having a similar problem.  I have the drive letters A and B mapped to folders, with my real drive being C, which is where I want my import folder to be.  However, the Import folder always changes it to A.  For example, if I make the import C:\EvernoteImport, it accepts it, but when I go back in to look at it, it has been changed to A:\EvernoteImport

 

Looks like something is changing it to the lowest letter.  Yes, I could remap the A and B drive to something after C . . . but . . . but, why?

Link to post
  • 1 month later...

I'm having precisely the same problem as Jerry A:  "I have the drive letters A and B mapped to folders, with my real drive being C, which is where I want my import folder to be.  However, the Import folder always changes it to A."  Has there been a fix for this?

Link to post
  • 7 months later...
  • Level 5*

Been seven months since the last post in this thread, and I still have the same problem with the Windows client.  Any progress on this?

Probably best to open a support request. See the link in my signature.

Link to post

jefito, thanks for the suggstion, but I did indeed open a support ticket -- #205553 -- seven months ago, on October 22, 2013; there's been no resolution to the issue. In that ticket, I described the issue as follows (I'm a Premium subscriber):
 

I have precisely this problem, reported already by others:
 

I have the drive letters A and B mapped to folders, with my real drive being C, which is where I want my import folder to be.

 

However, the Import folder always changes it to A. For example, if I make the import C:\EvernoteImport, it accepts it, but when I go back in to look at it, it has been changed to A:\EvernoteImport

 

Link to post
  • 7 months later...

Did you guys ever find a fix to this? I just started a new thread about this, the same thing is happening to me as well.

 

No, never found a real fix. My workaround was to leave the import folder on the drive that Evernote kept switching to and just create a shortcut to the folder on the other drive. You can still drag and drop files directly onto the shortcut. I have the source files set to delete once they import to Evernote so they aren't sitting on my SSD taking up space.

Link to post
  • 1 month later...

Uh folks, if you have drives mapped to A: and B:, as RobertJSawyer did, I just read that that, for legacy reasons, the drive letters A: and B: are treated differently than other drive letters. http://www.howtogeek.com/122891/what-are-the-windows-a-and-b-drives-used-for/

 

Jefito, that's true -- but the folder I want to  import from is on drive C: -- and Evernote should respect that.  It doesn't.  I first reported this problem in October 2013, and it occurs on (at least) Windows XP and Windows 7.  I've sent a follow-up query today on my support ticket from way back then, but I'm unimpressed by Evernote's support; I jumped through every hoop they asked for (logs, reinstall, etc.), and got back basically nothing more than, "Oh, well."

 

I've looked in the Windows registry to see if I could find where the names of the import folders are being stored, in hopes that I could patch them there, but I can't find it, and there's no file in the C:\Program Files\Evernote folder that seems to store that info, either.

 

The bug is still present in the latest public version 5.8.4.6870.  Sigh.

Link to post
  • Evernote Employee

It looks like the issue is because we look at the serial number of the underlying disk in order to properly import USB devices that may change drive letters. When you map/subst to the local drive, you now have 2 letters that map to the same drive. The import folders look for the first instance of the serial number in the drive letters - hence your import folder must be in the first drive (if A: is mapped to C:\something, must use A:. Conversely if c:\something is mapped to d:, you must use C:)

Hope that makes sense...

Link to post

Thank you, Dconnet.  The answer, of course, would be a tick box on the Import Folders dialog box, where you tick, "This is a removable drive" if it in fact is one, in which case invoking the algorithm you describe might be sensible -- but if it isn't then simply using the drive letter and path as the user entered them would be (1) doing what the user asked the program to do and (2) actually simpler from a coding point-of-view, no?  Surely a solution can be found that actually works for all users, not the just the subset (those who want to import from removable drives) that you are now properly serving. :)  Thanks!

 

Alternatively, a couple of lines of code that recognize that A: and B: are in fact special drive letters (removable at the OS level) and that the serial-number-tracking you do should default to drive C: or above in any case in which the same serial number is assigned to multiple drive letters and one or more of those letters are A: or B: would help ameliorate this problem. :)

Link to post
  • 7 months later...

I'm having the same problem. SSD is C:, storage on I:, as is the fold I'm attemtping to import. I select I but Evernote changes it to C. I read the explainations below but I still don't understand how this not a bug. Can't we get this corrected?

Link to post
  • 3 weeks later...

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...