Jump to content
  • 0

(Archived) Evernote 3 freezes frequently - beachball



Ever since updating to Evernote 3, the application freezes with a beach ball of death virtually every time that I use it. Sometimes I can actually do something before it happens, and other times it freezes right after launch. The only way to get out is to force quit.

It has happened when attempting to save an attachment from a note, or when I tried to download the Safari Clipper Extension via the preferences dialog (I didn't realize at the time that I needed a beta for Safari 5.1, but it still shouldn't have locked up Evernote).

When Evernote beachballs, my CPU usage goes way up, and the fans on my 15" MacBook Pro i7 (8 GB RAM) start whirring like jet about to take off.

I would have liked to have attached the Crash Reporter log, but Evernote seems not to have generated any.

Any other reports of issues? I'm pondering deleting Evernote 3 and reinstalling it. Can I revert to Evernote 2.x, or is my upgraded database incompatible?


Link to comment

14 replies to this idea

Recommended Posts

Reinstalling Evernote should fix crash issues in most cases. If you're still experiencing problems, please file a support ticket (in my signature below).

If you're running Lion, you might also try downloading and installing our Mac Beta, 3.0.1: viewtopic.php?t=28025 rather than doing a simple reinstall of 3.0.

Let me know if this works!

Link to comment

I know this topic hasn't been posted to in a few months, but I am having this issue. I've had it since I started using EN. Currently running v.3.0.5 (though I had it with earlier versions), and it seems like I get this problem anytime I try to right-click and do something with an attachment in EN. I even get it when I try to use the EN menu bar icon to "Clip Full Screen to Evernote" (kind of frustrating), or port a scanned image from my new Canon P-150 to EN (very frustrating). Just opened a second ticket with EN support. First one from a few months ago ended with support basically saying "no one else has this issue, so it must be something with your machine." I can understand their position, but my pretty new MBP works flawlessly otherwise.

Link to comment

Which issue have you submitted a ticket for, all of them? It's likely these are entirely separate issues with separate solutions.

The clipping issue will likely change based on the browser you're using to clip. The issue may be occurring when it tries to link up with your EN Mac account (if you have it set to do so, such as in FF).

I'm not having any issues with attachments, are the beachballing attachments specific kinds of attachments, or all attachments?

As for the scanned images, you'll have to explain what you mean by "port". Does the beachball happen when you scan a document to Evernote using Capture On Touch?


Link to comment

The ticket I created (16051-48533) mentions several of the ways working with attachments causes the beachball. The just had me install a pre-release of the Mac app, but that didn't resolve the issue.

The clipping tool I am referring to is in the OSX menu bar, not the browser extension. I actually haven't had any issues with the browser extension, but I think that's purely because it clips the web page directly to my EN account via the web, and not via the Mac EN app.

It seems to be all attachments cause problems. Right-clicking on an attachment usually causes the beach ball before the context menu pops up. But sometimes it shows the context menu before gives me the beachball. And I can occasionally select the application to open the attachment with...but then the beachball (and the select app never opens). All of these are only resolved by Force Quiting out of EN.

Regarding scanned images, by "port" I mean that I have OnTouch configured to send scans to Evernote. And I have found that it sometimes successfully does this (creates a new note in a child window with the scan attached) without issue. But often, once OnTouch scans the document and sends the image to EN to create a new note, EN beachballs.

So to me, the common thread is that any time I ask EN to do anything with attachments already in a note, it tends to lock up. FWIW, I can find the attachment in Mac Finder (Users{myUserID}LibraryApplication SupportEvernotedata) it open the attachment with no issues. I've only tried this for a couple of attachments, though.

One last thing. I really thought I was on to something when I found this article. http://goo.gl/o0t2V. But I followed the recommended steps, and it didn't help. Might help someone else reading this thread...or spark an idea for the EN support team.

Thanks for your time in helping resolve this issue. I really do love EverNote.

Link to comment

Interesting idea Metrodon. Any specific steps I should follow to do that without losing all my data? Should I just sync EN and go into Users{myUserID}LibraryApplication SupportEvernote and delete everything in the data directory?

Link to comment
  • Level 5*

Make sure you export any local notes first and that everything you want sync'd has been synced.

Close Evernote.

Delete the Evernote folder (from your path above)

Open Evernote

Wait for everything to sync up - may take a while if you have a lot of notes/embedded files

Import the local notes

Good luck

Link to comment

Thanks Metrodon. Did as you suggested, but still having the same issue. :) It pulled all the notes down fresh from the EN web service (took a little time to rebuild, as you thought it might). I have less than 200 notes, and about 140MB of attachments, so it was nothing crazy.

Link to comment

I notice that in your original ticket, you mentioned that this started happening when you got a LiveScribe. Do you still have the LiveScribe software installed on your machine? Just as a quick test, I would uninstall that (and possibly your Canon software as well) just to rule that out as causing some kind of interference. I'm going to forward your crash report to an engineer for more detailed analysis, but I would recommend trying that out in the meantime.

Link to comment

Thanks Automatica. I can give that a try, though I am a little less confident in doing this since my Livescribe data isn't synced as well as Evernote. FWIW, this problem happens with attachments not even remotely related to Livescribe (jpgs, for example). But I see understand your logic in wanting to rule it out.

Link to comment

These are maddening problems, but rest assured they'll get solved. Evernote should not behave that way, and does not do so for me.

Don't be reluctant to delete everything Evernote-related from your machine and start afresh, so long as you have backed up any local notebooks on your own disk. Re-installation on the Mac used to be a curse but EN's system has improved so much that for me it's just an overnight affair to restore my 10,000 notes from the servers.

Link to comment

Thanks John. I have full confidence they will figure it out. Sounds like EN has come a long way with re-installing for the Mac. I actually have tried it a few times (as per suggestions of their support folks), but no luck resolving the issue. However, it certainly was easy to do. They also suggested I try installing using a fresh Mac profile. I created a new account on my Mac just to install EN and see if that worked any better. Again, no dice...beachballed the same place.

Haven't tried reinstalling LiveScribe yet, though. Without smooth data syncing that EN has spoiled me with, I am afraid it'd be a mess.

Link to comment


This topic is now archived and is closed to further replies.

  • Create New...