Jump to content
  • 0

(Archived) Can't synchronize (content si not valid)



I'm can't finish my synchronizing process due to an invalid content message.

I'm able to get remote changes but I can't upload local changes.

The attached note can't be synchronized and I don't know how to solve it

Note content:

<?xml version="1.0" encoding="UTF-8"?>




Error from activity log:

2011-03-22 11:09:51 0x1a5817c0 [ENSyncEngine] INFO: Syncing note: 'Prueba'

2011-03-22 11:09:52 0x1a5817c0 [ENXMLParserWriter] ERROR: Failed to parse, libxml error: -1

2011-03-22 11:09:52 0x1a5817c0 [ENXMLParserWriter] ERROR: libxml error desc: failed to load external entity "/var/folders/dS/dS5ZAVNKE4mMGn6p1igMXU+++TI/-Tmp-/38C19BD9-8D2E-4902-993E-79CDAAF4F2F5"

2011-03-22 11:09:52 0x1a5817c0 [ENXHTMLToENMLConverter] ERROR: Parse failed converting XHTML to ENML: Error Domain=Evernote XML Error Code=4 UserInfo=0x1af58de0 "No se ha podido completar la operación. (Evernote XML Error error 4.)"

2011-03-22 11:09:52 0x1a5817c0 [ENNoteMO] ERROR: Error converting xhtml to enml for note 'Prueba' guid '(null)': Error Domain=Evernote XML Error Code=4 UserInfo=0x1af58de0 "No se ha podido completar la operación. (Evernote XML Error error 4.)"

Thanks in advance

Link to comment

4 replies to this idea

Recommended Posts

Have you installed the "Ruby" software development platform on that Mac? (We've seen a similar problem due to a problem in the Ruby packages.)

Is the note titled "Prueba" empty on your Mac client? If it is, then try deleting it and emptying it from the Trash. If it's not empty, you can try Exporting it to an HTML file instead of ENEX, and then delete it and empty the Trash.

Also - how did you create that note?

Link to comment

Thank you for your quick response.

Yes I have Ruby installed in my mac; in fact, I'm using this version:

ruby 1.8.7 (2011-02-18 patchlevel 334) [i686-darwin10.6.0]

The note is not empty, I have just checked that I'm able to synchronize empty notes, but I'm not able to synchronize notes with content (any kind of content: text, images, etc)

This note has been created using evernote client (with shortcut Control+Command+N), but I also have problems if I create notes using evernote toolbar (button to create a new note).

I've just deleted the note, and emptied the trash, but I haven't solved it.

I've also tried to delete all local notes and make a full synchronization of all notes, but the problem still persists.

Thanks again for your time.



Link to comment

One of the Ruby gems replaces the built-in 'tidy' command in OS X (/usr/bin/tidy) with a broken script in the same location. You need to restore the original /usr/bin/tidy command that comes with OS X.

On my 10.6.6 box, that command is 65072 bytes:

~ $ ls -al `which tidy`

-rwxr-xr-x 1 root wheel 65072 Aug 31 2010 /usr/bin/tidy

Once you've fixed that broken part of the OS, Evernote should work ok. You may also want to file a bug with the Ruby folks, who absolutely should not be replacing this file with their own.

Link to comment


This topic is now archived and is closed to further replies.

  • Create New...