Jump to content

ノート本文中の一部ハイパーリンクが機能しない。


匿名希望

Recommended Posts

■不具合発生手順

(1) google検索結果やwikipediaのURLをノートに貼り付ける

例)…

------------------------------------------------------------

「テスト - Google 検索」

http://www.google.com/search?num=50&hl= ... 2&aql=&oq=

「テスト - Wikipedia」

http://ja.wikipedia.org/wiki/%E3%83%86% ... 9%E3%83%88

------------------------------------------------------------

(2) ハイパーリンクにする

(3) ノートの編集を終了する

(4) 再度ノートの編集を開始する

(5) ハイパーリンクをクリックしてページへ飛ぶ。

以下のような結果になります。

post-31244-131906071852_thumb.png

post-31244-131906071885_thumb.png

Link to post

ちなみにノートを再編集するまでは正常動作します(リンク先へ正しく飛べます)

動作環境

──────────────────────────────

OS:Windows XP HOME SP3

クライアント:Windows版 Ver.4.2.2.3900(127835)Public

アカウントタイプ:プレミアム

──────────────────────────────

Link to post

自分の環境でも起こりました。

win 4.2.2.3913(128100)Public

気づかなかっただけかもしれませんが、4.2.1.3716 Publicを使っていたときは大丈夫でした。

ちなみに、このリンクは化けてたり化けてなかったりします。

(化けてたところが何もしてないのに直ってたりまた化けたりしていた)

Link to post

その後調べた結果ですが、

日本語が含まれる動的URLで、UTFエンコードされたもの?で不具合が起こるようです。

試しにURLをデコードしてから貼り付けたら問題は起きませんでした。

例として、以下のページで

http://user1.matsumoto.ne.jp/~goma/js/utf.html

問題のあるURLをデコードします。

[前] http://www.google.com/search?num=50&hl=ja&lr=lang_ja&tbs=lr:lang_1ja&q=%E3%83%86%E3%82%B9%E3%83%88&aq=f&aqi=g8g-c2&aql=&oq=

[後] http://www.google.com/search?num=50&hl= ... ang_1ja&q=テスト&aq=f&aqi=g8g-c2&aql=&oq=

デコード後のURLを貼り付けた結果、問題は起きませんでした。

一応対処はできますが、その都度行うのはちょっと面倒ですね。

こういったシーンはよくありますし、お困りの方も多いと思うのですが…

できれば早期対応をお願いしたいところです。

Link to post
  • Evernote Employee

ご迷惑をおかけしております。

こちらも現象を確認しており、次期バージョンにて修正を入れるよう対応検討中です。

修正版がリリースされるまで今しばらくお待ちくださいますよう、よろしくお願いします。

Link to post

Win 4.2.3.2(131509)Publicを使いましたが(少なくともUnsynced Notesに入っているノートは)まだ直っていません。

新しく作ったノートに関しては大丈夫みたいですが。

追記

すいません、一度編集をすれば大丈夫みたいです。

ただ、Unsynced Notesに入っているノートの同期ができません。

何か別の問題があるのでしょうか。

Link to post
  • 2 weeks later...

私も同じようになりました。

残ったUnsynced Notesは、一度エクスポートしてゴミ箱に入れ、エクスポートしたやつを入れなおすとUnsyncedにならなくなりましたよ。

Link to post

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...