Jump to content

Attempt to get help results in a never ending loop

Recommended Posts

I pay for a 2 personal accounts. If I try to get help, every attempt ends in a new login without getting any further. 


Link to comment

Thank you for your reply, but that does not fix the problem. After clicking to "submit a request" there is a site saying "Loading" for 2 or 3 seconds, then I'm logged out and have to log in again. - In Google Chrome it is exactly the same behaviour. 

Link to comment
  • Level 5*
4 hours ago, jo7k said:

Thank you for your reply, but that does not fix the problem. After clicking to "submit a request" there is a site saying "Loading" for 2 or 3 seconds, then I'm logged out and have to log in again. - In Google Chrome it is exactly the same behaviour. 

Not sure what else we can do for you - we're mainly other users here and if you're using https://help.evernote.com/hc/en-us/requests/new as the support link,  you should be getting through to a reporting page.  Failing at that stage is a browser-related issue - which may mean connection speed / AV,  firewall or VPN issues / conflicting add-ins or other processing issues.  It just worked perfectly for me.  As suggested earlier - try another browser.

Link to comment

I'm really grateful for your attempts to help me, but as I said before: I did try different browsers (Google Chrome, Firefox) and I did try different computers in different local networks, and I always get the same result. So I'm not convinced that the problem is really a local one. - The link you suggested leads me to the login-site, so I'm in the same trap. - The point is, that there seems to be no possibility at all to get in touch with Evernote, so this forum was my last hope before I have to leave Evernote and use a competing app.

Link to comment
  • Level 5

From what you describe, it is very local.

I assume you have popup windows disallowed, either by setting it or by choosing a strict security profile.

Popup windows are necessary to log in.

Make sure they are allowed, at least for Evernote.com and all subdomains.

Link to comment

In safari I have set "enable pop-ups" to "yes" and "block content" to "no" for the site "Evernote.com". Further on I have disabled everything in the sections "Privacy" and "Security".

In Google Chrome, Firefox and Opera I did not change the standard settings, I tried them right after the installation.

Do you know any browser that does not block Evernote help with the standard settings?

A few weeks ago I found this post in this forum from 2018:


It said:
Issues accessing Evernote Support Channels
Shane D.
By Shane D.

Hi All,

We've seen a few reports from users where they are automatically booted/logged out when trying to open support ticket, open a chat, or successfully login to the Help & Learning Center.

If you're one of these users, please reach out to Shane D. directly here, so we can iron out the issue, and get you up and going.

Let me know if you have any other questions!

I tried to contact Shane D. 5 weeks ago, but I got no answer. Probably she does not work any longer for Evernote.

In this older post she did not expect any settings in the browser to block the access to Evernote help, but see suggests that there might be a problem with some Evernote 
accounts that she promises to "iron out". 

Link to comment
  • Level 5*
5 hours ago, jo7k said:

suggests that there might be a problem with some Evernote 
accounts that she promises to "iron out". 

...and 6 years ago,  he probably did.  Things (and owners) have changed since then.  Do you have access to Evernote on a mobile?  It's possible to create a Support query via Settings on a mobile app.

Link to comment

I tried that too and got the same result.

Is there as far as you know a browser that has a security profile that should enable the Evernote help?


Link to comment

Yes, I tried the URL for the help site as well.

I just installed Thorium browser and got the same problem. The promised contact form does not appear after I've been automatically logged out and then I logged in again. 

I've got two Evernote accounts, one of those I've just upgraded to Professional, and both have the same problem. We've got a lot of computers in our business, and I tried different computers, but all showed the same behavior. 

Sometimes the site does not log in promptly after the discussed process but gets stuck with those colored emojis and does not process further, sometimes I get an empty site, so I can imagine that the site tries to load a contact form but does not succeed. But mostly I just get my usual Evernote landing site.

Link to comment
  • Level 5

Make sure popup windows are enabled in the browser.

If the problem prevails, try another browser on another network. Make sure to quit any security or ad blocking software before trying to access support. A network firewall can interfere as well.

Last resort is to go on mobile data, and issue the ticket from a phone.

Link to comment

Thank you for your reply, but as you can easily see when you look at this conversation,

I already did everything that you resume, including the "last resort" on my iPhone.

So there is no remaining resort, and the only conclusion at this time is: The Evernote help is by no means available for me as a paying member.


I'm only curious: I see that you answered to other members with the same problem as mine. Did you achieve a solution for any of them?

Link to comment
  • Level 5*
1 hour ago, jo7k said:

Did you achieve a solution for any of them?

The Forums here are supported by other users - we don't have any more information than you see in this thread.  As far as I know very few users are completely locked out of the Support system in the same way you apparently are. 

If we didn't already suggest it - you could try 'X',  the Evernote Product Lead is quite active there... https://x.com/fedesimio


Link to comment

Yes, that works. 

The topics I can choose and the questions I have to answer don't match my problem, but I hope I'll get an answer anyway.

Thank you again for your patient help.

By the way, if I alter guest=true to guest=false I can choose any of the topics and answers the form asks me. I submitted that request too and wait for reply.

Link to comment

The Evernote Support immediately answered, so I'm in contact with them now. 

They did not find the point of error by now, but they are trying. Once they will have found a solution I will post it here.

Link to comment

This is at the moment the state of the problem: 

Zoe (Evernote Help and Learning)

29. Mai 2024, 11:24 MESZ

Hi Joachim,
Thanks for providing the requested information!
We've forwarded the details you provided to our developers for further investigation. We appreciate your patience and understanding very much.
While the issue is being investigated, please be so kind as to submit tickets by pressing the Continue as Guest button (pictured below).
We'll be working hard to prevent any such issues from arising in the future. Please be assured that enhancing the user experience of Evernote remains a top priority for us.
In the meantime, please feel free to reach out anytime you need.
Kind regards,

Zoe, Evernote Support Team Help & Learning | Youtube | Forums



  • Like 1
Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...