Jump to content

Import of .enex backup of Legacy local Notebook loses *created* date


Go to solution Solved by RonC,

Recommended Posts

Finally upgrading to 10 because of the imminent demise of Legacy. I had one local Notebook, so exported it to .enex., then updated the app.  For good measure, I also exported the Notebook when prompted during the first run of 10. I then imported the .enex file, and as has been reported by others, the "updated" date is unhelpfully set to the time of import. But worse, the creation date of all except for a few of the 279 notes is given as 1970. The few that are not 1970 are listed as having been created at time of import.  I had a look at the .enex file and the correct "created" date info is in there (as is the "updated" info), so it just looks like an import error in 10.  For example:

</span></div><p></p></en-note>]]></content><created>2023-09-15T17:49:22.347Z</created><updated>2023-09-15T17:49:47.631Z</updated></note>

I repeated the process and got the same result, except there were no 1970 creation dates; all were from today.

Any advice for how to get my created dates back to what they should be?

Link to comment

Man, that's sad to hear. It's just one more reason I've been loathe to drop Legacy (loss of certain key UI features--in Legacy but not in new--are another).

But here's one more thing you should prepare for: that export of all notes you did (all or by notebook) you did in Legacy? Try doing that in the new app. Can't be done: export can only be done on notes (not notebooks or all notes)--and even then you'll find you can't SELECT more than 100 notes at a time.

Not meaning to hijack your thread. I came to the forums today searching for info on this matter and found your note first. If there's a good thread (and especially a solution) on this other matter, someone can share it here (I may, if I find a good one). Just sharing that challenge, as kind of "the reverse side of the coin" about your import.

Hope we may hear some solution on that import matter...and before the drop dead date.

  • Sad 1
Link to comment
Just now, carehart said:

Can't be done: export can only done on notes (not notebooks or all notes)-

Youy are right that you can't export all notes but you can export notebooks from either the sidebar or the main notebooks pop out.

image.png.2c689f96d77019b7d3ea18f1cc643bd2.png

Link to comment
24 minutes ago, RonC said:

Any advice for how to get my created dates back to what they should be?

Not much consolation to you but importing enex files exported from V10 retain the creation date (provided you opted to export the creation date). Unfortunately I don't have any enex files created in legacy to test. Looking at the snippet you put in your post the date-time format does seem to have changed.

Your example (legacy)
<created>2023-09-15T17:49:22.347Z</created>

My example (V10)
<created>20210303T204130Z</created>

So to test the theory I modified the created date-time in my enex file to match the formatting of legacy and re-imported. It was imported with the creation date-time set as the current date-time.

I thought local notebooks were automatically imported into V10 when you installed it. Does that not happen anymore?

  • Thanks 2
Link to comment

Just downloaded Joplin and imported the same .enex file. Joplin's imported notes all have the correct creation date, so it's just a buggy import script on Evernote's part.

I'm new here -- do Evernote PMs/developers read this and create tickets, or do I have to do a separate bug report somewhere? Or am I dreaming, and should find my own solution?

Thanks for any help.

Link to comment
5 minutes ago, Mike P said:

I thought local notebooks were automatically imported into V10 when you installed it. Does that not happen anymore?

Yes, it does, it by "automatically" you mean on first run, the existence of a local Notebook is flagged, a dialog is displayed, allowing the user to click to export the Notebook to .enex. That is the end of the guidance. I had to "manually" import the .enex file that was created.

  • Like 1
Link to comment
  • Solution

I didn't hear back from Evernote support, so I solved the problem myself.  Here is the comment section of the python script I wrote:

# This script helps corrects inconsistent date formats between Evernote 10 and .enex files exported from Evernote Legacy.
# For a given .enex file, the script finds every occurrence of the form:
# "<created>2023-09-15T17:49:22.631Z</created>"
# and replaces it with
# "<created>20230915T174922Z</created>"
# which is the format that Evernote 10's import function assumes.
# Similarly, the script finds every occurence of the form:
# "<updated>2023-09-15T17:49:47.631Z</updated>"
# and replaces it with
# "<updated>20230915T174947Z</updated>"
# On completeion, the script reports how many replacements of each type were made.


# This script defines a function modify_dates_in_file which takes the path to the file as an argument. It uses regular expressions to
# find and replace the patterns for 'created' and 'updated' dates, and then writes the modified content back to the file. Finally, it
# prints the count of replacements made for each type.
# Remember to replace 'your_Legacy_export_file.enex' with the actual path of your file.

If you are an Evernote user, and would like the code, contact me. Please do not redistribute without my permission.

If you are an Evernote developer, and would like the code so you can fix this problem for your users (it will be of use even after Legacy is decommissioned, as long as the .enex files were exported before then), please get in touch and I'm sure we can work something out.

  • Like 3
Link to comment
  • 3 weeks later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...