Jump to content

Recent attachments broken/missing after clean install of Evernote

Go to solution Solved by doonyakka,

Recommended Posts

Hi, a couple of days ago, I wiped my MacBook Pro so I could reinstall everything from scratch (it's something I do about once a year, when my system starts grinding to a halt), but now, the attachments (PDFs and images) in all my recent Evernote notes (of which there are hundreds) are broken. By this, I mean that, instead of (say) a PDF, I see this:


If I double-click on the file, a dialog pops up with this error:

The file “65956498c8e7540008c84ee2.pdf” could not be opened because it is empty.

and then a 0 byte copy of that file is saved to a Failed Uploads folder on local.

I could restore each note from an older version but Evernote makes that so tedious - restoring doesn't overwrite the broken note but instead places it into a newly created Notebook, one per restored note... 😖 - and it'll take me the best part of a day, if not longer so get everything back the way it was.

Is there anything else I could try? Evernote appear to have removed all official support channels, but is there a way to contact them directly about this? Any help much appreciated.


Link to comment

The files are there on the web client, phew. I'm going to try deleting every trace of Evernote and doing a clean reinstall. Hopefully it'll sync from the server.

I reinstalled everything from scratch.

Link to comment

Seeing some very odd behaviour now. I've reinstalled Evernote and logged in, but the most recent note that's loaded is from a month ago. My notes are up-to-date via the web client. How is that possible? 

Link to comment

I'm seeing a lot of this type of error in the logs:

1/5/2024 9:27:18 PM
Level:warn Origin:Conduit
conduit-electron-worker [["ContentFetchSyncActivity: Failed to fetch content for offline availability for note 07182d2c-c1f5-4674-b584-92a5080796ab. Skipping note.","TypeError: Cannot convert undefined or null to object\n    at Function.keys (<anonymous>)\n    at Y.propagateOnly (file:///Applications/Evernote.app/Contents/Resources/app.asar/boronConduitWorker/586-a0b18615f16f9837d750.js:4:939105)\n    at Y.prepareIndexPropagation (file:///Applications/Evernote.app/Contents/Resources/app.asar/boronConduitWorker/586-a0b18615f16f9837d750.js:4:938505)"]]

Is there any way to contact Evernote support?

[EDIT: having looked around the forums a bit, I've come to understand that attempting to contact Evernote support and getting a response is likely to be an exercise in futility.] 

Link to comment
  • Solution
Posted (edited)

OK, the problem appears to be solved. These are the steps I took:

  1. Log out of the Evernote desktop client (VERY IMPORTANT - don't just uninstall it).
  2. A dialog will pop up, asking if you want to keep or delete your local data. DELETE IT.
  3. Uninstall Evernote.
  4. This step involves a third-party utility (either Hazel (by Noodlesoft) or AppCleaner (free)) and may or may not be critical, but I recommend it just in case: in Hazel, if App Sweep is enabled, you'll see a Hazel dialog asking you if you want to trash all the Evernote-related files and folders that have been left behind. TRASH THEM. If using AppCleaner, drop the app onto it.
  5. Restart your machine.
  6. Reinstall Evernote and log in. Hopefully you'll have your notes back. This could take some time.


Edited by doonyakka
Added useful info provided by @PinkElephant
Link to comment
  • Level 5

Thanks for posting.

You can reach the same by logging out and quitting the app.

Then use the app AppCleaner to remove all trac s of EN. The advantage over Hazel: AppCleaner is free.

Restart the Mac, download a fresh installer from the EN website, install, open and log in.

The last step will take a while: Let the EN app open in the background. It can take some days for large accounts to download everything from the server. It will run without, but the content will not be there for offline use.

  • Like 1
Link to comment

I can't help but share my recent experience, hoping it might be a lifesaver for someone else dealing with file-sharing struggles. After a clean install of my MacBook Pro, my Evernote attachments went haywire, and I was left with broken files and error messages.

In the pursuit of a solution, I checked the web client to find my files intact. That was a relief, but syncing them back to the desktop turned out to be a challenge. After a clean reinstall of Evernote, the most recent note I could retrieve was from a month ago – not the fresh start I envisioned.

Digging into the logs, I encountered errors that added to the confusion. Frustration peaked, but I was determined to get things back on track.

Finally, after several attempts, here's what worked for me:

  1. Logout and Clear Local Data: It's crucial; don't just uninstall Evernote. Log out and delete local data.
  2. Uninstall Evernote: I used AppCleaner to ensure a thorough removal of all traces.
  3. Restart and Reinstall: After a system restart, I reinstalled Evernote, logged in, and waited patiently for the notes to sync. It takes time, but it's worth it. This process, while not without its challenges, eventually brought my notes back to life. A big shoutout to the community for the support!

By the way, in the midst of all this, I couldn't help but wonder how a dedicated file-sharing service like Filemail might have made this whole process smoother. Imagine seamlessly transferring large files without the hassles. If anyone has experience with Filemail, I'd love to hear your thoughts!

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...