Jump to content

Cannot access my account page after the SMS 2FA announcement ... cannot contact support either.

Recommended Posts

Not sure if there are other evernote members with professional subscription facing the same issue regarding the recent announcement for removing SMS based 2FA.

I just noticed evernote emailer on the topic and tried to access my account today to remove SMS 2FA from my account and replace it with Google authenticator. problem is I got stuck at the page requesting me to enter the SMS verification code sent to my mobile, and that SMS message is never sent. tried the other alternative of entering backup codes, however it keeps refering me back to entering the SMS verification code. I tried entering some of the backup code that I have there at no avail (tried the 16 digits with dashs between and without still not working).

it is extermely furstrating that there is no way to reach evertnote support on the issue either. there is no email support contact and the only way to rise an issue is through the forums which I cannot log-in at because I cannot recieve 2FA SMS anymore !! silly that i had to create a dummy account to reach out for help.

not sure how can I manage this is there any support contact that I can reach out to solve this issue ? 

(p.s. this topic is not posted by my subscription account that I am facing the issue with, I am using another dummy account just to access the discussion forums as I have no other option to reach support for this)

Link to comment
18 hours ago, stream400 said:

tried the other alternative of entering backup codes, however it keeps refering me back to entering the SMS verification code.

Did you click the "I need help getting a verification code" link?


Then click the "Use a backup code" button


Then notice the wording on this page is a little bit different:


well -- at least for me it was different, since I was using the authenticator app before. Perhaps that wording is the same as SMS 2FA.

Anyway, I opened a browser window in Incognito mode and tried using a backup code (entered with all the dashes) following the steps from above and it worked for me to log in.

Link to comment
  • 1 month later...


I had to do a hard reset on my iphone and lost my authenticator codes that I used for my Evernote account. I did not save any back-up codes at the time I created my MFA. I have tried to contact customer support but no one gets back to me.

I need some assistance, please advise...



Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...