Jump to content

(Archived) issues in (28915)

Recommended Posts

After using the latest version for a while (on XP SP3 and Vista Ultimate SP1), I'd like to report what I found so far:

* while Shift-F10 now works (thanks a lot btw!), it still doesn't work properly:

- select a note in the note list (tab there, use key-up/down to navigate to a note)

- since when working without a mouse, my mouse cursor is usually somewhere at the border of the screen

- press Shift-F10

--> the context menu should show up somewhere in the note list near the selected note, but instead it shows up where the mouse cursor is (usually at a completely different place, sometimes even on a different monitor!)

* navigating the side pane with the keyboard is only working partly:

- tab to the side pane

- use key-up/down to 'mark' a tag

- pressing enter does nothing, only space will select the marked tag (enter should work too, but not just 'select' but select and deselect all other entries)

- if you have multiple notebooks, it is not possible to select one: neither space nor return does anything

* navigating through the different panes with tab doesn't work properly.

- select the side pane

- press tab (the note list is selected)

- press key-up a few times to select different notes

- press tab (now I'm not sure what exactly gets the focus, but it seems to be the notes) --> hint: make it UI wise more clear what has the focus!

- press key-up a few times to go through different notes

- now suddenly the note list is selected again

* send-by-email didn't work in the last version at all, now it's back to the same I reported here: http://forum.evernote.com/phpbb/viewtopic.php?f=30&t=5905

* create a new notebook. Once created, the new notebook does not have an icon in the side view. Only after restarting EN3 the icon shows up.

* select Attributs->created->since->this month

--> Even though it's may 10th, I have notes show up way more than just a month. Even if 'this month' actually means 'one month', that would still mean the entry from april 6th should not show up (see attached screenshot wrongdates.png)post-7948-131906062009_thumb.png

--> after some more testing, I can see that none of the entries in the 'created since' attributes tree is working properly. I even get for the 'today' entry notes back about two months (those notes showing up have neither been modified or had a subject change ever)

--> the same problem happens for the 'last modified' attributes

Maybe relevant for this issue: I'm using a German OS which means the date format is DD/MM/YYYY and not MM/DD/YYYY

Now to some (still) bad UI decisions made:

* while the notebook 'tree' in the side pane properly expands, the sub-notebooks are expanded at the same level as the root node, they're not indented as for example the 'Atrributes' tree. This is very confusing.

* the menu entries are always all enabled, even if with the current situation they won't do anything. For example, the Note->Merge entry should only be enabled if at least two notes are selected. If no or just one note is selected, that entry should be disabled. Most menu entries have similar situations where they should be shown disabled.

* in Tools->Options->Tape the font selection combo works ok, but I doubt that many users can really chose a font by just seing its name. There's a lot of room just below the font combobox, why not put an example text there which shows up in the font currently selected in the combobox? Or even better, use a custom combobox control which shows the fontname in the chosen font (see attachment betterfontselection.png showing an example of such a custom font selection combobox).post-7948-131906062011_thumb.png

* The "Create Notebook" dialog uses a combobox to select from three (!) notebook types. The hint text for each type is only shown once the notebook type is selected in the combobox. Much better would be if the dialog was a little bit bigger, with the three nb types selectable with a simple radio button. And of course the hint text visible below each radio button so it's immediately visible what each nb type is for.

* The "change dates" dialog to changed the different dates of notes has links to set the current date. A link is used to open a browser, not to execute an action. Please put a button there instead of a link.

* The tags which are not selected are shown in grey. Grey labels indicate that they can't be clicked on, that they're disabled. But of course they can be clicked and selected. This should be changed so that the currently active tag is shown in bold and the others normal (but not grey!).

* The buttons in the toolbar don't indicate that their active when the mouse cursor hovers over them. It's not immediately clear that you can click on them.

* The default ink tool settings comboboxes show the icons not with a transparent background, which looks ugly. See attachment inktools.png. post-7948-131906062013_thumb.png

Link to comment

Problems / Observations to share with Forum

24 notes actually

Updated to (28915) DESKTOP VERSION

Windows XP PR SP2 actualized to the day

Office XP (2002)


I declare that I am strictly following the statement from Microsoft stating that Administator session are for maintenance, installs, uninstalls, check-ups etc.... and I created a normal user session from where I do and keep all my work and data... (it is stressed by Microsoft in a (very) small statement...)

I NEVER WORK nor use programs (not even Office) from an Admin session, all my work is in the normal session.


1) Upon update in an admin session, all other users are updated (obvious) BUT search queries in admin session deleted ARE NOT deleted in normal user session... could be normal, but what will happen if I sync from my Admin session (with the data on the web) or sync from my normal user session??

2) I see NO CHANGE at all in the behavior of Tags in the Parent-Child hierarchy (still not implemented I guess, except for GUI beauty but not functional)

- A new tag created while on a tag (selected) will NOT create a child of that tag, it will create a new tag below the EN TAGS and placed in alphabetic order as a new Parent

- a Parent with 0 notes asssigned to itself but with assigned notes to children will NOT show ANY data if clicked upon (never)

- a Parent with some notes assigned to it and notes assigned to some children will ONLY show the Parent notes if clicked upon (double-click, triple-click, clikyticlickyticlickity,...)

- a double-click on a Parent (assigned notes or not) will switch to show the previously declared behavior in point above to showing the complete "all notes" behavior... weird! (switch always between the two view on consecutive clicks)

-The ONLY tag that will remain with the same showing view of ALL notes upon consecutive clicks is the "Tags" (EN implemented tag).

- The 2.2.1 behavior of clicking on different tag (causing an OR selection) still causes an AND selection in Beta3 which is very weird for upgrading users.

- Still not possible to have selected tag(s) immediately assigned to a new note.

- Still not possible to have keyword filters.

3) ATTRIBUTES children show weird behavior

If I click today (08-05-2008 11:49) and ask, for instance, my notes Attributes Created Since Today I will get the only note I wrote today PLUS all notes from 25-04-2008 PLUS one note from 30-04-2008???? wow!

if I ask for Attributes Created Since This Week I get note from the 23-04 up to today inclusive....!!!!

If I ask for Attributes Created Before Today (on a total of 25 notes in database) I get only 20 notes!!!! (I only wrote one today!!!! so expected result was 24!!!)

And so on....

4) DRAG AND DROP from desktop aplications (or from my documents etc...) (Note: Office XP 2002)

- still no links appear nowhere

- dragged a photo from My docs into EN OK (no link showing) but could NOT drag a Word .doc of 25 kb from its folder into EN B3 note pane nor to the Title pane

- dragged a Word selected text OK (no link showing)

- copied and paste an excel part of a sheet OK, no link showing



- Search remain any/and (soooooooooo limiting)

- Search not working with tag selection (as tag behave strangely)

- all: cannot be written in a search (give error message), and it is the default search (which is a AND condition and very limiting), there is no field "All/any" to be selected as in Web version), the "any:" must be written especifically in the search field in the Desktop version.

- as reminder of the tag problem, you should write the any: condition plus the Parent Tag plus every tag of the children to see all your notes (that is a lot of typing!)

- Is capable of searching for numbers like 09 or 09/ or 09/07 or like 5,240 or ,240 or 5, (although not highlighting the "/" nor the "," but this kind of search IS NOT POSSIBLE ON THE WEB Mozilla.

- Accents in words (like spanish "hesitación or algún" will only be found if search includes the accent... But highlighting and finding is correct in a search like alg* which will highlight the "alg" of algas or algún.... but only "algún" will be found if accent is mentionned. NOTE: THIS WILL NOT WORK ON THE WEB AS HIGHLIGHTING IS FAILING TO HIGHLIGHT PROGRESSIVELY. So: on the web, hesita* will corectly find the note but NEVER highlight it as it is an accentuated word. It will only highlight if you search specifically for "hesitación". This is a bore for us people who write in another language not english.

Link to comment
- create a new notebook. Once created, the new notebook does not have an icon in the side view. Only after restarting EN3 the icon shows up.

- if you have multiple notebooks, it is not possible to select one: neither space nor return does anything

These ones are fixed already.

Thanks for such thorough feedback, BTW! Some cases are filed already, some are new to us.

Link to comment


This topic is now archived and is closed to further replies.

  • Create New...