Jump to content
  • 0

Revoke access to Evernote Web does not work



Hi all,

Evernote keeps locking me out due to 2-device-limit. I recently logged in to Evernote web to accept a shared notebook (which didn't work either by the way) and am confronted with the limit since.

The problem:

Revoking access to Evernote Web via https://www.evernote.com/Devices.action  does not work. Once I click on revoke access button, I get logged out. Once I log back in, Evernote web is still there.

I also tried logging out Evernote web when I got the 2-device-limit dialog on my desktop client, but that didn't work (and I only have 2 tries for that anyway...)

Any ideas on how to resolve this issue (other than creating a new account and never using Evernote web again)?

Thanks already!

Link to comment

1 reply to this idea

Recommended Posts

  • 0
  • Evernote Expert

If recommend only using the web client and disconnect the desktop.

The two device restriction is very limiting for Free users. The web client is the best option to enable ready access to the account, settings etc 

If you've tried to revoke access more than twice you'll have to wait 30 days or pay for one month. If you decide to pay remember to cancel renewal a week or so before the renewal .



Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...