Jump to content

PDF gets broken/empty after changing it in (Apple) Preview, EN 10.57.5


Recommended Posts

I just encountered a new issue: I scan most documents with an Fujitsu Scansnap iX1600, an then a note on paper becomes a note in EN with a PDF inside. Often I write on "boxed" paper, so the empty second page appears also in the PDF or today one paper was 90° the wrong way round. Until now I just double clicked in in EN and then (Apple) Preview opened the pdf, I make my changes, close the file (I'm not even asked to save or anything) and then the pdf appeared in EN again correctly. 
Today: the same process, but after doing the process the pdf seems broken or empty. It just says "Untitled Attachment" no other text, like 1 of 1 page or the size 200 kB. Like no size at all. One note was even duplicated... It looks the same on the iPad and quiting EN and opening again didn't change anything.

Intel MacBook Pro, Ventura 13.4,

Evernote: 10.57.5-mac-mas-public (459854)

Does anyone have encountered the same? I also mail it to the support.

Link to comment
  • Level 5

You can save back into the note by hitting cmd-W to close the window in Preview, or cmd-S for an intermediate saving.

I had a similar problem in Preview a while ago - but the PDF was loaded from the Finder, EN was not involved. After a number of page operations, the file got corrupted and didn’t open any more. Maybe Preview sometimes gets a hiccup on page movements.

With EN you have the advantage that you can go to Note History. Open the note holding the pdf, and open the 3 dots menu. Choose note history from the menu. It will show prior versions of the note with their editing / syncing date. You can create a duplicate with the status back then, before your edit went foul. This copy won’t have your changes, but it isn’t corrupted, so you can redo your steps.

Involving support is always a good idea.

Link to comment

I did close the preview file window by hitting cmd-W... And for the second note I first hit cmd-S for saving and then closed Preview, both ways broke the pdf in EN.

But I was able to restore an old version of the note AND Evernote 10.57.10 was released in the meantime and I assume that this resolved the issue, because I tried the usual workflow again with the new version and now the pdf was immediately shown correctly. I noticed a lot of "Saving now" messages in EN, maybe the new conversion code was the issue, but of course it is difficult to find out now, where the error happened. But I'm quite relieved that the "restore old version"-feature worked, these notes were new and I still had the paper, but I was worried of course about old, unique notes. Thanks for your help!

Link to comment
  • Level 5

As I said, I had a pdf file corruption in Preview when using it off the finder. Can happen, I made many page operations in a rather big pdf file. In my case EN was not involved.

If it has to do with the EN version, no idea. But I doubt it has to do with EN at all.

Link to comment

Yes, of course, Preview could be the issue or my workflow. I also retried it only after 2 days, and then I also did a restart. The most important piece for me was the reminder for using an old version of the note!! And that feature worked well.

  • Like 1
Link to comment
  • Level 5

Actually it only happened to me once that Preview (probably) corrupted a pdf while editing. 

And I agree, if I had the original pdf in EN note history would have been very nice. I used TimeMachine instead, but version recovery on a note works with less effort.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...