Jump to content

When using the Mac app, following a note link attempts to display the target note using the web browser rather than the app

Go to solution Solved by Boot17,

Recommended Posts

Ok this problem has been around for a while but I don't primarily use the Mac for Evernote so I have made do.  My iPhone is my primary interface, followed by my iPad, then my Mac.  However, the Mac app has additional capabilities that I really want to take advantage of in my work flow.  However, every time I increase my Mac use, I encounter this note link issue, try to trouble-shoot (unexpected time waste), and eventually push the Mac aside and go back to my mobile devices.  This problem is a complete killer to my work flow and makes me want to write Evernote off.  I really like the app on the mobile devices and would love for it to work on the Mac for when I really want to engage with the application for an extended period of time.  I'm reaching out here as a last measure before I conclude the Mac app is worthless.  To add insult to the situation, every time I follow the Mac app note link, it dishes me out to the web version but first it wants me to provide my credentials.  Oh, and apparently Safari doesn't support multiple tabs so an additional note link click will display an error messaging reminding you of this fact.  This behavior is not "effortless note taking".

Please help because I can't seem to find a solution by reviewing the forum although it certainly appears to have surfaces as an issue with the introduction of version 10.

Screen Shot 2023-05-13 at 10.33.25 AM.png

Link to comment
  • Solution

95% of my Evernote usage is on the Mac and I don't experience the linking problem that you are having. All my note links keep me in Evernote in the Mac app.

There are two types of links to other notes in Evernote: web links and in-app links.

There are numerous ways to generate either link, but one of the ways is to right click on a note from the note list and you'll see a context popup menu like this:


However, both links show as "green" in the note editor so you can't tell them apart just from looking at them:


If you hover over the link and click the Edit button:


You will see if it's an internal link (starts with evernote:///):


Or if its a web link (starts with https:):


Note that the mobile apps don't open web links in the web browser -- they keep you in the app. However, the Desktop apps will open the web links in the web browser.

It sounds to me like you have created web links thinking that they are in-app links. However, you still get your desired behavior in the mobile app because it doesn't open web links in the web browser.

Link to comment

@Boot17. Thanks for taking the time to respond with very helpful details. Sure enough I had web links in places.  I have been aware of the internal link section preference (web link vs. an app link) for quite a while and struggle to believe that I would select web link when I know the outcome but can't deny that web links appear throughout my notes.  I can correct as I encounter and will scrutinize my workflow to see if there is some other way I am introducing a web link.  I can't rule out just plain ole operator error at this point.  I appreciate your time.

  • Like 1
Link to comment
  • 8 months later...

So this is still a problem for me.  My intentions were to test various permutations of source device and link insert methods and then report back to the forum on the combinations that result in problems.  Because I mostly work on my mobile devices, I have not been motivated to do so until tonight.  I really want to work on my Mac but this problem kills my workflow.  The Mac application has some nice features that I would like to take advantage of but ugh always with the web browser thing.

Link editing on iPhone 13 with iOS 17.2.1 and Evernote 10.66.0

Link result viewing on MacBook Air with MacOS Sonoma 14.2.1 and Evernote 10.71.2

1st test: (How I normally do it)

Edit actions:  

  1. In note A, copy a link using the ellipse (...) option and selecting "Copy internal link"
  2. In note B, paste note A's link by tapping the screen to get context menu [Paste, Select, Select All...] and then select "Paste"

Link Results: 

  1. On iPhone:  Displays note A within Evernote Application
  2. On Mac:  Displays note A in Web Application :(

2nd test: (An alternate way to do it)

Edit actions:  

  1. In note B, insert a link to Note A using the "Link" option from the Insert menu
  2. Select note A using the search function.

Link Results:

  1. On iPhone:  Displays note A within Evernote Application
  2. On Mac:  Displays note A in Evernote Application :)

3rd test: (Yet another way to do it)

Edit actions:

  1. In note B, insert a link to Note A using the "Note Link" option from the insert menu
  2. Select note A from the find note search tool

Link Results:

  1. On iPhone: Displays note A within Evernote Application
  2. On Mac:  Displays note A within the Evernote Application :)


Don't paste a note link as described in 1st Test (i.e. don't do what I do) if your workflow involves using Evernote across multiple Apple devices.  I may check that same results hold for editing on iPad.  Stay tuned.

Link to comment
  • Level 5

I think this effect is due to the way iOS handles connections between objects. The mobile client in general can’t have 2 notes open at any time.

The link is created when the first note is open. It is placed on the clipboard. Then the note is closed when the target note is opened.

Whatever the clipboard holds at that moment is inserted into the second note.

If you check out the link, it has a format like https——www.evernote.com-shard-<weird address>.webloc . This means it is already in that moment a Weblink.

Inserted it works fine, backlinks are created - but it will always work as a weblink.

To dive deeper into it, posting in the forum won’t change anything. You need to get into contact with support.

Personally I doubt this is anywhere on the agenda yet. And it may be the behavior of the iOS app can’t be changed to create in-app links anyhow, due to the OS restrictions.

  • Like 1
Link to comment

Agree that a correction to my reported issue is likely not on developers radar screen nor will it be any time soon. My solution is to modify my behavior.  My post is really a PSA for anybody who may have unfortunately adopted my now previous workflow. 

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...