Jump to content

Javascript Error when trying to open Evernote App

Recommended Posts


As of today I am having an issue when trying to open the evernote app (installed from Windows store). 

I am presented with the error - "A JavaScript error occurred in the main process" 

I've tried the usuals of re-install and reboot but with no joy. 

Running on Windows 10 22H2 on a Surface Pro X (with a Microsoft SQ.2 Proc), It was running fine just last week. 

Any suggestions would be greatly appeciated. 


Link to comment

Hey Gazumped, thanks for coming back to me. 

I've tried removing the app version and running the installer from evernote but I'm hit with a different error saying there is no associated file type for .lnk files just as the installer is about to finish. 

Any ideas?


Link to comment
  • Level 5*
1 minute ago, muddyfox said:

Any ideas?

Hmmn.  LNK files are just shortcuts in Windows - 1KB bookmarks that drive things like lists of recent files.  Don't ever remember any reported issues like that.  Maybe try Revo Uninstaller Free?  If it can find any Evernote files,  it will totally nuke any data that might have been left behind after a corrupted install and allow you a completely clean retry.  If that fails,  or if you uninstall with Revo and still have issues,  then it sounds like you may have other system issues.  If you subscribe - or can do so for a month - you can contact Evernote Support (who are not us) who may be able to help with that.  They may need to see your activity logs.  Or (longer term option) as a Basic user you can try @EvernoteHelps on Twitter.

Link to comment
  • Evernote Expert
1 hour ago, muddyfox said:

there is no associated file type for .lnk files

That's a Windows system error. Your favourite search engine will offer dozens of websites offering solutions.

Link to comment

Hi muddyfox,

the same javascript error here. I assume it is caused by an (auto)update of Evernote: Evernote offered me the update to 10.54.4- After installing it the error occured.

I deleted Evernote completely and re-installed the prevoius version. Up to now it works, but in the nearer future there will be the next auto-update. Let's see...

Link to comment
  • 4 months later...

Since the last update, I get the attached error message every time I open Evernote. Evernote opens in spite of the message, although it is a few seconds slower than usual.

Screenshot 2023-08-09 132007.jpg

Link to comment
  • Level 5

The pragmatic solution would probably be to log out and uninstall the app using Revo Uninstaller. Then restart the PC, install EN again, log in and try. This would heal a bad install.

The better solution would be to go through support - ,maybe they can find and fix an underlying bug.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...