Jump to content

Paste of PNG files fail in Evernote/Mac app, work in Evernote on Safari/Mac, Edge/Windows

Recommended Posts

Title says it all. I selected an article with images in it, which apparently were PNG files. When I paste them into a new note in Evernote app on Mac, they have a gray bar and say "Unable to render image in this format.". The same paste works fine on the web at evernote.com via Safari on Mac or Edge on Windows. Please fix this!

UPDATE: Paste of JPG files fails too in the Mac App. What is going on? It's certainly not that they are too large.

UPDATE 2: Fails in Windows 11 Evernote app as well.

Version: 10.44.8-mac-ddl-public (3632)
Editor: v156.1.19058
Service: v1.57.3

Screen Shot 2022-09-08 at 3.23.54 PM.png

  • Like 1
Link to comment
  • Level 5

OK, then the file itself is not damaged, it just don’t show correctly.

You can try to reach support (subscribers feature). 

Or you can try to uninstall and reinstall the EN client. To make sure all parts are removed use the app AppCleaner to uninstall, and check all program parts to be removed together with the app itself. When you reinstall, use the direct download, not the version from the AppStore.

Link to comment

Thanks @PinkElephant, I am doubtful that will help. I went over to a Windows laptop, and installed the Evernote app from the Win Store - first time it was ever on that laptop. Then I tried pasting the same article, and it fails there too. And it's not just one article, it's anything I have tried today - JPG and PNG files.

Link to comment

If you go to this site for Apple news, go into Reading view on Safari (View/Show Reader), Cmd-A to select all, Cmd-C to copy, go to Evernote App, do Ctrl-N for new note, Ctrl-V to paste - the one image here also needs up being unable to load:


PS - I just tried NOT in reading mode, copying the picture and some text and pasting it, fails again. I also tried highlighting and copy the image and some text using Chrome on my Mac, and it also fails, so it's mot a Reading View or Safari issue. Also - if I paste into the web site Evernote, it shows up fine in Evernote app. But the ones that fail in the App, look fine on the web!

Link to comment
  • 4 months later...
  • 4 months later...

I encountered similar issue.

My evernote versions is as below:

10.57.10-mac-mas-public (459878)
エディタ: v169.1.20965
サービス: v1.68.5
© 2019 - 2023 Evernote Corporation. All rights reserved


It said that "画像を描写できませんでした" mean "failed to render image".


Link to comment
  • 2 months later...
  • 2 months later...

I figured it out: it was net IT security protocol pushed out to my work computer from my employer. Doesn't allow uploading of screen grabs from work PC to EN. I found a work around by logging into web version on this same PC and I am able to paste PNGs here and then they populate through to desktop client and iphone. Thx!


edit - as of Feb 2024 can now update PNG and JPG from any machine across accounts and desktop app to online, but I am not sure if was IT change at my office or change to EN. Inconsistent behavior.

Edited by johnarush
Updated info
Link to comment
  • 2 months later...

The Evernote image paste saga seems like a head-scratcher. PNG and JPG both playing hard to get, even in Windows 11 – wild! Gray bars and "Unable to render" messages? No bueno.

Before pasting, maybe try to compress image? Sometimes it does wonders for these digital quirks! A quick pre-paste compression might be the tech equivalent of a magic wand. 

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...