Jump to content

Can't update

Go to solution Solved by PinkElephant,

Recommended Posts

I have been using Evernote for many years.  In the last two weeks I have been receiving popup messages urging me to download the newest revision.  I always click YES, and the next screen says "Unable to download Update now. Try later."  What's wrong?  My computer or yours?  The version i am running seems o.k. (308094) Public (CE Build ce-58.1.6897)

Link to comment
  • Level 5
  • Solution

You are running a pretty aged version (probably of the Windows client).

Probably the best method in this case would be to go to the EN website and download the new client. Since there may be different installation situations, you should read this help document first:


If then in doubt, contact support.

Link to comment

Yes it was an old Win client.  I had tried everything in the page you referenced already, except downloading a fresh version.  Fortunately the download is smart enough to recognize the existing installation, preserve settings, remove it, and install a current copy.  I'm up to date at last.  I just got a new computer and I think the ancient version came over from the old computer.  We still don't know why it wouldn't update.  Moot point now.  Thanks for the suggestions.

  • Like 1
Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...