Jump to content

I installed new version of evernote in my PC. Now it taked ~5 minutes to add a new note and the CPU usage is very high


Recommended Posts

Evernote is updated quite frequently, but I couldn't care less about all the new features -  I just want to have fixed the bug that causes an evernote.exe process to always takes 30% of my CPU soon after I start using it. Am tired of the frequent freezes this causes, and having to endure the fan noise just because of Evernote. Getting ready to migrate to OneNote over this... 😞

Miss the time when Evernote was a quick and small and stable app on Windows!

Regards,
Espen

evernote_high_cpu.png

  • Like 1
  • Sad 1
Link to comment
  • Level 5*
4 hours ago, Espen said:

I just want to have fixed the bug that causes an evernote.exe process to always takes 30% of my CPU soon after I start using it.

As you're a subscriber I'd suggest you contact Support - your logs could help them determine what's causing the issue.  I doubt it's a 'bug' - this is the first comment I've seen recently about CPU use;  if every Windows user had the same problem,  there would have been a little more fuss.  It is interesting that you have several sub-processes going,  though only one is a major cause of CPU traffic...  

https://help.evernote.com/hc/requests/new

Link to comment

Thank you for providing me with the Support link @gazumped

I agree - if it was a frequent problem it would probably have been fixed long ago. It might be a problem with only one specific (and quite large) note. I'll report it to Support and hope they find out why, and can fix it. 🙂

Cheers,
E

 

  • Like 1
Link to comment

I've reported this issue many times and it even moved back to legacy version for some time (about 4 months).

I hoped it would have been fixed in the meantime but it hasn't.

And it's not limited to a single machine. My colleagues experience the same issue.

CPU usage is so bad that your laptops battery charge won't survive longer meetings. Mine (Dell XPS 13 7390) is dead in 3 hours.

 

 

  • Like 1
Link to comment
  • 1 month later...
I see the same high CPU too on Windows.
Upgraded to 10.17.6 a few days ago (10.17.6-win-ddl-public (275), Editor: v126.2.16348, Service: 1.37.8)
Now I have high CPU whenever Evernote has focus (CPU drops down when just open in background) - which could be contributing to this. One thread running at 30% of CPU. Mainly when you've opened a note in a separate window - editing a note in the main window has 30% CPU when you are actively editing, but drops down when you stop typing. But when I edit a note in a separate window it runs at 30% CPU all the time.
Link to comment
  • 3 months later...
  • 5 months later...

I have the impression that the high CPU load will go away if I disable "Tools/Preferences/Check spelling while typing" (tested with WIndows 11).

Cheers,
T.

  • Like 2
Link to comment
  • 3 weeks later...

Great tip thofis!

I haven't had that problem again since I disabled spelling. Now Evernote on Windows is finally usable again! 🙂
Strange though, that Evernote themselves did not know about this!

Cheers,
ES

Link to comment
  • Level 5

It if known since last year that the spell checker has an significant impact on the CPU load and the system performance. But it is not the only reason, and the impact depends on the total computing power available.

I run with spell check and have no significant problems with CPU load.

Where I agree: Support should have it in their toolbox.

  • Like 1
Link to comment

Got here by googling this same problem. 

Disabling "Check Spelling while typing" definitely fixed it for me.

But I also found that for me it was the combination of "Check Spelling while typing" together with having a note selected that includes a PDF attachment (I didn't check other attachments).

I have a paid account that includes Searching within PDFs, so it may be that this "feature" is required for the CPU usage to spike when it's trying to spellcheck the docs or the metadata?

Link to comment
  • 5 weeks later...
  • Level 5*
2 hours ago, lisa-jean said:

I have the same problem here. hate this.

So have you tried any of the work-arounds mentioned here? Reported this to Support? (We're not them.)

EDIT - and please don't post the same issue twice I merged your other post here.

Link to comment
  • Level 5

Sometimes a process gets stuck and runs in a loop. Click on the arrow in front of the word Evernote, and the sub processes will open. Usually there will be one causing the pain.

You can try this:

- Quit the app (not only close it), reopen.

- Log out, quit, restart, log in.

In both cases use it then for a while, to see if it is back to normal, or the problem repeats itself.

If it comes back, it may be the app is running against a corrupted database. In this case you can rebuild it:

Troubleshooting PC:
  1. Go to File > Sign Out [name] from the menu bar.
  2. Select the "Remove my Evernote data from this device" option, then click Sign out.
  3. Restart your computer.
  4. Sign back in to Evernote

 

Link to comment
  • 2 weeks later...

so I have recently stopped using Evernote legacy and tried standard version again and now I remember again why I didn't want to use v10!

Jeez how is this possible to still be happening? This is no fun, because you know that energy prices will go up a lot in the whole world. Maybe it's about time this finally gets fixed! I just type few words in my note and the result is maybe 10minutes of very high power usage of Evernote processes. How ridiculous is that?

Link to comment
  • 2 weeks later...

Well, so I have done it - logged off with erasing of user data. Restarted computer, logged in and now I am looking at the loading screen for half an hour already an nothing seems to be happening! CPU load 0-0,3% and almost no disk or network traffic. No new lines for 50minutes already in evernote.log

Should I wait longer?

Link to comment
  • Level 5

Something is wrong …

The client starts within seconds, log in (if not saved from the last use), and then it starts to load data. All is visible.

Did you disable internet security stuff before installing ? What you describe looks very much like something blocking the client, inabling it’s use.

Link to comment

so after more then one hour the window changed and navigation pane appeared. CPU load increased to 1%. I seem to be able to open some notebooks, but the homepage is still loading... Still there is nothing new in the log files, so I wonder what they are for 😕

Link to comment

OK so the result is, that my Evernote works, but I have somehow broken the homepage :-] Regarding the CPU load it hasn't changed at all, BUT I found out it really is caused by spell check, so I just disable it and seems like no more high power usage of Evernote processes.

The thing is that this thread is already one year old, so I just think devs could have done something like not do spell check on laptops running from battery for example. That would probably help many people who don't have time to read forums and try some procedures (which don't help)

Link to comment
  • Level 5

To find out what helps is always try and error.

There probably is something specific to your laptop, but given the number of devices and software I don’t think we should go for a hunt.

When turning of the spell check worked for you, good. If it brings your laptop to its knees, probably it is short on resources anyhow. So turning it off for anybody just to solve the individual situation on your laptop seems a little bit beside the point to me.

Link to comment

Sorry, but I don't have a laptop, I have a PC and I didn't start this thread, so no, it's not an individual situation. There is multiple other people claiming they have this problem.

In my case the issue was not battery life (because desktop PC don't have battery), but rather increased fan noise, CPU temp and also frequently frozen window of note opened outside of the main EverNote window (via double click). It was also happening very often that after clicking on any link it would take about 20seconds before the web got opened. I am yet about to see if disabling of the spell check was related to this also...
Regarding shortness of resources - if Evernote is capable of bringing Ryzen 5600X with 32GB RAM to it's knees, then that's really not good :-]

Link to comment
  • Level 5

I am running it on an i7 (OK, on a Mac) - and the client "behaves" quite nicely.

What you describe (especially that it persists after a reinstall) points to a deeper problem. Thus contact support.

That some people seem to have similar problems says nothing. From appr. 200 Mio. users, most will be using Windows. There is such a wide build of PCs, with components from a very diverse supplier base, plus additional hard- and software installed that is is pretty easy to predict some users will develop problems.

EN runs in a sort of Virtual Machine, which adds to the system load. But this does not mean the load is necessarily high (all EN processes together are running on less than 1% on CPU at this moment on my Mac, while the client is idle, and they hardly ever exceed 30% in full use. This is 30% of one core, not of total CPU) - which leads to the conclusion that there may be an underlying issue.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...