Jump to content

Evernote Routinely Hangs with Mulitple Evernote Processes Running

Recommended Posts

Every time I use Evernote on my Windows 10 PC, when I am done and close the window, the Evernote process fails to exit correctly.  From then on, when I try to run Evernote again, no window appears.  I then run Task Manager and find that there are many different Evernote processes running. I can only get Evernote to run if I use Task Manager to kill all existing Evernote processes that are running in the background.



Link to comment
  • Level 5*

Hi.  Not sure what you're reporting or asking here.  Should the app hang mid-activity, it's possibly because you have too much else going on and Evernote can't find the necessary resources to complete. Killing any active processes will (usually) allow you to reload.  This is nature's way of telling you that multi-tasking isn't always a good thing...

I had similar experiences with a 4-year old Dell laptop which never seemed able to run Evernote v10 reliably. I've now moved up to an all singing/ all dancing new desktop with a faster processor and memory and an SSD and Evernote is fabulous again...

Not defending the company here - the app should work on any level of hardware;  I'd suggest you (and anyone else in the same situation) should report your situation to Support (we're not them) so that maybe they'll get the hint.

Link to comment
  • Level 5

There is a very simple answer to the observation / question posted:

In Windows, when you close an app (by the X or by the menu „Close“ command), it does not necessarily stop the app altogether. It just stops it being active in the foreground.

It is normal that EN uses a number of processes, this is by design. And when you leave EN running in the background, the processes continue. This means immediate startup of the app when activated.

To stop all processes in one simple step, use the „quit“ menu command, or simply the shortcut strg/ctrl - Q.

Problem solved …

Link to comment
On 6/5/2022 at 9:44 PM, Bradley Ward said:

I can only get Evernote to run if I use Task Manager to kill all existing Evernote processes that are running in the background.

As PinkElephant wrote "pressing" the X is not closing the app as one would expect on windows. It stays in background. But therefore it should start immediately if you restart it again from task bar. (just checked, worked like expected). Having to kill the processes to restart Evernote is not the expected behaviour. Maybe there is something wrong with your installation. Maybe you try fresh reinstalling?

  • Like 1
Link to comment
  • Level 5

As I said, a simple menu „Quit“ or a ctrl-Q (instead of closing, which is the X or ctrl-W) should kill all processes at once.

There is usually no need to apply the special forces of the task manager.

Link to comment
  • Level 5*

To completely shut down Evernote for Windows and all of its processes: File / Quit Evernote

Or from the Windows notification area (the far right of the Taskbar): right-click on the Evernote icon, select "Quit Evernote"

With respect to clicking the 'x' button on the main Evernote window, as noted, that just shuts down the main Evernote window, but leaves the Evernote processes active, so that restarting Evernote should happen more quickly. This is all by design and has been so for quite a while. I do this relatively often, and haven't seen it fail to restart cleanly, at least for a very long time. Click on the 'x', the main program goes away; click on the Evernote program shortcut, and it all comes back. If this isn't working, then you're probably in tech support territory.

Link to comment

I appreciate the multiple detailed replies on how Evernote should work.  It does  appear from these replies that Evernote appears to be a bit non-standard from normal Windows applications in that clicking the X in the upper right hand of the window does not do the exact same thing as a menu invoked (File | Exit) type of command. That is fine provided it worked as it is supposed to. But in my case  it does not work as many of you have described in this thread.

Here is what I am experiencing:

  1. I start Evernote by clicking on a shortcut on the main Windows 10 taskbar across the bottom of my screen.
  2. Evernote starts. The main Evernote window appears, and the shortcut icon on the taskbar also changes its appearance to indicate that Evernote is an active process.
  3. When I am finished using Evernote, I click on the X in the upper right hand corner of the screen. The Evernote window disappears.
  4. BUT: The shortcut icon on the Windows taskbar does not go back to the non-running appearance. It indicates that Evernote is still running. And I I hover over the shortcut with the mouse, the small popup window shows a minimized version of the no longer visible Evernote main window.
  5. AND: If I click on the shortcut icon on the taskbar the next time I want to use Evernote, nothing happens. Evernote does not start, and no window opens. Evernote is hung at this point.
  6. As I'm a software engineer by trade, I of course know how to open the Task Manager and see what processes are running. What I find is a long list of Evernote processes.  I have to start killing each active Evernote process one by one and eventually I will kill the one that is hung up. The rest of the processes then exit.
  7. I can then run Evernote by clicking on the taskbar shortcut.

After writing this reply, I ran Evernote and got an upgrade notification.  This problem has been going on for multiple past versions of Evernote and I always update to the latest version.  I just updated today to version 10.38.3-win-ddl-public (3437), Editor: v149.0.18202, Service: v1.53.4.  If this update fixes this problem I will report back on this thread.

Thanks for the help!


  • Like 2
Link to comment
  • Level 5

Thanks for this detail. I'm using Evernote on a Windows 10 laptop, and am also finding some peculiarities, including differences from (I think) how Evernote used to run.

  1. With Evernote not running at all, I start it from a desktop icon or one pinned to the taskbar (my preference). It takes 15-20 seconds, whether because of the Electron framework or EN phoning home or whatever. During this time 7 or so EN processes appear one after the other as background processes in Task Manager. Once EN is fully up and running, the pinned icon on the taskbar gains a blue underline, and the background processes (8 of them) shift to being listed under the running app.
  2. When EN is open, if I click the X at top right, the EN window closes, the EN icon on the taskbar loses the blue underline, and all running EN processes become background processes (per Task Manager). But there is still the white elephant EN icon in the hidden icons popup.
  3. Right-clicking that icon and selecting Open Evernote pops the EN window back on the screen instantly, open to whatever I was last viewing, with the running processes shifted to the running app.
  4. OTOH, when EN has been closed (paused??) with the X, clicking the icon on the taskbar (or the desktop) seems to start it from scratch: it takes 15-20 seconds, and additional Evernote processes appear in the background. But once the window is open the background processes disappear and the usual 8 processes are listed under the running app in TM.
  5. File > Quit Evernote closes the EN window, removes the white elephant icon, and exits all running EN processes (Ctrl+Q no longer does this in v. 10.38.3).

So that's what I'm seeing. @Bradley Ward, note the difference between my #2 and your #4: when I close (pause?) EN with the X, the pinned taskbar does lose the indicator of a running app, and hovering the mouse over it does not display a popup thumbnail window. So definitely two difference experiences. I hope that's some help. If the update doesn't fix the problem, you may need to do a complete uninstall and reinstall.

  • Like 1
Link to comment
  • Level 5

One sees processes called „Evernote“, but we don’t see a process called „Electron“. So what we see in fact is the Electron framework running, and inside of it the app itself is nested.

I think the best way to think about it is to think of Electron as a precision tailored Virtual Machine. It is derived from Chrome, and Chrome does the same. If we think about ChromeOS, we have an OS based on a browser. If you do not run it natively on a CPU, but inside of another OS, you get a VM driving a browser. When you strip the front end from the browser, you get a framework.

When you start EN, you first start the framework. It nests itself into the OS, and when it is operational, the app inside of it starts. Most of the time needed is to establish the framework, get internet connectivity, etc. the app start itself takes little.

If the app window is closed, the framework keeps running. These are the processes we see with the app closed. Opening the app takes little, because the VM is still up and operational. The benefit is the app is running in its own environment, and the framework handles the OS interaction. The app will in general execute in every OS supported by the framework. Code once, run many (which does not work entirely, as some bugs like copy & paste on Windows prove).

Downsides are a high resources consumption (as all VMs do), and that the OS interaction needs to pass through an additional layer. This layer will allow many actions, but as well makes some difficult or impossible. 

  • Like 1
  • Thanks 1
Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...