Jump to content
  • 1

CRTL-Q vs. global search - I am struggeling


mczin

Idea

I am struggeling with shortcuts for "search".  My issues:

  • global search: When I use my shortcut for global search, often a notebook is preselected. Which I did not set to be preselected. So, to use global search, I need to use the mouse to deselect the preselected notebook. Often I have to use the mouse addionally to use my shortcut for global search.  
  • CRTL-Q: It is not working, when I am working directly in a note (when curser is in note). But that's my usecase for a switch-shortcut: when I wan't to fast switch to another note. So, I need to click in the note-list to be able to use CRTL-Q.  I have to use the mouse addionally.  

In both cases, to use a search-shortcut in Evernote, I need (in allmost all cases) an additional mouse-click.

Am I doing something wrong?

If not, are you satisfied with this behavoir? 

How do you search? Any tips?

(All over, I am very happy with the new Evernote)

Link to comment

11 replies to this idea

Recommended Posts

  • 0
1 hour ago, mczin said:

global search: When I use my shortcut for global search, often a notebook is preselected. Which I did not set to be preselected. So, to use global search, I need to use the mouse to deselect the preselected notebook. Often I have to use the mouse addionally to use my shortcut for global search.  

The notebook is preselected if you are in that notebook. I personally would prefer the default to be "everywhere" but that is another issue. If you are not in a notebook the default is to search everywhere. So to go to "Notes" you can do alt+ctrl+2 and then search. So alt+ctrl+2 followed by alt+ctrl+F.

1 hour ago, mczin said:

CRTL-Q: It is not working, when I am working directly in a note (when curser is in note). But that's my usecase for a switch-shortcut: when I wan't to fast switch to another note. So, I need to click in the note-list to be able to use CRTL-Q.  I have to use the mouse addionally.

A quick look at the keyboard shortcurts (ctrl+/) will show you that to focus on the note list you can do alt+ctrl+\. No need to use the keyboard. I don't really understand why ctrl+Q is not available when you are editing the note and it has been raised before.

  • Like 1
Link to comment
  • 0
  • Level 5

About the preselection of the current notebook: It was introduced a few releases ago - based on user feedback wishing for it.

This is how to select „Everywhere“ without a mouse action:

  1. Activate search alt/opt & ctrl/cmd & F
  2. Type your search string
  3. A down arrow takes you to the notebook selection
  4. A second down arrow selects the „Everywhere“ filter
  5. Now hit Enter, it activates the selection
  6. Now a tab, takes the cursor back to the search field
  7. Hit Enter to search 
  8. The search runs for all notes and shows

…. or take the route described by @Mike P , or use the mouse.

  • Like 2
Link to comment
  • 0
5 minutes ago, PinkElephant said:
  • Activate search alt/opt & ctrl/cmd & F
  • Type your search string
  • A down arrow takes you to the notebook selection
  • A second down arrow selects the „Everywhere“ filter
  • Now hit Enter, it activates the selection
  • Now a tab, takes the cursor back to the search field
  • Hit Enter to search 
  • The search runs for all notes and shows

Nice alternative. Interestingly if you do the third and fourth steps first the text insertion point never leaves the text box. So you can just type your search term directly after and then hit enter. A few less key strokes.

  • Like 2
Link to comment
  • 0
2 hours ago, mczin said:

My shortcuts seemed to be mixed up.

In the shortcuts menu (ctrl+/ or help -> keyboard shortcuts or the little keyboard icon at the bottom of the sidebar) there is the option in the three dots menu at the top to "restore defaults". You can also change many of the keyboard shortcuts. General experience also suggests that the more different your keyboard is from a standard US keyboard the more problems you will have!

Link to comment
  • 0

Thank you @Mike P.

I tried to reset the shortcuts, but I have the same behavoir as before.

Many shortcuts are not working for me. May because WIN11 is the problem.

But the most important shortcuts are working, like global search.

So everything is fine for me.

 

  • Like 1
Link to comment
  • 0
  • Evernote Expert

OK. As a temporary experiment, switch to an English keyboard and see how the shortcuts work then. I'd change keyboard and reboot the PC. Check how the shortcuts work in Evernote. I suspect all will be well. Then reverse the process so you go back to your German layout.

You may need to change the keystrokes allocated to the shortcuts so that they don't conflict with the default Ger mean keys.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...