Jump to content

Index getting out-of-date

Recommended Posts


It is not unusual to have notes missing in the results after a search.  Had this forever with the new re-write -- I was hoping this would get fixed.

I have two notes with titles: "Techniques" and "Techniques 2", both tagged with "Woodworking", and both updated within a few minutes on January 23rd.  The search is for "intitle:Techniques" and qualified by Tag "Woodworking".  The result only shows the single "Techniques 2" note.

If I update the missing note on another machine and wait a few minutes for the first machine to get the change, the search works and finds both.

It would seem that the index is able to lose data over time.  I have not tried this to see if it is affected by including the Tag or not.  I think it might be the Tag.





Link to comment

I forgot to post the environment.  Sorry.

The problem machine is Windows 10, running the latest version of Evernote.  The secondary machine that I compare results to is Windows 10, running the pre-re-write version 6.25.  This older version still has important functionality I sometimes need.  

I did some more search results comparisons.  It doesn't appear to have anything to do with using a Tag - I see differences without searching with Tags. 

I've attached two screenshots, searching intitle:purchase* w no Tags, on each machine.  The indexing issue isn't strictly time related, as can be seen in these screenshots.

Paraphrasing an old friend, it seems to be "data-rot".  'Touching' the note causes the index to be updated correctly with the missing data.  This is a tough bug to find, or even to unit test for.  1934 notes in the notebook.

Screenshot intitle purchase 625 ver.jpg

Screenshot intitle purchase curr ver.jpg

Link to comment
  • Level 5

Not really that difficult. With nearly 8k of notes, my note count matches to the point between web, legacy and v10. Same with searches - i test it from time to time, and it just matches (we had a problem with upper/lower case tags behaving differently, but they fixed it).

The master is the data on the server. You can check this directly using the web client in a browser.

The legacy client has a local database with its own index. It can be broken, it can be reorganized. To do so, I think on Windows it was holding down the ctrl/strg key before clicking on Help. There should be additional options, allowing to run corrective measures on the local database.

Remark: With all the hype around legacy being soooo perfect, I regularly find that the local database carries mistakes. Nothing big, but if you are missing THAT note you know is there, but can't find it, it is big enough. We should stop hyping legacy - the double database sucks, and this means the whole concept sucks.

The installed v10 desktop client has its own local database as well, and it can have problems as well. Here the trick is to Remove the data once from the PC, which forces it to reload from the server. 

  1. Go to File > Sign Out [name] from the menu bar.
  2. Select the "Remove my Evernote data from this device" option, then click Sign out.
  3. Restart your computer.
  4. Sign back in to Evernote
A good sign that all this has worked out is to look up the note count in total, and in the single notebooks. It should match.
Link to comment

Thanks for the index re-build options.  Note that the only issues I see at this moment are in the current version. 

I don't mean to be picking on versions. I use the old version to resolve / verify searches on the current version that seem wrong.  The current re-write has come a long way - I'm glad to have it.  There are a few features I use in the original version that I rely on.  

Thanks again

  • Like 1
Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...