Jump to content

Evernote direct support to paid users not working anymore.

Go to solution Solved by Carlos Cadu,

Recommended Posts


I'm trying to contact Evernote support directly through the link:


Then clicking on the link "additional support options" (Evernote Personal, Professional, and Teams customers can also access additional support options).



As shown in this screen-recording (https://tinyurl.com/yafouzz3), I'm logged in with my Evernote account.

However, by clicking the link, I've been simply disconnected from my account and the link is not working.

I cleaned the browser cache, but the issue is there.

Is it a temporary issue with Evernote support, or have Evernote stopped providing direct support to paid users?

Is there any alternative to the link in https://evernote.com/contact ?


Thank you,


Link to comment

Thanks all of you for the prompt replies!

From my side, I can't access Evernote support by any means or links.

I tried the links in Chrome, Edge and Firefox and the behavior is the very same I showed in my screen-recording.

Just hypothesizing why I can't get support:

- I pay for a legacy plan that isn't listed in Evernote actual portfolio. 

- I live in an underdeveloped country and generally the service quality provided by any company is bad or below that (even they are outstanding abroad).

Link to comment
  • Level 5

The link I posted even works with a Free account ! It then restricts the available ticket types, but the support page itself is opening.

If you believe your location might be an issue, use a VPN service and connect with a server in a „rich“ country. Does not make a difference - EN does not restrict access to support based on the origin (tried it myself, just using my VPN to go to a less developed place).

The reason is most likely with your own computer, or with the network you are using.

On the computer: Security software, browser extensions, browser settings, ad blocker, local Firewall. It was reported that Google WOT web of trust interfered.

On the network: Local DNS servers with blocking abilities (Pi-Hole, UBloc), Firewall, other security software, closed ports (although port 443 needs to be open, if you are able to visit https-websites).

To tell an example: I can’t view your tinyurl-clip, because my security settings don’t allow to open it. Why ? Because this service is known to be a source of malware, placed there to work around blocked servers.

So it is blocked on my network. I disable the blocking app, and the video shows.

From your task bar you have a ton of software installed on your computer. Probably there is something among it that kills the connection to the EN support server. You just need to find out which it is.

Link to comment

Thanks for all information @PinkElephant

Indeed, the issue seems to not be related to the ones I first hypothesized. 

Also, it seems not related to my computer settings, since I'm getting the same error message "You have logged out of Evernote" (screenshot below) when I tried to access https://help.evernote.com/hc/en-us/requests/new from two different computers and my mobile phone.


What is strange is that from all devices' browsers I tried to open a request/support, I get in the browser address bar the link below that mentioned a certain email (which is mine, but it isn't my Evernote account email) 'has+already+been+taken'.


I tried different browses (also in private mode), I cleaned caches, disabled proxies and so on, but every time I try to access  https://help.evernote.com/hc/en-us/requests/new the error appears.

Do you know if it is possible to contact an Evernote representative through the forum to help me out solving this issue? 



Link to comment
  • Solution

Just informing to other users that may face the same situation that this was an issue from the Evernote end, related to my account login into the support system.

So if you aren't able to open a direct support ticket, send a DM to a staff member through the forum, and ask for an Evernote representative to contact you.

For referencing, the support ticket with the history and fix of this issue is Ticket# 3483580

  • Thanks 1
Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...