Jump to content

Mising images: image could not be rendered properly


Recommended Posts

On my laptop (web version of Evernote) I pasted some images in a note.  When I view it from another computer via the web interface random images in the note say "image could not be rendered properly" and clicking the download image link when you hover over the error it does nothing. 

I tried from the iOS app (also a registered device on my account)  and the same issue on the same images occurred.

Yet when I go back to the laptop I pasted them from they display.

Why is this happening?
When I got to school my presentation documents were incomplete so thanks for the D Evernote.

Link to comment
  • Level 5

Have you checked the file extension yet ?

This .jpg or .png behind the file name. If on the first PC it is set wrong, it may create a problem on other computers.

You can check by saving the attachment file from EN and look it up in Explorer. Maybe the extension is not visible, this can be changed.

If a jpg carries a png as extension (just one example, there is a ton of picture formats), it will not render correctly on many computers.

Link to comment

Thank you for pointing me in the right direction.  PNGs seem to be the issue.

The images I'm pasting in are screenshots mostly from printscreen/paste so I'm not sure what the working format is.

I see that images clipped from firefox's built-in screenshot function are the broken ones as well as any PNG files I pasted.  Again these display on the source laptop I pasted them from but any other device does not display them correctly.

To remedy this in the short term I and re-screenshot images from my notes (from my source laptop where they display correctly) and cropping/copy in Irfanview image viewer and pasting them back to EV.  This seems to be working.  I imagine is some bug around png files.

Link to comment

Interesting is that I get this behavior for .jpg images on Windows that i copy/pasted into it from Windows Edge.

image.png.4dc8c2de4c012f87a0e871296578d92c.png

 

But double clicking it shows it fine (Windows 11 Photos), saving it to, say, the desktop gives a proper jpg image with the proper thumbnail. I uninstalled and reinstalled the last version, just to make sure it was not an inherited problem.

image.png.1c6621ae74a03b492c9a43be4f25a527.png

Update: Android (10.27) also exhibits the same inability to show the picture in the note, but also allows to download it, and the download is just a normal jpg picture.

 

 

 

 

Link to comment
  • Level 5

Some picture programs use the file extension (xxx.png, xxx.jpg etc.), others use metadata to detect which compression algorithm was used, and how to uncompress. Since all modern software is build from libraries, it may well be that the code to display a full picture is different from the one used to make and display a thumbnail.

It is a know issue that sometimes the extension file type and the real algorithm used to create the picture are not the same.

Link to comment

There could be something to that, but I find it unlikely.

It opens fine with web browsers (well, the latest versions of Edge), Windows 11 Photos, Paint, Paint.net, Affinity, Samsung browser, Samsung Gallery, and an online metadata service does define it as JPEG. Nothing strange there.

Also, exporting the image (which shows more like an attachment that cannot be rendered) to the desktop and dropping it into a new Evernote note from there works. Also, importing with the web clipper works. Exporting the note with the supposedly non-renderable jpg image to PDF works.  

It is dragging/dropping or copy/pasting the original content (pictures and text) from the browser (Edge) that results in the problem. 

Exporting as .enex and re-importing the note also shows it as non-renderable in the imported note; nothing strange there.

In conclusion, I feel therefore tempted to indeed squarely suspect Evernote --- in particular the drag/drop copy/paste part --- rather than the format or content of the image. 

For anybody having the patience to submit a bug report or investigate, I attach a copy of the corrupted note. The image and the note are provided with the intention of allowing interested parties to reproduce a problem. I claim no ownership of the content, do not transfer any rights, and provide no warranties.

 

 

Image Corrupted, JPG or what.enex

Link to comment

The image rendering bug is a support confirmed issue since 10.0 which has been never solved completely. I regularly get in touch with support every few release cycles and they do not have an ETA. I am experiencing the exact same issues on Android only with all kinds and sources of image files. So I would not invest too much time digging for the root cause as it is probably a software issue of EN in the end. If your OS can show the picture, EN should also. I would please everyone encountering the issue to raise a ticket to get more focus on this by EN. Thank you.

Link to comment
  • Level 5

@Alxa Sure, if I read your postings, everything is Evernote’s fault. Lucky you - for some people the world is a really simple place.

My opinion: First this statement does not help any user coming here for help - even if it would be true.

Secondly I use a lot of pictures, from different sources, and have not come across a problem yet. Which does prove nothing, as does the opposite case. There are some posts about it in the forum, but not many - which makes it very unlikely it has its root cause in the software used by (most of) all forum members.

Conclusion: Trying to exchange and find out is never a senseless exercise - even when occasionally it leads to a bug that needs fixing, yes, by Evernote. 

Link to comment

 @PinkElephant when reading your postings you neglect input I gave. I am in exchange about this issue, read postings here carefully and spent hours with support on Android client. There is a one year old thread on this issue on Android which staff joined half way. Obviously nothing to do with simple world, but evidence. I will be lucky if this would change. Fortunately as you I did not see this issue on web or desktop. There seem to be other side effects which lead to the problem on other user accounts. Therefore contacting support maybe helps giving more data to fix.

Link to comment

Hi! i had a look at the note you attached and the image data in it is valid base64 jpeg image data. I embedded it in an html img tag and it opened fine in chrome, so i presume it will work in other browsers. Just in case: which browser(s) do you use? As far as I know, jpeg is jpeg is jpeg, but i'm not an expert on image formats.

 

evernote web is probably trying to pull the image from https://www.evernote.com/shard/s3/res/4059aed0-7f52-961f-4b8a-9a4da16dcadc. If you open the developer tools in chrome (or probably other browsers) to the network tab and reload the page, you'll see an entry starting with 4059aed0...

When you right click this entry, you'll see possibilities for Copy. Depending on your operating system you can select "copy as power shell" or "copy as curl" and then paste the text in a terminal window on your computer. This will try to download the file from the server.

Hope this helps

 

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...