Jump to content

Srivener link not working

Recommended Posts

OS is Windows10, Evernote 10.30.6-win-ddl-public (3202), Editor: v140.0.17554.

The link is copied/created directly in scrivener.
"Copy document and link"

Loaded link:

I recently considered leaving Evernote because it was not possible to open local folders.
I use that a lot and it's fine now.

Now this link doesn't work. From other programs the link is working. (Word, Xmind, etc.)
That's why I'm asking if there's a trick.

Link to comment

I've tried all that, hence the question.
When inserting
is automatically created
if I edit to
it's an invalid link (in Evernote, the link box turns red)
if I edit it to
there's a bug in windows
"Windows cannot find \x-scrivener-item:\\S:\creativity.scriv. Make sure
the name is entered correctly and retry the action"


Link to comment
  • Level 5*

Hmmn.  Some part of your link is not recognised by Windows - try file://"x-scrivener-item://S:/kreativita.scriv?id=FFF7A69D-915F-4757-8767-FD6C1F6A11F8" or file://"S:/kreativita.scriv?id=FFF7A69D-915F-4757-8767-FD6C1F6A11F8" or file://S:/kreativita.scriv?id=FFF7A69D-915F-4757-8767-FD6C1F6A11F8

- My local file links all start with the drive letter.  The x-scrivener bit might be confusing Evernote.  The punctuation could also be an issue,  hence trying the link with and without quote marks.  If none of those work,  you could raise this with Evernote Support who - if they don't have an answer,  they can ask the developers to add this in to a future version.  I also don't know if this is a Legacy -vs- v10 issue.  You may be able to get around it in Legacy,  if you can't in v10.

I'm not a Scrivener user so that's my best guess as to options - maybe an actual other user out there can give you a suggestion....

Link to comment

Thank you so much for your time, I'll try the support, we'll see.
It's a problem between Evernote and windows, Scrivener generates a link that works elsewhere.
Scivene is better to work with multiple texts, it has adapted to that.
I would like to have an overview of everything from Evernote.
Thanks again and have a nice day


Evernote doesn't take quotes, reddened box below.  


  • Like 1
Link to comment
  • Evernote Expert

If you create a shortcut on your desktop pointing to: x-scrivener-item:S:/kreativita.scriv?id=06F78DCC-3140-4C08-BE05-B5B396153533
does that open when you double click it? This doesn't look like a conventional WIndows 10 link so I suspect that it is an internal link that will be interpreted by Scrivener but not by Windows. If Windows doesn't understand the link then Evernote will not be able to Open it. A bit like putting an Evernote internal link inside another program. It just wouldn't link eg: evernote:///view/74240/s1/02a5540a-4686-43a2-8e14-2f5d9afcb588/8af91230-5957-4f67-b1c7-95667533cae Although Evernote internal links are interpreted by Windows if placed in a desktop shortcut.

  • Like 1
Link to comment
  • 1 year later...
On 7/6/2023 at 4:40 PM, sokrakes said:
After some time, I tried the link again, Evernote keeps automatically adding "http" and nothing above works.
If I save the link as a desktop shortcut, that works.
If I "drag and drop" (drag and drop) the link from the desktop to evernote, the link works from evernote. 

It appears that Evernote has a bug where protocols that are x-* don't work (an http: is added).  Protocols that don't start with x-*, like evernote:, tel:, file: (except for directories), drafts:, etc. do work.

Just submitted a ticket: #3712209a

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...