Jump to content

Evernote is broken on my Mac

Recommended Posts

Not sure it's related, but since updating to the Monterey OS, Evernote has become very troublesome (after years of working very reliably).

Right now, when I launch it, all I get is a black window with the logo in the center, surrounded by the endless "comet" orbiting around it, with a sequence of "tips" displayed below that. I deleted and reinstalled the app—no change.

Last night I was using it and suddenly it showed my notebooks contained 0 notes, and when I tried to open one, it said "You no longer have access to this notebook". What!

Several days ago, I went to use the Web Clipper in Safari and it caused a HARD freeze on my Intel MacBook. When I restarted, the Evernote app was apparently corrupted—I had to reinstall it to get it to work.

The only hunch I have on what could be causing this: trying to use the Web Clipper in Safari to clip a web page that's displayed in Safari's "Reader" mode. As I recall, this seldom if ever works, and it seems correlated with these problems. Possible?

Evernote seems to work fine on my iPhone and my Samsung tablet.

I need this to work!

Link to comment
  • Level 5

Web Clipper has its own reader mode clipping style, and in general does not like to clip when the page is already set to reader mode.

You probably need to repair your local database.

  1. Go to the Evernote menu, Preferences, and uncheck „Keep data when leaving“
  2. Log out of EN (File menu), quit EN (cmd-q). When asked confirm "Remove Data from This Device".
  3. If you want to be very sure, restart the Mac
  4. Open EN, log back in, wait for it to run an initial sync. 
Link to comment

Yes, I tried that procedure more than once the last time this happened, and it wouldn't work. Check my last reported issue for details. Only deleting the Application Support/Evernote folder restored operation.

I'm not doing anything weird with Evernote. Why does this keep happening?

Link to comment
  • Level 5

No idea what happens inside the black box - I think some piece of information gets (virtually) stuck, and makes the retrieval process choke.

To be fair I am distributing this procedure - but myself only used it once, when I checked it would restore the data without damage. No need since.

In general EN does not like jittery internet connectivity. You can run a speed test - watch out for the values for ping, jitter and packet loss.

Link to comment
  • Level 5

Since the latest update (10.28), I get a loading page on startup, for maybe half a minute. No idea what has changed.

Since I start the app shortly after starting the Mac, and the regular use is not altered, it does not influence my practical use.

If it would take longer, I would issue a support ticket.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...