Jump to content
  • 0

Can't fully remove formatting from a clipped website



I clip this website using the Evernote Web Clipper 7.17.0 in Firefox (on macOS): https://datatracker.ietf.org/doc/html/rfc7414

Now, I want to modify the formatting of what I've clipped, so as usual, I click the "Simplify & make editable" button (in 10.25.6-mac-mas-public (458831), or the web interface). It appears to simplify the formatting, but I'm unable to highlight or bold any text. I can insert text, however.

I believe it's because simplifying the formatting has placed the text in code block, where such formatting is still not allowed. I couldn't figure out how to remove the code blocks. I've tried copying and pasting without formatting, but in the browser at least, I'm still getting content in a code block.

Any suggestion appreciated, but I'm thinking this is a bug.



Link to comment

1 reply to this idea

Recommended Posts

  • 0
  • Level 5

First I can confirm that in the case of this web site, the result of a simplification is set inside of a code block.

This happens when directly clipping simplified by the WebClipper, and it happens as well after clipping normally, and then simplifying the web clip.

If it is a bug I leave open for discussion.

What I observe is that the original website is a pretty simple one, probably strictly HTML code, not even CSS or other stuff. But it is entirely set in monospaced font. This would be the same if the site contained code: Simple formatting, monospaced.

Probably EN tries to make the life of developers easier by identifying simple, monospaced content as "code", and places it into a code block.

If you want to talk to EN about it, issue a support ticket.

As a workaround, select the whole clip (cmd-A), then copy or cut it, and then paste it outside of the code block with the option "adapt style" cmd-shift-V. This will insert the content in a standard text format, including variable width font. Pasting it normally cmd-V only creates another code block.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...