Jump to content

Web Clipper - no longer supported in Firefox?

Recommended Posts

I can't get the Evernote extension working in Firefox.

The Evernote Web Clipper page says:    Available for Chrome, Safari, Internet Explorer (IE) 7+, Firefox, Opera, and Microsoft Edge (for Windows 10 or higher)

Tried updating FF, removing and reinstalling the EN Web Clipper extension, but it just won't load (EN Web Clipper icon doesn't appear on task bar, or in list of taskbar icons to add).

Should I assume that I just can't use it, or am I missing something obvious?

Done a lot of Googling on the topic, but haven't found anything useful yet.    <Sigh!>   Life is too short to waste...

Link to comment
  • Level 5*

Hi.  Welcome to IT,  which is the quickest way to get to the next road block in your life...  Browsers issue updates every day these days,  and it's possible that Fx's latest version is not compatible with the current Clipper.  If that's the case Evernote will catch up shortly.  Meantime if you've closed the browser down and restarted,  and removed the extension and reloaded,  there's nothing much more to do in Firefox.  Meanwhile it is possible to print web pages to PDF,  and copy/ paste content into notes.

You could make sure Evernote is aware of this by connecting with https://help.evernote.com/hc/requests/new for support - if you have problems with that, use 'account' from the drop-down options as an issue type, or use the help/ feedback link from one of the mobile apps.

Link to comment

Thanks - yes, I have been in the IT business for longer than I care to admit.   The one aspect of the business that i never get used to is the one you point out so eloquently:   "the quickest way to get to the next road block in your life... "

I will wait for EN to post an update - heck, maybe I have one waiting now.   Meanwhile, maybe this posting will attract comments from others with the same issue.

Appreciate your response.

  • Like 1
Link to comment
  • Level 5

Just updated to Firefox 91 on my Mac (BigSur). Usually I am browsing with Safari.

Web Clipper needed to be reinstalled after updating. It installed without a problem from the FF extension store. After authorisation to access my EN account works like a charm.

There can be many reasons for problems, among which colliding extensions and security software is probably the most common.

  • Like 1
Link to comment

Nope, disabled the MalwareBytes extension, removed and reinstalled the Evernote extension, but the Evernote icon still isn't in the toolbar.   Giving up, switching my default over to Chrome.   Hate Google, but at least Chrome works with Evernote.   (Well it does today, anyway.)

Computers are supposed to make our lives easier, and software is supposed to make working with computers easier.  <Sigh!>

  • Haha 1
Link to comment
  • 1 month later...

I'm having the same problem on my WIN10 PC -- Evernote Clipper is installed as an extension in Firefox, but the icon doesn't appear in the toolbar.

In following an earlier thread, I saw that many people reported this problem in mid-May, 2021, and it appeared to (was reported to ) be resolved.  But it appears to be back.  I will make sure I have the latest version of Firefox installed, and if that doesn't fix it I'll report it to the Evernote support link noted above in gazumped's post.

  • Like 1
Link to comment
  • 3 weeks later...

I verified that I do have the latest version of FireFox (and EverNote) installed, and the EN Web clipper will still not install properly on FireFox.  It reports that it installed correctly, but the EN icon never appears in the FireFox tool bar.

And the link to an EN Support page noted in a post above by gazumped, doesn't get me anywhere.  It does get me to an EN page for "Help and Learning" but there is no way to actually contact EN to report a problem.

Methinks perhaps there really isn't any EN tech support any more?  Posting messages to the user community may help in some instances, but that is not the same thing at all as company-provided Tech Support, which I believed I was paying for when I upgraded to Premium some time ago.  Now they have re-configured all their subscription levels, and I find I am on "Personal" . . . but I can't find a level that offers Tech Support.  How can that be?



Link to comment
  • Level 5

The easiest way to a ticket is through a mobile client - it avoids the help web site.

You can use this link:

Alternatively if you are on a desktop, log in on evernote.com, open the help pages , search for a topic, select an article and scroll down. You now see this, the support option not really neon flashing …


Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...