Jump to content

Evernote Web Clipper Fails hangs on Amazon Product Page Running in Google Chrome on Windows 10

Recommended Posts

As recently as a month or two ago, I had no problem clipping pages amazon.ca in Google Chrome. In fact, the web clipper had a special clip type just for Amazon product pages, and it worked brilliantly. Now it just hangs until I click the web clipper icon again.


I am running Evernote web clipper 7.14.0 in Google Chrome Version 92.0.4515.107 (Official Build) (64-bit)

Evernote for Windows 
10.17.8-win-ddl-public (2809)   Editor: v126.2.16348   Service: v1.37.10

Windows 10 Pro 21H1 build 19043.1110
HP Z2 Mini G5 32 GB, Intel i7-10700.


Link to comment
  • Level 5*
10 minutes ago, markeh said:

Same problem with Firefox. Amazon pages start with "loading web clipper", never go farther.

Anyone know a temporary work-around??

Hi.  At this stage I'm thinking Copy & Paste,  or use a screenshot - Evernote are aware (see thread) but you need to find another way to record what you need.

Link to comment
  • 2 weeks later...
  • 3 weeks later...

As a premium member, I was also able to post this as a service request, which I did Aug 24. Aug 25, I got this response:

Hi there,

This is a follow up email from the escalation that I mentioned.

Regarding the issue that Evernote Web Clipper won't work on Amazon websites, we received a lot of reports regarding this concern, some of the users experienced this issue on amazon.com, homedepot.com, wayfair.com, lowes.com, or other websites. This is the issue that we are already aware of. Our development team is still working on a permanent fix.

We still don't have the time, and date when this issue will be resolved. We really apologize for this matter.

  • Like 1
  • Thanks 1
Link to comment
  • Level 5
On 8/10/2021 at 9:55 PM, CalS said:

Add me to the list for Edge, Vivaldi., and Brave.  For Some reason Firefox still works.  😕

Probably it is because FF uses their own web engine. The others are AFAIK based on Chromium/Chrome.

Link to comment
  • Level 5*
3 hours ago, PinkElephant said:

Probably it is because FF uses their own web engine. The others are AFAIK based on Chromium/Chrome.

Well FF has stopped working now.  0 fer.

Link to comment
  • 1 month later...
  • Level 5

Just tried it on some Amazon pages (Safari 15, BigSur 11.6, WebClipper 7.15): Did the job.

It would be good if for WebClipper the same type of release notes would be published as for the EN clients. The improved release notes introduced with v10 make it far easier to learn what's new and what's fixed.

Edit: Don’t use GMail

  • Like 1
Link to comment
12 hours ago, Jay-Bob said:

Hi @Reuven, this should be fixed on version 7.15. Can you please double check and see if your extension has updated? If the issue is still happening for you on 7.15 please do get in touch with our support team.

I just updated to extension 7.15 on Chrome for macOS and clipping Amazon listings works, but clipping Gmail emails does not. I was under the impression that these fixes would ship at the same time - are the Gmail fixes delayed? Coming soon, I hope?

Link to comment
  • Ex Employees

@Paul A.Amazon fix is ready and released in 7.15; Gmail fix will not be in 7.15 or 7.16. The Gmail fix is still in development but will be coming asap, but no eta at the moment. Possible workarounds to consider in the meantime, hopefully the Evernote for Gmail add-on or forwarding to the incoming Evernote email address can fill in until then.

  • Thanks 2
Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...