Jump to content

Recommended Posts

Ciao,

i have several saved searches which use the -tag option to exclude tags, suddenly it stopped to work, on Legacy the same saved search works. I know  how to create new saved searches, but one things that's missing that I can't figure out is how to exclude certian tags from saved searces.

It used to be -tag:XYZ, but now it's not letting me do that, I can only search for specific tags. Anyone know a way to exclude tags from a saved search? These searches are important to me, what I'm missing here? Is it a bug?

Thanks in advance for any advice

ciao

  • Like 3
Link to comment
42 minutes ago, Friestok said:

It used to be -tag:XYZ, but now it's not letting me do that, I can only search for specific tags. Anyone know a way to exclude tags from a saved search? These searches are important to me, what I'm missing here? Is it a bug?

This is very strange and worrying. -tag:XYZ still works when you type in a search but not for a saved search. To give an example the search

tag:R -tag:+*

is supposed to bring up all notes tagged with R but not containing tags starting with +. It works as expected:

image.png.4640f7b4e190b9e4fdfa69da0d69aa7d.png

Note how the tag:R is not converted into a lozenge. Using the previously saved search for this gives the wrong results:

image.png.bb821a7618cf7ca4ee26ddbd8bb5bee0.png

A random selection of notes. Not even all the notes that contain the R and a tag beginning with + .This used to work in V10

Saving the search that did work leads to the same faulty saved search. Something very strange here. As expected I get the same behaviour on the web version. 

Definitely a bug.

 

  • Thanks 1
Link to comment

The streange thing it worked untill the last update, I liked the new feature and began to use more this than legacy, and the seaved search with the -Tag worked, yesterday evryting broke after new update.

  • Like 1
Link to comment

FWIW I'm experiencing something similar on the Mac desktop version. I had a saved search for -tag:* and in a Notebook called ACTION PENDING. Since the last update, the saved search is returning results with tags when there should be no tagged notes in the results. 

It does appear connected to the last updated.

Link to comment
  • Level 5

After the initial phase, all clients are pretty much in sync with updating. The releases usually are available a day or two apart, which may well be the AppStore release delay.

Desktop is on 10.16 now, mobile on 10.12.

Link to comment
6 hours ago, PinkElephant said:

After the initial phase, all clients are pretty much in sync with updating. The releases usually are available a day or two apart, which may well be the AppStore release delay.

Desktop is on 10.16 now, mobile on 10.12.

Right. I haven't received the 10.12 update yet, so I can't say if this search problem is present for me there.

Link to comment

I'm an Android user. Play Store rollouts take up to a week from what I understand. I'm sure I'll get it, but as of right now it's not available for me. However, if it's going to break my saved searches, I'm in no rush.

Link to comment

I'm having a virtually identical problem. I spent half an hour with tech support, sending them logs and screen shot and...nothing. They're passing it on to the developers. I think it's clear this was a major error in the new release. I hope they can fix it soon!

  • Like 1
Link to comment

I'm seeing this as well. saved search "tag:bills -tag:receipt" works manually, does not work as saved search/shortcut in windows (10.16.7) but does work from my iOS devices (pad & phone)

Link to comment

Thank you for your post--this enabled me to give it a fix, if an awkward one. The -tag command won't work in conjunction with the filters, but if I put ALL the tags in the upper left search bar, it works. It's the filter system that doesn't work!

Link to comment

Quite relieved in a way to find this is a bug & not a feature like the horrible new ctrl-alt-T dialog. My entire workflow depends on a bunch of saved searches and some important ones have been broken by this -tag issue. Hopefully it will be fixed soon.

  • Like 1
Link to comment

Yes--thanks for your post. I always thought it was very awkward to have to put tag filters in one area and -tag filters in another. Now I have to manually add them all into that little search bar.

Link to comment

Yeah. I understand problems come up, but they kept insisting it was just me. Also, when I reviewed a beta version, I told them that having a half-and-half search function (the "positive" tags in one place and the "negative" tags in another) was going to lead to problems. And it did.

Link to comment

I have been having problems with the -tag:"xxx" as well.

Today I just had a problem with a tap + updated today. If I search for updated today I find the note and it is tagged as PETS. But if I do, tag search with pets then add the updated today it does not find anything.

image.thumb.png.a4f16ad04bc1b5caf703f0261c96ee7c.png

↑ This is the PETS tag first then adding the updated:day tag to it.

But I do updated today only, I locate 17 notes and one of them has the PETS tag. ↓

image.png.9b2e3c3713cc0034033b7e875f70135f.png

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...