Jump to content

Sync issues on Evernote Legacy 6.25.2 but not on 6.25.1 or any other version


Recommended Posts

I've got a ticket open with support for this issue at the moment but just throwing it out to the hive mind, as we've tried a few things without success.

I've got a new work laptop (a Dell XPS 9310) on which I've installed the Legacy client, but it will not complete a sync.  It gets to roughly the last 200 notes and then gives the red sync icon.  It syncs "inward" (i.e. note changes done on other clients appear in the app) but not "outward" (no new notes or edits from this machine go out).

I use Evernote on several other devices: another windows PC with 6.25.1 (green icon, pre "Legacy" tag), a Macbook with Legacy 7.14.  My previous work laptop was a Macbook with the last green icon 7.x client (can't remember the version) and that worked fine.  There are no sync issues with iOS or Web.  I've had the 10.x client on this machine with no sync issues either... just the multiple and well documented issues that make me want to stay with the legacy desktop clients for now.

So, assuming most other folks with 6.25.2 on Win 10 are ok, there must be some change in this version that conflicts with something in one of my 4000+ notes.

Here's a log excerpt.  It's always that same error message, and always just after an INFO event saying  "96% Submitting a batch of 70 note calls, size=7.6 MB"

14:35:47.782 [INFO   ] [2052] [29184] 96% Submitting a batch of 70 note calls, size=7.6 MB
14:35:47.931 [DEBUG  ] [2052] [25664] 96% CSyncThreadPool::OnPooledThreadFinished: 0d1f3b68
14:35:47.931 [DEBUG  ] [2052] [25664] CAppController::OnENThreadEnding: Ending thread [25664] threadPoolThread
14:35:48.681 [DEBUG  ] [2052] [29184] CGoogleAnalyticsBasicEvent::ctor: crash EDAMSystemException NoteStore:getResource 
14:35:48.681 [DEBUG  ] [2052] [29184] CGoogleAnalyticsExceptionEvent::ctor: EDAMSystemException:%201529a327fa885059ab9844ac0f368b12%20(4)
14:35:48.681 [ERROR  ] [2052] [29184] 96% EDAMSystemException: errorCode=INTERNAL_ERROR message="1529a327fa885059ab9844ac0f368b12"
14:35:48.681 [DEBUG  ] [2052] [29184] 96% CGetNotesDelegate::dtor: 1637df40
14:35:48.681 [DEBUG  ] [2052] [29184] 96% CSyncGetNotesTask::Run: FINISHED tid=7200
14:35:48.682 [DEBUG  ] [2052] [5752] 96% CSyncTaskList::WaitForAll: 17 tasks done, result: 0
14:35:48.682 [DEBUG  ] [2052] [29184] 96% CSyncThreadPool::OnPooledThreadFinished: 16227a18, syncGetNotesTask
14:35:48.683 [INFO   ] [2052] [5752] 96% Connecting account xxxxx
14:35:48.683 [DEBUG  ] [2052] [5752] 96% CNoteStoreClient::CreateNoteStoreClient: shardId=s122
14:35:48.683 [DEBUG  ] [2052] [5752] 96% CThriftTransportProvider::Get: REUSING 0948c6a0 1 www.evernote.com/edam/note/s122:443
14:35:48.683 [DEBUG  ] [2052] [5752] 96% CSyncTaskList::WaitForAll: 17 tasks
14:35:48.683 [DEBUG  ] [2052] [5752] 96% CSyncTaskList::WaitForAll: 17 tasks done, result: 0
14:35:48.914 [DEBUG  ] [2052] [5752] 96% CSyncAccountDelegate::SaveSyncUploaded: syncState.uploaded: 3317443 bytes
14:35:48.916 [DEBUG  ] [2052] [5752] 96% CSyncAccountTask::Run: FINISHED tid=1678
14:35:48.917 [DEBUG  ] [2052] [5752] 96% CSyncAccountDelegate::dtor: 17898378
14:35:48.918 [DEBUG  ] [2052] [5752] 96% CSyncAccountTask::dtor: 0d2a9b18
14:35:48.918 [DEBUG  ] [2052] [5752] 96% CSyncThreadPool::OnPooledThreadFinished: 0d1fd790, syncAccountTask
14:35:48.930 [DEBUG  ] [2052] [24828] 0% CBaseController::OnBaseTranCommitted: C:\Users\xxxx\Evernote\Databases\xxxx.exb
14:35:48.930 [DEBUG  ] [2052] [24828] 0% CSyncClientTask::Run: FINISHED tid=60fc
14:35:48.930 [DEBUG  ] [2052] [24828] CSyncController::OnSyncClientTaskStopped: flags=00000031
14:35:48.930 [INFO   ] [2052] [24828] Client synchronization finished, status: failed

The string in the INTERNAL_ERROR error message (and in the CGoogleAnalyticsExceptionEvent above) is obviously an object ID, presumably a note or attachment.  That string is the same every time (on 2 separate machines).

Any Evernote API gurus who can decipher this log?

If I could narrow down the problematic note it would help.  Or at least the 70 notes (or less, as it says 70 note calls) it's in, I could export and delete them one at a time, but I don't know the ordering.

Link to comment

Just looking at some of the options under the extended help menu (CTRL-click Help) and noticed Enable HTTP Request Batching.

Hmmm, I wonder.  That should help identify the suspect.  The sync is going to take a while though.

Link to comment

My $0.02: When I started with Evernote I used to get excited about troubleshooting sync problems, trying to narrow them down in hopes of getting a readily reproducible bug. I gave up on that because there are too many variables, too many different sources of sync problems, and support is of no help getting to the root cause. Just when you think you have a problem isolated and reproducible, the pattern changes, or the problem goes away. Also, the developers rarely act on an isolated, reproducible bug anyways.

Link to comment

@John in Michigan USA you're right about the amount of help support has been, but fortunately doing the un-batched sync and turning on all the logging details enabled me to fix my database.  I was able to narrow the search to two notes with attached PDFs.  One PDF appeared to be corrupted and one was on the large side; but not excessively so and I couldn't see anything wrong with it.  It was viewable both in Evernote and a couple of other viewers.

Removing these two fixed it, but only after deleting and recreating the database exb file and all index files.  I might try to re-add the large PDF from the export to see if that was actually problematic or a red herring.

I'd love to know why these notes were fine on all other versions but 6.25., but the main thing is I can again use (a usable version of) Evernote on my work laptop. 

As a one time developer my suspicion would be they've implemented stricter validation of some sort in this version.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...