Jump to content

V10 just doesn't work at all. I need V8 app back.

Go to solution Solved by joki,

Recommended Posts


On Android smartphone, I was totally happy with V8 app. But right after updated to V10, nothing works now. No exaggerations.  This is the buggiest application I have ever seen.

It can not open any notes I have created so far, it can not upload anything at all. All it can do is to show three titles of my notes, on the newly introduced fancy home screen, and the titles don't open the note even if I tap on them. 

I really wonder anybody in Evernote can actually use V10 app in any productive ways. Except for debugging. I'm not trying to be sarcastic. This app just doesn't work.

I need V8 Android app back, because V8 worked. 


  • Like 1
Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...