Jump to content

Downloading and Printing PDFs does not work?

Recommended Posts

Hello everyone,

when I open a note with an embedded PDF I experience 2 issues:

  • downloading the PDF to local phone storage does not create a proper file
  • printing the PDF via network printer (HP) is not possible

When pressing longer on the embedded PDF there is a download Button (or selecting "save PDF" in the options menu) I can store the PDF locally. But the file is always corrupted, only 1024 kb file size, every time, no matter which PDF file. Therefore when I open the saved PDF with Acrobat it always say "corrupted PDF file, can't open".

For the second topic I did not find any option to print a note or PDF within the app. Downloading the file and print it with acrobat does not work, see issue above.

Any suggestions? Is it a bug or am I the only one who experience this?

My phone: Samsung Note 10+, Android 11, OneUI 3.1,Evernote version 10.8.2 (1112579)

Thank you.

Best regards,


  • Like 1
Link to comment
  • 11 months later...

I have same problem. I just spent three days fighting with Evernote over last problem - blank first pages when I scan into Evernote. Now, when I try to download a pdf from evernote it creates a blank file and doesn't even allow me to see the pdf option. EVERYTHING worked before last two updates. I hope they answer and fix this soon because I am about to DROP Evernote if this ***** isn't resolved quickly. NOTHING works like it used to they have ruined a good product with updates full of bugs.

Link to comment
  • Evernote Expert

I don't use network printers with my phone.

I download a PDF to phone storage and it opens just fine inside my viewer of choice. As it happens I dumped Acrobat in favour of FoxIt.

The options to print exist but I haven't anything set up to test.

Inside Evernote, the PDF viewer has a share button (top right) there is an option to share to a printer there but not, curiously, to share to a PDF viewer.

Link to comment

Guys, my Issue was 11 months ago... Meanwhile they fixed it and PDF downloading and opening within Acrobat works fine now. 

Just press long on the embedded file, release and then press the arrow down Button which appears and it will save the PDF to local storage. Then you can use Acrobat to open it or to print it. 

I hope it will stay that way 😁

Best regards, Martin 

  • Like 2
Link to comment

But still, this is half solved solution. A lot of manual work (save to phone and then again search for a file to open it). In v8 you just pressed on a PDF file inside the Evernote note and your PDF opened in your preferred PDF viewer app or got the Android app selection menu to choose from different PDF opening apps. This is how other apps are behaving and how it should be done.

  • Like 1
Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...