Jump to content

Can't clip in Brave browser

Go to solution Solved by gazumped,

Recommended Posts

  • Level 5*

Just installed Brave browser on Windows 10. EN Clipper has been fine for me in Chrome browser, but it's not working in Brave.

I was able to log into the Clipper extension, but cannot access options (the wheel just spins indefinitely as seen in snapshot below). And when I click on the Clipper extension, I just see a briefly flashing popup indicating that login was successful, but it doesn't try to clip the page the Brave browser is on.

Anyone experiencing something similar in Brave?


Link to comment
  • tavor changed the title to Can't clip in Brave browser
  • Level 5*
5 minutes ago, gazumped said:

I used Brave for a while,  but never had a problem with clipping - can you disable the various pop-up and cookie blockers and/ or whitelist Evernote anywhere? 

I just whitelisted the Clipper for all sites, and now it works. I'm also able to access Options.

Strange because I previously whitelisted the site I was trying to clip from, but that didn't work.

Thanks for helping me get it working.

But it sucks that I have to give such broad access to the Clipper. Unnecessarily intrusive.



  • Like 1
Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...