Jump to content

Evernote 10.4 jumping over next word


Recommended Posts

This bug has been reported before. I haven't seen Evernote acknowledge it, but it's been reported enough times that hopefully they've seen it and plan to fix it in the next version. In addition to other maddening bugs, such as the bug that deletes a word when you highlight a word and tap the shift key while using the Gboard keyboard.

The desktop app has been steadily improving the last few versions. I've been disappointed to not see the same improvement in the Android app (I've been using it since it was in beta), but I'm hopeful that changes soon.

  • Like 3
Link to comment

Yes, same here. I agree, extremely frustrating. 

There is nothing more basic to note taking than the ability to write plain text, but in my case it is sometimes even deleting the word the cursor jumps over making it near impossible to write anything like this. 

  • Like 2
Link to comment
  • Level 5

I'm still on v10.4 of the Android app. I have not been aware of this issue so went to test.  I don't have a problem. The edits worked just as I would expect.

Evernote 10.4
Google Keyboard 10.1.04.342850159-release-arm64-v8a
OnePlus 8
Android 11 (OxygenOS 11.0.4.4)

One of the challenges with Android apps is that problems can arise within the OS, the interaction between individual apps or with the specific app. Naturally we point the finger at the thing that changed last but it might be a more complex interaction. I recall that my keyboard was also updated recently as was my OS.  All about the same time coincidentally.

  • Like 1
Link to comment

I'm having this problem too. Very frustrating. I have Android version 10.4. Everytime I insert some typing within existing text and press the space bar, the cursor plays leapfrog and jumps to the point after the next word. I'll have to use EN's web version to avoid this glitch. Evernote techs, please fix asap! 🙏🏽🙂🙏🏽

 

Link to comment
  • Level 5
14 hours ago, Leah_73 said:

I'll have to use EN's web version to avoid this glitch.

I can't access Evernote Web on my device. The website says it isn't suitable for my device ;)

I don't know if the newer version 10.5 which is rolling out to those that have 10.4 will fix this issue.

 

Link to comment
  • Level 5

On iOS it won't open if the browser is registered as "mobile version".

When I hit the little AA-symbol left of the URL address field, I can ask for the desktop version of a web site. With this option, EN web client will open on an iPhone as well. It is not very good, but can be done if need be.

On the iPad since iPadOS the Safari browser is already set to desktop mode by default.

Maybe there is a similar option for Android.

Link to comment
  • 2 weeks later...
Guest matt12345

Same issue here running 10.5.1 on stock Android 11. I only noticed this starting to happen in the last couple of weeks when I've been using the app a lot so it's possible I just hadn't edited many notes on my phone for a while before that. Its extremely frustrating and annoying.

Link to comment
  • 3 weeks later...
Guest Brad b

Definitely frustrating. Having the same issue. Maybe we could all email evernote support at once to get some eyes on it...

Link to comment

Just started having same issue on Evernote 10.7.2, Gboard, Android 11.

No other apps have the issue, so it's not Gboard.

--

Reporting back (on July 11, 2021...original post April 12, 2021).  About a month after I reported this issue, somewhere in Evernote 10.8 stream, the issue seemed to be addressed.  Now 3 months later and running Evernote 10.12 and issue has definitely been resolved (for me).

Edited by Andy Fra
Issue was addressed by Evernote update.
  • Like 1
Link to comment
  • 2 weeks later...
  • Level 5

This issue has been very frustrating. I installed an alternative keyboard (I chose SwiftKey) and the jumping over the word issue isn't present.  So I can use SwiftKey instead of Gboard and all is well.  It seems, therefore, that the issue indicates that Evernote 10 isn't playing well with Gboard rather than a more general issue with keyboard input. Anybody have the problem not using Gboard? I can suggest trying SwiftKey as a positive resolution.

  • Thanks 2
Link to comment
Guest Jim

This is insanely frustrating!!!!!  Evernote, I loved your app until this bug started.  Now I am wondering if something else might be better.  Please fix this!!!!!

Link to comment

Same here. I was referred here after contacting member support about this issue. I'm using Evernote v 10.9 and Gboard v 10.4.04, both updated to the most recent versions. No issues with Gboard outside of Evernote. I also can't use Text Input Assistant to input text such as the current date or other snippers of text into Evernote like I did before. I will try a different keyboard as a temporary workaround, but I've gotten so used to Gboard. It's hard to switch to a different keyboard app. I sincerely hope the devs will get this fixed soon because the problem seems fairly easy to reproduce!

  • Like 1
  • Thanks 1
Link to comment
Guest GONZALO

Same issue. I'm on a Google Pixel 5G. I can't believe Evernote hasn't resolved this yet;

Link to comment

Same issue for me as well, so annoying. Android 10, Gboard 10.4, Evernote 10.9. As others mentioned, it goes away when I use SwiftKey, but I far prefer Gboard and hate to switch just for this one app. 

Link to comment
1 hour ago, matej1990 said:

V10.10 (1113552) beta fixes the issue!!! Freaking finally!

THANK YOU!

That is fantastic news! I hope others can confirm soon just to make sure the fix works for everyone.

Could you also check whether highlighting words and using the shift key to cycle capitalization is also fixed? Currently, that action deletes the word and sometimes jumps the cursor to the top. Thanks!

 

Link to comment
Just now, matej1990 said:

Yeah I checked and selecting text and taping shift key still deletes the text.

Also "paste as plain text" also does not remove formating from text.

Ooof. I had really hoped that a bunch of editor fixes might have landed all at once in the latest beta. :( Well, one small step forward, at least.

Link to comment
  • 4 weeks later...
  • 2 weeks later...
  • 2 weeks later...

Samesies! I'm on v10.11, Android, on a Samsung S10 with its native OS using Gboard (I think). When I place the cursor before a word and type something new, then hit spacebar, the cursor jumps to the end of the word on which I originally placed the cursor. A fix would be appreciated!

The workaround I have, which is awkward but might help people, is not to place the cursor at the very front of a word, but in front of the previous space before it.

  • Like 1
Link to comment

I recommend going back to v8 for android use. So far I did not find any text editing issue in the old version. It's also much faster to start the app - only 2 sec!

Drawback is, there is no auto theme switch (light & dark mode). Another annoying one is, that I always manually start app updates in Google Play store. So I have to always remember to not update Evernote to v10.

  • Thanks 1
Link to comment

This issue was fixed for me in a recent version but this bug was introduced...

I lodged a support ticket for that "jumping back one character" bug, and it was fixed in 10.12, which is great, but that version reintroduced the "jumping over the next word" problem.

I remember writing a basic text editor in an introductory programming course, I really don't understand why it's so hard to support basic text entry without the cursor weirdly jumping all over the place!  I don't care about the new "Tasks" thing when I came even enter and edit text properly.

 

  • Like 2
Link to comment

Yeah, ok, maybe I'm underestimating how hard it is to write a HTML based text editor.

Web based email client have been around for a very long time though; and I'm entering text in a HTML based editor right here in this low cost forum software with no issues at all.

All software has bugs.  My main issue is when really bad ones get through testing, and take a very long time to fix.  Then when they do get fixed, they get re-introduced later.  That's not a coding difficulty problem, it's a lack of testing, care and/or attention.

  • Like 1
Link to comment

Reading a little more about the perils of implementing a text editor in HTML...

https://www.mutuallyhuman.com/blog/the-curious-case-of-cursor-jumping/

It seems likely that the source of all these recent cursor jumping issues*, is with the inline manipulation of text, and/or the auto-save feature.

For things like the auto-creation of numbered and bullet lists, heading styles, text entry need to be intercepted and analysed in real time, if the cursor position isn't tracked properly, this can lead to unanticipated cursor repositioning from the user's perspective. 

It seems like there's known fixes for a lot of these issues, but the more inline automated text manipulation you do, the more testing, checking and careful cursor repositioning your code needs to handle.

So it looks to me like this is a matter of priorities - Evernote seems to be prioritising the release of shiny new features over application stability and predictable performance.  New features are great, but only if they don't break basic expected functionality, like, you know, being able to enter text.

---
* - There's been at least 3 separate cursor jumping issues that we've been afflicted with recently:
1. Cursor randomly jumps to the start of the note (fixed, for now)
2. Cursor jumps back one character after entering the first word on a new line (fixed, for now) - and;
3. Cursor jumps over the following word when editing within an existing text block (still not fixed reliably)

 

  • Like 3
Link to comment

** Update: Now fixed. Updated to v10.12 (1115297) on 29th June and now works correctly. Change log just says "various bug fixes"

--

Same issue here - if you put the cursor at the start of a word and type to insert some text before that word, the text you type appears ok, but when you hit <space> - a space is inserted but then the cursor jumps to the end of the next word. Very annoying.

Android - Google Pixel 4 XL. Evernote v10.11 (1114563) - and just updated app to v10.12 (1115297) - and still the same.

Evernote? Can you acknowledge this please? This post started 4 months ago.... 4 months with all your Android users not being able to enter text reliably..?

Can anyone with a subscription log a support call or anything? I've really considered subscribing but with the amount of bugs like these that take months and months to fix I don't have any confidence that that would get me anywhere with getting these sorts of problems sorted - unless anyone has experience otherwise?

Edited by dantek
Issue fixed
  • Like 2
Link to comment

Happy to see I'm not the only one frustrated by this annoying habit of jumping words, but sad it's not fixed yet. I love evernote but this drives me insane. Evernote please fix this bug.

  • Like 1
Link to comment
  • Level 5

I have a support ticket for this. The issue was fixed but then broke again.  Part of the issue is that Evernote and GBoard don't play nicely. Alternative keyboards work fine with Evernote.  So it could be an Evernote change that caused the problem or it could be a GBoard change.

I can say that the issue is known but not how long it will take to resolve. I changed keyboard and the problem was solved as a temporary workaround.

  • Like 1
  • Thanks 2
Link to comment

I think a lot of us on this forum reported this problem to support. So they should be very aware of it.

14 minutes ago, agsteele said:

Part of the issue is that Evernote and GBoard don't play nicely. Alternative keyboards work fine with Evernote.  So it could be an Evernote change that caused the problem or it could be a GBoard change.

I think this is good thinking. The problem is, that other apps on my phone are working fine with GBoard. For me it's just Evernote that is the problematic one. 

I say vote with the wallet. Don't pay for a premium subscription if you think Evernote experience is not "premium". IMO at the moment on Android it is not worth paying for a subscription.

  • Like 2
Link to comment
On 6/29/2021 at 10:11 AM, matej1990 said:

I think this is good thinking. The problem is, that other apps on my phone are working fine with GBoard. For me it's just Evernote that is the problematic one. 

I say vote with the wallet. Don't pay for a premium subscription if you think Evernote experience is not "premium". IMO at the moment on Android it is not worth paying for a subscription.

Agreed on both counts. The Android app is important to me, so I canceled my Premium subscription until they bring it up to snuff.

Link to comment
  • Level 5
55 minutes ago, matej1990 said:

Must be some server side editor change. I installed v10.12 and there was no jumping over when hitting spacebar.

Or, as we've noted previously, a change at GBoard side of things - or both. For now the Gboard thing has been resolved ;)

Link to comment

I'm on version 10.12 (build 1115297), and without updating anything, this problem seems to have been resolved. Something must have changed server-side, but I like to think that it was me logging a support ticket that got them to fix it 😉

  • Like 1
Link to comment
9 hours ago, agsteele said:

I got v10.13 today and the keyboard issue with GBoard appears to be fixed again :)

That's good news. Would you mind testing the "highlight a word and tap the shift key to cycle capitalizations" and see if it still deletes the word?

Thank you!

  • Thanks 1
Link to comment
  • Level 5
15 hours ago, Paul A. said:

That's good news. Would you mind testing the "highlight a word and tap the shift key to cycle capitalizations" and see if it still deletes the word?

That feature is still as you have previously noted - the word is deleted.  Might be best to raise that as a separate thread or add to one previously started on the specific issue to give it better profile.

  • Like 1
Link to comment

Now fixed. Updated to v10.12 (1115297) on 29th June and now works correctly. Change log just says "various bug fixes". Or GBoard updated 7th July (not sure what version to? Not sure how you see that?) so could be that too.

Link to comment

 

2 hours ago, dantek said:

Now fixed. Updated to v10.12 (1115297) on 29th June and now works correctly. Change log just says "various bug fixes". Or GBoard updated 7th July (not sure what version to? Not sure how you see that?) so could be that too.

Gboard 10.7.05.377032818

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...