Jump to content

Missing android 10.4 update !!!


Recommended Posts

  • Level 5

It is a know issue issue that Android devices are unreliable with updates. They ship with too much bloatware from their producers. This makes updating it difficult, this is if there are any updates. Many Androids don’t get any, or only for a very brief period.

It seems something that is on your phone is blocking the update. So the PlayStore offers the last applicable release. 

Has nothing to do with EN.

Link to post
  • Level 5*
2 hours ago, grumpyg4 said:

Unacceptable for a paid software.

I understand your frustration, but what version of Android does your device run?  Evernote for Android v10 requires Android 10 for the moment - they're working on making it backwards compatible with earlier OS versions,  but I'd reckon that at least 50% of Android users are in the same position as you (including me!).  No upgrade available at present...

Link to post
1 hour ago, PinkElephant said:

It is a know issue issue that Android devices are unreliable with updates. They ship with too much bloatware from their producers. This makes updating it difficult, this is if there are any updates. Many Androids don’t get any, or only for a very brief period.

It seems something that is on your phone is blocking the update. So the PlayStore offers the last applicable release. 

Has nothing to do with EN.

Actually the people who offer apps on the play store can choose between different release strategies in different countries. Evernote seems to have chosen a staged release. Some will get the app slower. 

The other software on the device has nothing to do with this.

  • Like 1
Link to post
1 hour ago, PinkElephant said:

It is a know issue issue that Android devices are unreliable with updates. They ship with too much bloatware from their producers. This makes updating it difficult, this is if there are any updates. Many Androids don’t get any, or only for a very brief period.

It seems something that is on your phone is blocking the update. So the PlayStore offers the last applicable release. 

Has nothing to do with EN.

 

50 minutes ago, gazumped said:

I understand your frustration, but what version of Android does your device run?  Evernote for Android v10 requires Android 10 for the moment - they're working on making it backwards compatible with earlier OS versions,  but I'd reckon that at least 50% of Android users are in the same position as you (including me!).  No upgrade available at present...

@PinkElephant it is actually En's fault that they have decided to do this, they say they want evernote the same on all devices but they decide to leave out the under 10s. 

@gazumped and @grumpyg4 you can get v10 on under 10s if you go to apk mirror, however you have to install their own installer first but then you can download it from their site. it's worth a try.

  • Like 2
Link to post
  • Level 5

Well, sometimes a new release is not for older builds. On iOS you need to run 13.3 as a minimum as well, which was released late 2019.

The difference is that iPhones from 2015 regularly update to this, and even to iOS 14, whereas Android users won’t get updates that far backwards.

For me this is still related to the missing updates  of most Androids.

  • Confused 1
Link to post
  • Level 5*
2 hours ago, Rajesh Gaire said:

you can get v10 on under 10s if you go to apk mirror, however you have to install their own installer first but then you can download it from their site. it's worth a try.

I have an old (and increasingly cranky*) Samsung Note 4 - I mentioned somewhere else that I'm not an early adopter! My next upgrade option will be to a Note 21 I believe...

Samsung show no sign of bothering to update older models from Android 6 or 7 and in view of the above mentioned crankiness I'll wait until either I upgrade the phone or there's a backwards compatible Evernote version.  I suspect the performance of a shoe-horned cross-load might make both the current phone (and me) even more cranky,  as well as creating amusement for several Support teams...

I'm quite happy to miss out on the current 'excitement' of Version 10: the first 100 days...

* very like its owner...

  • Like 1
  • Haha 2
Link to post
17 hours ago, gazumped said:

I have an old (and increasingly cranky*) Samsung Note 4 - I mentioned somewhere else that I'm not an early adopter! My next upgrade option will be to a Note 21 I believe...

Samsung show no sign of bothering to update older models from Android 6 or 7 and in view of the above mentioned crankiness I'll wait until either I upgrade the phone or there's a backwards compatible Evernote version.  I suspect the performance of a shoe-horned cross-load might make both the current phone (and me) even more cranky,  as well as creating amusement for several Support teams...

I'm quite happy to miss out on the current 'excitement' of Version 10: the first 100 days...

* very like its owner...

I think it would be quite difficult for Evernote to get v10 running on Android before Android 6. Google has been making huge changes to Android for years now to try to get control of updates out of the OEMs' grasp. Now it's at the stage where there's no real need for users to update the base OS because a large amount of the security relevant components are updated automatically within minutes over the play store as soon as a fix is available. However earlier versions of Android had a much larger monolithic OS with things like webview and bluetooth stack baked in. 

It's possible that the problems Evernote has in offering v10 for Android 8+ have more to do with Electron than Android, but this is just wild speculation on my part because I've never used Electron and don't intend to start. If I wanted to write a cross-platform app, I'd use flutter, but 2 years ago, that wasn't an option.

  • Like 2
Link to post

Using Android 11 with latest security patch here, still no upgrade to Evernote 10 on my device yet. Still running older version. 

May be regional rollout ?

  • Confused 1
Link to post
  • Level 5

Probably so. When they pushed the first v10 for iOS, support got inundated very fast, and could not handle the tickets. Remember this was the very first v10.0, and it was really bad. Maybe they learned from this experience - although v10.4 is already pretty good.

Link to post
13 hours ago, ehrt74 said:

It's possible that the problems Evernote has in offering v10 for Android 8+ have more to do with Electron than Android, but this is just wild speculation on my part because I've never used Electron and don't intend to start. If I wanted to write a cross-platform app, I'd use flutter, but 2 years ago, that wasn't an option.

I doubt they are using Electron on mobile, probably something more like PhoneGap/Cordova, which is a mobile-first cross-platform framework that supports JS/HTML/CSS technologies. But yes, I imagine there is something in the framework and its dependencies that is causing them issues supporting Android pre-10. Hopefully to be figured out soon, because last I saw, >50% of Android users are using an OS older than 10.

  • Like 1
Link to post
  • 2 weeks later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...