Jump to content

MacOS Classic links no longer open Mac app?


Recommended Posts

I use the Evernote links in other applications to launch specific notes (i.e. Slack, Todoist, etc.)

It used to work where I could generate an Evernote classic link (using these instructions) and have the MacOS app launch. Now it's not launching the MacOS app.

Has anyone else run into this issue or found a way around this?

 

Classic link example: 

evernote:///view/{user id}/{shared id}/{note guid}/{client specific id}/{linked notebook guid}/

 

Things I've tried:

3420a58f5c65cd1fc0508d46153d75fc.png

1.) Copy "app link" option and paste in Slack. Slack doesn't launch the URL in the Evernote app (or anything). This used to work, but doesn't anymore.

2.) Copy "app link" option and paste into Todoist. When I click on the link, I get a Finder message (path obfuscated in the image), but the "Choose Application" leads to a greyed-out option for Evernote. So I can't actually open these links in Evernote. 

20d062e9702fec354472a5dbc03451ed.png

d6eed79bc4664b6bc0b4b42e3e8f7741.png

3.)  Copy "app link" option and paste into another Evernote note. This works from within another note.

3bb22dcff25e076957c1bdf9a9be38f0.png

 

 

Evernote Version:

10.6.9-mac-mas-public (458440)
Editor: v116.1.14913
Service: v1.26.7
© 2019 - 2021 Evernote Corporation. All rights reserved

Link to post

Maybe this is an issue w/Slack. I use App Links with Things every day and it's been working fine for me.

For the heck of it, I just tested out a couple of App Links from some other applications and had mixed results. Firefox, TextEdit and open CLI command produced the results you'd expect (bring Evernote to the front, switch to the note) but neither Teams nor Outlook seemed to know what to do with the link. Outlook at least brought Evernote to the front, but the corresponding note didn't come up.

Edit:  Outlook does work. What I described above occurred clicking the link while composing a message, but if I send a message with an App Link in it, Outlook handles it just fine. Apple Mail also handles App Links without issue.

Another Edit:  I tried using an App Link in Slack and it works just fine for me.

Link to post

I have exact the same problem. I use this links with Things 3 on an iMac in my office and I works fine without any problems. Yesterday I installed Evernote on a second iMac in my homeoffice and I get the same error message like you! I tried everything, also new installation, nothing works ....

(I run Big Sur on both iMacs, it’s not a problem of OS)

 

  • Sad 1
Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...