Jump to content

Windows 10 Legacy 6.25 EN has stopped Working


Go to solution Solved by Paddytc,

Recommended Posts

In the last couple of days, 6.25 has stopped working -- it won't sync, and it won't create new notes, including screen clips, which I rely on it to do.  It had been fine, even with the new 10 installed. I've tried running repair, reinstalling, restarting PC, all the troubleshooting things I can think of.

Makes me wonder if the latest EN 10.6.9 has changed something that is has messed up 6.25. Haven't tried uninstalling EN 10 yet, to see if makes a difference. If it has changed the database, or the parameters, then doing so wouldn't help.

To me, EN 10 is still a disappointment. Only good thing about it is that it does seem to sync without the troubles that EN 6 used sometimes have, and it doesn't hang like 6 often did. But it is still hamstrung in the important features that I've used most.

Link to post
  • Level 5*

Hi.  I'm running the previous public version (6.25.1) and have no issues (yet) - if you Ctrl-Click on the red "!" on the sync icon it may give you more information about any issues you have.  Otherwise:  have you reached or exceeded any account limits recently?

Link to post

Thanks, but Ctrl-click on the ! doesn't give any info -- just brings up a menu - Show Labels; Customize Toolbar; Restore Defaults.

But the Activity Log under Help shows errors:

00:15:45 [ERROR  ] [19524] [30908] Commit failed: code=00000302, CANT_INSERT_ATTRS_TABLE, error: "Can't save uid=9, error: database disk image is malformed (11)"
00:15:45 [INFO   ] [19524] [30908] 0% Cannot commit transaction "writeNotes", error: CANT_INSERT_ATTRS_TABLE (Can't save uid=9, error: database disk image is malformed (11))
00:15:45 [INFO   ] [19524] [30936] Client synchronization finished, status: failed
00:15:45 [INFO   ] [19524] [30936] * elapsed time: 0s

Seeing that "database disk image is malformed" I tried running ChkDsk /f , and restarted, but that didn't make any difference.

Does anyone know how to wipe out the database and re-download from cloud?

BTW, I found that EN is putting its files in strange places -- under Programs in AppData Local, under Apps in another version, and in Program Files x86 Evernote folder in another place -- confusing.

Link to post
  • Solution

Found the solution! -- From Tools/Options/General -- at bottom is a link to the database -- opened the folder, closed EN 6.25.1, deleted the EXB file, then restarted EN 6.25. It immediately started downloading the latest notes, and I expect will repopulate the database overnight.

  • Like 1
Link to post
  • 2 weeks later...

How do I get to Tools/Options/General to use this solution? My version of 6.25.1 won't open, period, so I can't get to Tools or anything else - it opens, tries to sync, and I get the "Evernote not responding" and that's it. Any help? 

Link to post
  • Level 5*
On 1/31/2021 at 7:39 PM, lori410 said:

How do I get to Tools/Options/General to use this solution? My version of 6.25.1 won't open, period, so I can't get to Tools or anything else - it opens, tries to sync, and I get the "Evernote not responding" and that's it. Any help? 

Hi.  How did you get into this state?  Are you a new user / did you update to v10 and are now winding back / have you tried the Legacy app / is Legacy or v10 still installed on your device??  Please give us more background here. 

Link to post

No, not a new user - I've been a premium user since 2011. The punch line is that a complete reinstall today fixed the problem, but I still don't know what happened in the first place. To answer the questions you ask, though, which I should have done from the start: I did update to v10 a few weeks ago, really disliked it, so uninstalled pretty promptly. Went back to 6.25, but it was that "legacy" version (6.25.2) that kept encouraging me to upgrade, so I uninstalled THAT and used my original 6.25.1 installation file, which was still sitting in my downloads folder. That was working just fine for a few weeks until this weekend, when it just ... stopped. Would not even open, just pretty quickly went to the Windows "not responding" message and I was stuck. I tried uninstalls/reinstalls, with no change, so today I manually deleted *everything) Evernote-related on my hard drive, the entire folder and subfolders, then did another uninstall of 6.25.1, and then another reinstall and so far, so good. 

No earthly idea why it crashed, but happy to have 6.25.1 back and (fingers crossed) working as normal. Appears that getting rid of the database plus all related files and forcing a full re-download may have been the key? 

  • Like 1
Link to post
  • Level 5*
7 minutes ago, lori410 said:

Appears that getting rid of the database plus all related files and forcing a full re-download may have been the key? 

Absolutely.  Like the pilots say - any crash you can walk away from...  ☺️

  • Haha 2
Link to post
On 2/1/2021 at 7:17 PM, gazumped said:

Absolutely.  Like the pilots say - any crash you can walk away from...  ☺️

Not quite fixed -- EN 6.25 works when reinstalled, after deleting the database, but all the Tags and Notebook names are missing, and customizations are missing too.

Then, separately, 10.7.6 stopped working, and upon reinstalling, each time there is an update, it forces an uninstall of 6.25.1.

So far, this whole revision of EN code has done nothing worthwhile for my use, except 10.7 doesn't hang as often as 6.25 and earlier did, but it has been a constant problem for my use.  I keep hoping that eventually they will bring out something new really useful, a la Roam or Obsidian, but there is no hint that is in the future.

If EN weren't so integral to my daily use, with over 60,000 notes to date, I would abandon it.

Right now I'd settle for the time being if I could customize the keyboard shortcuts, like can do in 6.25.

Link to post
  • Level 5*
13 hours ago, Paddytc said:

each time there is an update, it forces an uninstall of 6.25.1.

Replacing the previous public version (6.25.1) is baked into EN10.  If you intent to keep on using 10 you're better to go back to the Legacy version which will at least co-exist with v10.  No clue why you should have lost tags or notebook names though - is that in both the old and the new versions?

Evernote Legacy:  https://help.evernote.com/hc/en-us/articles/360052560314-Install-an-older-version-of-Evernote

Link to post

I had to delete not just the .exb, but .exb.* -- deleting just .exb resulted in the same issue you had, Paddytc - notebooks and tags gone even though notes restored. I had to wipe everything about Evernote off of my hard drive and then do a reinstall of 6.25.1 (not Legacy, which is 6.25.2, but original 6.25.1) in order to get back to normal working order. I agree, unhappy with recent Evernote changes. I tried OneNote once a few years ago and didn't like it, so I am hoping I can stay with 6.25.1 indefinitely - perhaps naive, but ... 

  • Like 1
Link to post

@gazumped"No clue why you should have lost tags or notebook names though - is that in both the old and the new versions? " No, it's just the 6.25 version where the tags and notebook names are missing. They are there in the 10 version. Thanks for the link, I'll check it out in detail.

@lori410 Thanks for the tip re .exb.* -- I'll try that.

I also have used CCleaner to try to wipe out all the 6.25 links in the Registry before trying reinstalling it. Haven't done the reinstall yet to see if that helps.

  • Like 1
Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...