Jump to content

V10 export is unreliable: missing titles


Recommended Posts

I discovered an export problem while testing Joplin import from a V10 ENEX notebook. All my notes were imported properly, except for some notes which missed a note title. To pinpoint the problem, I did a second import from a V6 ENEX from the same notebook. This time all titles were intact and the complete import was perfect (except for some complicated web clips).

Then to find the culprit, I exported with V10 one of the notes were the imported title was missing. A brief look in the enex file revealed that the title was really missing in the export! So it has nothing to do with Joplin...

I hope Evernote can fix the export problems and provide HTML export as well. When this seems to be impossible, I will switch to Joplin because I don't want to lock me in. Joplin's functionality is very close to my workflow (additional plus points : E2E encryption,  read-only mode, readable export format, fast search)

Link to comment
  • eric99 changed the title to V10 export is unreliable: missing titles
On 12/27/2020 at 7:51 PM, eric99 said:

I discovered an export problem while testing Joplin import from a V10 ENEX notebook. All my notes were imported properly, except for some notes which missed a note title. To pinpoint the problem, I did a second import from a V6 ENEX from the same notebook. This time all titles were intact and the complete import was perfect (except for some complicated web clips).

Then to find the culprit, I exported with V10 one of the notes were the imported title was missing. A brief look in the enex file revealed that the title was really missing in the export! So it has nothing to do with Joplin...

I hope Evernote can fix the export problems and provide HTML export as well. When this seems to be impossible, I will switch to Joplin because I don't want to lock me in. Joplin's functionality is very close to my workflow (additional plus points : E2E encryption,  read-only mode, readable export format, fast search)

I've read on the forum that the title is undefined in the export when there are comma's in the title https://discussion.evernote.com/forums/topic/132633-export-all-notes-in-html/?do=findComment&comment=600037

edit: i think also if the title contains a minus sign

 

Link to comment
  • 1 month later...
On 1/11/2021 at 12:01 PM, Peter Wouda said:

I have the same problem with ENEX export and comma's in the title. The minus-sign is exported, but the comma's are modified into "undefined".

Evernote version: 10.5.7

This export problem is still not solved in EN 10.8.4  !!!

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...