Jump to content

Images disappear/get deleted when I annotate them.


Recommended Posts

Hey guys,

I annotated some images in the newest update 10.5.7 (windows), after few days I noticed that those images are no more there in the note. This happened to all the images. I had to go to note history to find back my images and now I can't annotate anyone to not get them deleted.

Also, the mouse right click on an image to go to annotate option is not working. To annotate, I have to click on the edit symbol we see when we click on any image.

 

Link to post
1 hour ago, Abhijat Pandey said:

I annotated some images in the newest update 10.5.7 (windows), after few days I noticed that those images are no more there in the note. This happened to all the images. I had to go to note history to find back my images and now I can't annotate anyone to not get them deleted.

I've not noticed this behaviour. However when you merge notes containing images it looks like the merge has worked and then when you come back to the merged note some or all of the images are missing. It is possible that your observation is related.

1 hour ago, Abhijat Pandey said:

Also, the mouse right click on an image to go to annotate option is not working. To annotate, I have to click on the edit symbol we see when we click on any image.

I can reproduce this. Well spotted.

Link to post
On 12/24/2020 at 2:36 AM, Mike P said:

I've not noticed this behaviour. However when you merge notes containing images it looks like the merge has worked and then when you come back to the merged note some or all of the images are missing. It is possible that your observation is related.

I can reproduce this. Well spotted.

I feel that Evernote coders are fixing one thing and breaking another. I can see more than 10 things which were working well before and now have become a pain to use. But what can we do as users!

Link to post
  • 1 month later...

I just tried the same thing about a couple hours ago and all my annotated images have just disappeared!!!!

I am trying to be patient with all the new rollout bugs, but this has to be fixed.

  • Like 1
Link to post
11 hours ago, DPS188 said:

I just tried the same thing about a couple hours ago and all my annotated images have just disappeared!!!!

I am trying to be patient with all the new rollout bugs, but this has to be fixed.

Agreed. Surely if your users are experiencing data loss in a note keeping app you would cancel all non-essential work and focus all your effort on getting a fix out there as an emergency release. But this has been going on now for months such that I can no longer trust the safety of my images and attachments in Evernote.

Link to post
  • Evernote Staff*

@DPS188Thanks for this report.

We believe this issue is fixed in our current release. I see that you're running our previous version 10.5.7. Please install our latest update from this link: https://evernote.com/download/  After updating check the note history for the missing images.

Please let us know if you see any other issues after updating to 10.7 

Thanks

Link to post
1 hour ago, Austin G said:

@DPS188Thanks for this report.

We believe this issue is fixed in our current release. I see that you're running our previous version 10.5.7. Please install our latest update from this link: https://evernote.com/download/  After updating check the note history for the missing images.

Please let us know if you see any other issues after updating to 10.7 

Thanks

This is definitely still happening in 10.7.6 but for me at least, it is limited to screen shots obtained using the webclipper. Edit the screen shot and then click onto a different note. When you go back to the note the image (and the picture in snippet view)  have gone,. For me it happens every time.

Interestingly if I do the same on the web version (10.8.6) it doesn't save the edits and I get an error message saying "something went wrong when adding your attachment..." but at least my image doesn't get deleted so a good example of fail-safe.

  • Like 2
Link to post
9 hours ago, Austin G said:

@DPS188Thanks for this report.

We believe this issue is fixed in our current release. I see that you're running our previous version 10.5.7. Please install our latest update from this link: https://evernote.com/download/  After updating check the note history for the missing images.

Please let us know if you see any other issues after updating to 10.7 

Thanks

Annotate option doesn't open up after mouse right click on image and selecting annotate. Issue persists  in 10.7 also. Images do get deleted still.

Link to post

@Austin GI've now repeated the sequence of events described above in the desktop version of 10.8.4 The image is still deleted. Can you replicate the issue? Also if you merge bookmarks obtained from the webclipper you also loose one or more of the images

More details here:

The workaround is to restore from history and then the image behaves correctly

Link to post

In version 10.7.6 screenshot + annotation will be deleted.

14 hours ago, Mike P said:

This is definitely still happening in 10.7.6 but for me at least, it is limited to screen shots obtained using the webclipper. Edit the screen shot and then click onto a different note. When you go back to the note the image (and the picture in snippet view)  have gone,. For me it happens every time.

Interestingly if I do the same on the web version (10.8.6) it doesn't save the edits and I get an error message saying "something went wrong when adding your attachment..." but at least my image doesn't get deleted so a good example of fail-safe.

When I make a screenshot with the Web Clipper and duplicate the imported note... the duplicated note has no screenshot... only text.
When screenshot in original note is annotated the screenshot disappears and cannot be found anywhere. 

Tested in version 10.7.6 / Windows 10

Link to post
17 minutes ago, ArjenC said:

When screenshot in original note is annotated the screenshot disappears and cannot be found anywhere. 

As I explained above, if you go to the note history you can restore the original note with the image and this time it appears to be possible to annotate the image without loosing it.

Link to post
13 minutes ago, Mike P said:

As I explained above, if you go to the note history you can restore the original note with the image and this time it appears to be possible to annotate the image without loosing it.

There is something really strange with screenshot webclipper... I'm no beta tester but:

 

1- make screenshot with web clipper to new note
2- export new note to local disk
3 - import local note into Evernote

-> Result: No image in import note

I assume there is some information missing, when export file is opened in text editor and source-url information is used, the file exists on Evernote server.
After edit the source-url is deleted.

Hope this helps Evernote Dev's? I can give my approach and file if necessary for analyses. But with some simple testing everyone can produce this result. 

Link to post
2 hours ago, ArjenC said:

> Result: No image in import note

I can repeat this. It is yet another way of removing the image from the note together with things like annotating it or copying it to another notebook. The interesting thing is the size of the note (from note information or the size of the exported file) certainly makes it look as though the image is embedded in it. Opening the enex file in a note editor also suggests the image is there. 

Link to post
16 minutes ago, Mike P said:

I can repeat this. It is yet another way of removing the image from the note together with things like annotating it or copying it to another notebook. The interesting thing is the size of the note (from note information or the size of the exported file) certainly makes it look as though the image is embedded in it. Opening the enex file in a note editor also suggests the image is there. 

Issue seems to be in the file-name tag. When you copy the source-url address https://www.evernote.com/shard/***** then a file is with screenshot is downloaded. When you place this filename in the file-name tag and import the enex file it works fine...

Think dev's should look at this 

  • Like 1
Link to post

additional info: when exported file is adjusted, filename is added in enex file, and imported. Annotation also works fine... think this solves the issue with disappearing screenshots. 

But exporting, adjusting, importing is not a nice work around 💀

Link to post
2 minutes ago, ArjenC said:

But exporting, adjusting, importing is not a nice work around 💀

Agreed! My workaround of retrieving the original note from history after the image has disappeared is also not exactly convenient! I have no idea why retrieving it from history should make it anotatable.

Link to post
  • 2 weeks later...

@Jay-Bob I had an auto update to 10.8.5 this morning. I have annotated an image obtained from clipping a screen shot in the webclipper. The good news is that so far the image has not disappeared. The bad news is that merging two notes with screen shots or two notes with bookmarks still deletes one of the images. So here is the example of merging two bookmarks. Initially I get:

image.thumb.png.4ac8af00be7d8f46b6828c930cc09709.png

And then when I leave the note and come back the first image has gone:

image.thumb.png.1c73281dc5a70b0d2910fd79805b7038.png

  • Like 1
  • Thanks 1
Link to post

Yes I am experiencing the same as @Mike P

I have an open ticked relating to loss of images when merging notes. With 10.8.5 I only lose the image from the first merged note - so some improvement !

I have now retried this with two and 3 notes - in each case, just the first note/image was lost.

While doing some other testing, I found that if you merge notes and try to re-merge the merged notes, this gives an error message and fails.

I.E. merge notes A & B = NoteAB
merge noted C & D = NoteCD
Try to merge NoteAB and NoteCD and it will fail, with an error message.

Reported this as a possible bug, but was told it was a feature not yet implemented in the latest version (but suspect this was a cut 'n' paste, go-away answer).

Don't understand why this should happen, as a I would have thought a merged note is just a another note.

 

  • Like 1
  • Thanks 1
Link to post
  • 3 weeks later...

Update following release of 10.9.10 : The merged note is still losing all the images, however, the original notes are not being moved to trash when you do the merge. I suppose this counts as some improvement.

 

  • Like 1
Link to post
On 3/11/2021 at 10:21 AM, FrankC said:

the original notes are not being moved to trash when you do the merge.

That's always been an option in the "advanced options" drop down.

I still can't believe that a bug, which deletes users data, is not being addressed with more urgency. For me it's a "cancel all shore leave and don't work on anything else until it is fixed" kind of issue!

  • Like 1
Link to post
3 hours ago, Mike P said:

That's always been an option in the "advanced options" drop down.

I still can't believe that a bug, which deletes users data, is not being addressed with more urgency. For me it's a "cancel all shore leave and don't work on anything else until it is fixed" kind of issue!

I never used that option - so guess the default has changed.

Agree with the seriousness of this. Still 2 major issues/bugs for me (and of course lots of additional ones for others) preventing me using it. While its nice to have new features, I would have thought that basic functions would be a priority.

I am also not that encouraged by the beta process so far. Having now been involved in 3 recent ones, I have seen very few of the suggestions taken up. Yes - if something doesn't work the way EN intended because of a bug - they may address that. However, most of the improvements or alternative options or suggestions don't seem to have made it in to the released version. Because of this,  I don't spend too much time on detailed evaluation for the "beta" testing, just check the major options.

  • Like 1
Link to post
  • 1 month later...

The merging notes problem finally seems to have been fixed in V10.11.5

This means that two major bugs preventing me from using V10 have finally been fixed (this one + the incomplete indexing of prior-to-v10 text in images) .

I will now try to use V10 more - to see if any other showstoppers remain.

  • Like 1
  • Thanks 1
Link to post
  • 2 weeks later...

Just to keep this up-to date as of V10.12.4

(1) The main merged notes problem has been fixed, and images are no longer lost. As documented by agsteele, there is still a problem where 1 of the notes contains only a HTML container. This will be lost in the merge. Workaround is to add some random text in the html note.

(2) The incomplete indexing problem remains. I was misled in checking this because it was picking up some of my test notes. However, the original problem remains. (OCR indexes for pre-V10 created notes are incomplete I.E. not migrated properly - so some notes are missed in searches).

 

 

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...