Jump to content

No thumbnail on scanned images and no OCR


Recommended Posts

Since upgrading to the new Android app, when I can documents, although I can see the image when I open the note there is no thumbnail in the note list - just the grey document icon with the turned over corner.

In addition, OCR doesn't seem to be running on these scanned documents. I've tried to search for terms found in a number of scanned letters but the relevant notes are not behind returned

  • Like 2
Link to comment
  • 1 month later...
  • Level 5

When did you try the search ?

Picture OCR is done on the EN server,. My experience is that often it is done within a few minutes,  it on other das it may take several hours. Probably there is a queue in front of the processing unit that does the OCR. 

If search does not turn up hits, try again the next day. If it is still not indexed, I would issue a support ticket.

Link to comment

I have found that some documents which were OCR'd/Indexed by the legacy version are not fully OCR'd/Indexed by the latest version. This results in different search results between the two versions. I tracked this down by doing various searches and seeing what notes were returned by the same search on each version.
Doesn't make complete sense to me, as I would have thought both versions would be "looking" at the same index. The notes causing the discrepancy in my tests were not recent ones.

Support ticket raised recently, so am awaiting a response.

 

  • Like 1
Link to comment
On 2/9/2021 at 4:16 PM, PinkElephant said:

When did you try the search ?

Picture OCR is done on the EN server,. My experience is that often it is done within a few minutes,  it on other das it may take several hours. Probably there is a queue in front of the processing unit that does the OCR. 

Then the EN servers are busted or *****.  I have tried the search repeatedly - right away, after a few hours, next day, a week later.  Still nothing.  The majority of the images (documents/receipts) I scan are not properly converted into thumbnails, EXACTLY as the OP described, just a generic document icon.  These are the images that do not show up in a search.  Occasionally, and I have no idea why, the thumbnail is correctly created/displayed and for those images, they do show up in search results as they should.

  • Like 2
Link to comment
  • 1 month later...
59 minutes ago, PinkElephant said:

Yet tried a support ticket on this ?

No less than 3 tickets.  Fragmented responses via email.  Completely ineffective.  Evernote is a service - you pay a subscription fee and are supposed to get the advertised features.  When what you pay for doesn't work, you should be able to reach someone that can resolve the issue.  That's service.  That's NOT what Evernote is currently providing.  An unfortunate trend in the tech industry.

What would be nice, is an acknowledgement, reply from Evernote staff in the forums, in this thread, that this is a known issue that will be resolved.

In the meantime, with limited help via chat, Evernote did provide the link to download the old version of Evernote for Android. 

http://evernote.s3.amazonaws.com/android/google-play/com.evernote.google-play.8.13.3.1083330.allArch.6087.apk

I uninstalled the new version and re-installed the old version.  I am once again able to scan documents via my Android device, they are properly displayed as thumbnails in the notebook view, and are properly indexed via OCR and displayed among relevant search results.

Not sure why if it worked for a decade in the old app, that it's so difficult to program it to work correctly in the new version.

  • Like 1
Link to comment
  • Level 5

Without meaning this excuses non working software: EN v10 is completely new, no code from the old apps was reused, since everything is now coded in JavaScript. Plus the new clients run inside of a framework - think of it as a browser without user interface.

Currently they struggle with the Android app. iOS was quite a mess initially, but since 10.5 most of the toothing seems behind us. Android is more complex, many makers, diverse OS releases, no update policy etc. 

 Hope the old app does the job you need done. On iOS there was no way back, courtesy of the AppStore policy by Apple. So we went through it, somehow.

Link to comment
  • 4 weeks later...

UPDATE: Google Keep kicks butt all over EN for OCR of hand-printed notes. It is instantly indexed, and instantly searchable. But, it's Google Keep, and not Evernote. 😕

UPDATE: Image captured with Microsoft Office Lens (Android) then shared to EN was indexed successfully. As a bonus, the image was processed as a document should be. This is an acceptable workaround for now, but shouldn't EN's own document scanning workflow accomplish this?

UPDATE: The image which I attached to a new Note was indexed and can be found via search. None of the other approaches worked.

I have been experiencing no indexing in images of neatly written notes for the last several weeks. I have tried various approaches with no luck (EN Scan Document, Send image with Share Sheet on Android, and attach image to new Note.) No luck with Support Chat, but haven't yet opened a support ticket.

Link to comment

I am experiencing the same issue with Evernote 10.7.2. Images captured by Evernote for Android 10.7.2 have no thumbnail in note list (all platforms then). Also the images are not indexed... (that is what Evernote legacy says in note info!). Therefore I cannot search them even if they were perfectly readable. So mainly capturing is useless now with Evernote for Android. I also wonder if the indexing will at some point in time catch up for all images taken with EN Android 10.xx or if they will be lost for search forever. In any case: I raised a ticket today.

  • Thanks 1
Link to comment

Update: Technical support acknowledged this to me to be a known issue they are (hopefully) working on.
Just got 10.8.2, no change: All images captured via Android App are not indexed, most also do not get a thumbnail picture.

  • Thanks 1
Link to comment

I did some testing and can confirm, that images, that are cut and pasted afterwards (within another client but not Android) are running through indexing and can be searched afterwards... this runs almost instantly then. So hard to see, the bug is not eliminated by the developers since months.

I again asked support, if images finally will be queued and indexed afterwards, as soon, as the bug has been resolved... I got a cryptic answer which should say yes but felt like ... well , not really... keep fingers crossed. 

Link to comment

Just to confirm: with Evernote for Android 10.9 the problem is still persisting. Images/documents taken via the Evernote app are not indexed and never show a thumbnail in notes list (all Evernote 10 clients). This is a real deal breaker since capturing text and searching for it is one of the formerly strong features of Evernote. Since Evernote 10: gone...

Link to comment
  • Level 5

Have you already issued a support ticket on this ?

If yes, it would be nice to inform your fellow users about the outcome.

P.S. No problem with the iOS mobile client.

Link to comment
10 minutes ago, PinkElephant said:

Have you already issued a support ticket on this ?

If yes, it would be nice to inform your fellow users about the outcome.

P.S. No problem with the iOS mobile client.

Yes, I explained my two tickets and outcome in the four postings before yours.

Link to comment
  • 2 weeks later...

I wanted to do an update here. It seems the issue is really caused by the app not the cloud service. As of today still no picture taken via Evernote capturing tool (EN 10.X) is indexed later nor do you get thumbnails in the note list for these. I have been monitoring this for weeks now. Sadly it is still not addressed by Evernote appropriately although a number one feature (searchable capturing of content). Since the number of notes in my account with non-searchable content is constantly rising I had to switch back to EN 8.13.3 which does the indexing process fine.

Maybe this is of interest for other users wondering why they cannot find their content from images: You can verify the image indexing status on each note easily in EN legacy for desktop via note information.

Link to comment
  • 4 weeks later...

Do you still see this problem?

A couple days ago I could still reproduce this bug: if I took a picture as a picture, it was indexed and showed a thumbnail. If I "scanned" it as a document it wasn't indexed and only showed the grey, generic icon. So I opened a support ticket and a few days later I was asked to produce a screen-recording to show this. When I tried to do this, it didn't happen any more.

"Scanned documents" now also get a thumbnail of the image and get indexed on my device. Maybe it was a server-problem, and it was solved just in the meantime?

 

(By the way: I had a few old notes that I had were this didn't happen. These did not update. I re-created the notes and dragged the images over. They stayed gray and non-indexed. So I modified the pictures slightly (minimal cropping) and put them into new notes. That did the trick and they were then also processed correctly.)

Link to comment

I did some testing with EN 10.11. To me the problem persists: Pictures taken as "scan" or "image" via EN get indexed afterwards (note info in EN legacy for windows says that). But: Pictures taken as "photo" still do not get a thumbnail (grey icon).

Summary:

Picture taken with EN10.11 as "photo": indexed but no thumbnail (grey icon)

Picture taken with EN 10.11 as "document": indexed AND thumbnail!

Obviously EN solved the indexing problem, but there is still something going on regarding thumbnails.

  • Thanks 1
Link to comment
  • 2 weeks later...

It seems more complicated than that: I thought this was solved (at least for me), but sometimes the error still comes up with Evernote 10.11.

If I encounter it, it is still both the grey generic icon AND missing indexing of the image content. 

I was able to screen record the bug now and shared that with the support. I hope they are able to locate the bug sooner or later.

 

  • Thanks 1
Link to comment
On 6/9/2021 at 1:18 PM, Alxa said:

I did some testing with EN 10.11. To me the problem persists: Pictures taken as "scan" or "image" via EN get indexed afterwards (note info in EN legacy for windows says that). But: Pictures taken as "photo" still do not get a thumbnail (grey icon).

Summary:

Picture taken with EN10.11 as "photo": indexed but no thumbnail (grey icon)

Picture taken with EN 10.11 as "document": indexed AND thumbnail!

Obviously EN solved the indexing problem, but there is still something going on regarding thumbnails.

Thank you, Alxa. I'll have to try this to see if that's why some of my camera notes don't display an index image. This seemingly inconsistent behavior where some notes display index images and some don't has been driving me nuts.

  • Like 1
Link to comment

Just an update from my side: with 10.12 Evernote seems to have reintroduced the old bugs. With 10.11 at least indexing worked in any case. Now with 10.12 it is unpredictable again if an image taken via the Evernote app is indexed afterwards. I have taken around 20 images in 5-6 notes in "scan" mode. None of them were indexed. In contrast images taken as "photo" are indexed normally. That was a hard landing for me again.... since it renders Evernote unusable again when handling with documents 😞 Bug tracking / working seems out of control of Evernote staff regarding the Android app... There is no "getting ever better" (Ian) without doing your basic homework first!

I reopened a follow-up ticket to hopefully get some updates on this. My initial ticket was with EN 10.7.2...

  • Like 1
Link to comment

Meanwhile I figured out a workaround, since I remembered (from the forums here) that Evernote mobile saves all "scanned" documents wrong as *.jpg although they are *.png files. Go to desktop, save each image with the correct file ending *.png to desktop and save them back to a (important!) new note. You get the same quality document and the files are indexed fine afterwards. Lots of work but maybe important if you need index on special documents. So the technical problem behind the non-indexing is very simple: file format does not match file ending and therefore indexing engine probably skips the files as defective. That being said, I have no understanding why Evernote staff do not simply correct it by letting the app save the files with the correct ending... maybe too small to fix in 6+ months.

Link to comment
  • Level 5

Have you send this to support yet ?

I can’t, don’t use Android.

Edit: Just tried it with iOS. Scanned something using the scanner build into the client. It created a new note with that picture, saved in document mode ( cutting away surrounding area, perspective and exposure correction etc.) in a new note. Waited 20 minutes, then searched a word that appeared in the text in the picture.

The note with the picture was perfectly found - I assume from this test this issue with the picture extension is not relevant for the iOS client.

Link to comment
49 minutes ago, PinkElephant said:

Have you send this to support yet ?

I have just opened a brand new ticket via the app explaining exactly and in detail what seems to be the reason why indexing on "scanned documents" fails on Android. Hopefully they will direct it to development.

  • Thanks 1
Link to comment

I got response from support. The staff member refuses to even read my ticket's description neither understands a word I wrote. Instead she constantly wants me to send screen recordings. It is ridiculous, I gave up on this. The whole product is managed too bad. If anyone of EN reads this: ticket number 3337443. Thanks

  • Like 1
Link to comment

I got response from support to my old follow up ticket - not the above one. The technical support told me, they made "some strides" but are still on development and had a hard time on figuring out the problem. The can not say, when indexing and thumbnails will work normally. I can hardly believe that, since in the meantime they kicked new stuff in the app permanently. They obviously have no time to even fix bugs affecting basic all time functionality like indexing for search. At this point the EN 10 for Android app is evolving slower than the Android eco system itself. Therefore EN10 will probably never reach a speedy and productive state as we knew before at all. It is something caused by design, bad management with focus on shiny features only. No priority on core stability or any usability at all. Every other professional app with a paid subscription on Android I know is built and evolved on a stable core code. Stability and bug fixing first, than adding features. These apps work well, no matter which Android device or version you use. Evernote does it the other way round, adding and adding features, nice looking? yes, working? Seems to does not matter.... an unhealthy and - for me - since 7 months failing path. Blaming the Android eco system here after 7 months of EN10 in the wild is distracting from management mistakes EN made and still mades. They could do better, if someone decides to...let's see, how long we have to wait for this decision.

Rolled back all devices to 8.13.3.

  • Like 1
Link to comment
  • 3 weeks later...

Update 10.13.2:

Did some testing. New version and 3 weeks later - issues still not resolved. Images taken as "documents" via the Evernote App are not indexed afterwards and will never be searchable.

I had to somewhat laugh when I saw introduction of boolean search whilst EN not being able to get core indexing of snapped image to live on Android. Who needs a better search if there is nothing to search for. By the way: as this is known since months EN should consider changing their advertising (on OCR) at playstore to not gather additional desillusionated users as me.

Link to comment
  • 2 weeks later...

Update 10.14: I just tested the "document" scanning with a bunch of papers, combinations, with rotation, without, one paper, multiple and so on. It seems that indexing as well as thumbnailing of scanned "documents" now works as expected. Thank you, Evernote! I will monitor if the bug returns inlater versions 😉

Can anyone confirm it is resolved as well on another device so this thread could be marked as solved?

Link to comment
36 minutes ago, Alxa said:

Can anyone confirm it is resolved as well on another device so this thread could be marked as solved?

I will do some testing today on my Pixel 5 and report back. Thank you. 

Link to comment
On 8/2/2021 at 12:30 PM, Alxa said:

Update 10.14: I just tested the "document" scanning with a bunch of papers, combinations, with rotation, without, one paper, multiple and so on. It seems that indexing as well as thumbnailing of scanned "documents" now works as expected. Thank you, Evernote! I will monitor if the bug returns inlater versions 😉

Can anyone confirm it is resolved as well on another device so this thread could be marked as solved?

No joy for me. Document scans attempted from Evernote Android 10.12.1 (3115308). Attempted to view on Evernote Macintosh 10.18.3-mac-mas-public (458749). 

No thumbnails and no indexing for the scans. @AlxaWhat was your configuration?

Link to comment
  • Level 5

Both are server based services. AFAIK there is no way to influence it from the client side (apart from fulfilling the requirements documented in the help papers, like picture = jpg, png or gif).

If in doubt ask support.

Link to comment
21 minutes ago, pgsvensk said:

No joy for me. Document scans attempted from Evernote Android 10.12.1 (3115308). Attempted to view on Evernote Macintosh 10.18.3-mac-mas-public (458749). 

No thumbnails and no indexing for the scans. @AlxaWhat was your configuration?

I used EN Android 10.14. Prior versions were buggy. Please try to update.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...