Jump to content

password recovery doesn't work


Recommended Posts

Dear Evernote Team,

The password recovery doesn't work. I've got a @gmail.com account which is the email I used to signup an evernote account back in 2013.
After updating to the new version of evernote on my computer I was asked to login. SInce I couldn't remember my password, I clicked "forgot password" and asked for a reset. The email didn't reach me. I've tried maybe ~20 times since then, trying both my email and my account name (tkoomzaaskz) and no email has reached my gmail inbox. I also checked spam. Nothing came.

There's something stuck with password recovery. Please let me know what can I do in order to get my account under control again. It's urgent.
PS the email I'm writing from is just a temporary account I used in order to reach any help whatsoever - you need to be logged in to ask for any help. It's extremely user unfriendly...

Thank you very much for any help.

Edited by tkoomzaaskz_another
  • Like 2
Link to comment

Dear Evernote Team, I'm having the same problem and need help. Updated to the newer version and couldn't remember password, so tried to reset, but didn't get any mail. Tried lots of times. Please help to log in to my usual account konnovagalya. Thank you in advance.

UPD: my problem is solved, got my password recovery mail after an hour and a half.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...